Partitioning flash drive failed, doesn't show up anymore

By hellokitty[hk]
Apr 14, 2009
  1. I tried to partition my OCZ rally2 16gb into a NFTS and a fat32 using Acronis disk director.

    It started off as a 14.9gb NFTS (I don't have anything important on it and I RARed all data to my computer prior, so i'm safe to format it) before I tried to split a 1.25 gb chunk off. I got about 10% through before I got an "invalid format error" as shown in my logs. I retried a couple times, then skiped hoping it would still work. I got more errors and just canceled it after the first four.

    Acronis showed it as two partitions, but the sizes were not as they should have been if the operation finished successfully. HPUSB format utility showed the drive as a single full sized drive. The original 14.9gb drive showed up, but said 0 bytes free, 0 bytes used and 0 bytes total. I did not check the contents, but the custom icon was still there so I assume my data was fine.

    I reemerged the partitions successfully and both Acronis and HPUSB format show it as a single 14.9gb drive, with the correct amount of free space. The only problem is I can not see it on my computer. I rebooted and changed the name with acronis, but it still doesn't show. It shows up under device manager as a USB storage device. I've run the USB drive cleaner already, still not showing up.

    I can still boot off my flash drive though, so I think it is still fine.

    UPDATE: Pluged the drive in to another computer. shows up perfectly, so I flip the removable media bit ocz rally2 16gb, and poof, shows up again on my original computer as a local disk.
    Thanks everyone for reading :D.
    Partitioned with Acronis successfully this time.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...