1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

PC cannot turn on

By ewq108 ยท 12 replies
Dec 1, 2008
  1. My PC'd shutdown suddenly when i was playing game yesterday .
    And I can't turn on the Computer anymore ...

    I've checked the power supply with paperclip and a fan , it's okay .
    I tried to turn it on by point the pen on the mainboard ... i see the Asus Mainboard Screen , after few second ... it turn off .

    Afterthat , i remove the CPU chip , CPU fan . VGA + fan + hdd + ram is still on the mainboard . Turn on and it run smoothly ( i mean the fans of them ) very long .

    And now , i connect all of them together again( power supply , mainboard , ram , vga , cpu ) . The Green Led is light , but i can't turn on the Computer anymore .

    Some one help me :( .
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Replace that power supply first. Just because you can get it to run sometimes, doesn't mean it is not the cause of your trouble. It is cheaper to replace the PS, than it is to replace the motherboard
  3. ewq108

    ewq108 TS Rookie Topic Starter

    I've changed the Power Supply . I can turn on but after 4-5s ( I can see the boot screen ) , it turn off again ..
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Ok after all you have done, it is time to replace the motherboard
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Bench testing a board out of a previously working computer that has been working for years is not really necessary is it Kimsland? It is a hardware failure, not a mounting or wiring error, like a new build. This failure reminds me of a classic eMachine failure... Power supply, then motherboard. I have had several Asus motherboards just quit working right in the middel of doing something. Never to work again
  7. basupartha2003

    basupartha2003 TS Rookie

    have u tried removing all the connections from smps like hdd, cd/dvd power cable and other connections like hdd, cd/dvd signal cable. if the system starts up after disconnecting them, the problem is surely with one of them not motherboard. now connect them back one by one to detect the faulty component.
  8. clickit

    clickit TS Rookie

    Tmagic650 I am having a problem something similar to ewq108. I am working on an Insignia D300a with the following:

    2.8 GHz pentium 4
    60GB hard drive
    512 MB SDRAM

    It will not power up. First thing I looked at was the PSU. The mobo seems to get power because the light is lit on board. When I hit the power button...nothing. I have tried switching out 2 different psu's that I know work. Nothing. I unplugged the hard drive and the cd rom. Tried to fire it up...nothing. I tried searching for the manual for the mobo but could not find anything. Insignia has discontinued this particular model. Please advise.
  9. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    All that green LED means is that one of the 5 or so voltages from the power supply is working. The green LED may be +5 volts. You could be missing + or - 12 volts, + or - 3 volts, and -5 volts. Voltages from the power supply are regulated by components on the motherboard, so the motherboard is suspect after you change the power supply first. In my experience, motherboards fail more than power supplies do. What make is your power supply?
  10. clickit

    clickit TS Rookie

    Let's see...the power supply is a Hipro Model # P3037F5. Looks like it's 230W max. Also, I read one of the post above and checked out the No post tutorial. Very helpful. I tried one of the suggestions which was to reset the CMOS. I followed the instrucitons and I am now able to fire up the pc. I wonder what happened for it to get to this point in the first place?
  11. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    That's good news, and thanks for the update
    But this thread is for member ewq108's issues with not posting, new members are advised to create their own thread. Thanks for the feedback too.

    There are many possibilities of why CMOS settings can corrupt, the most likely being power disruption, consider replacing the CMOS battery
  12. ewq108

    ewq108 TS Rookie Topic Starter

    Thanks everyone :p .
    The problem've solved .
    Replace PSU . Remove all devices .
    Clear CMOS , Clean CPU's Fan .
    It's ok now , cost me 3 days .
  13. King Ping

    King Ping TS Rookie

    Hmm it might be the graphics card fan becuase with mme it got clogged up with dust and it gave in and well the system wont show anything without a functional graphics card
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...