PC randomly loses connectivity

I got a new PC 5 days ago, installed clean Windows from Microsoft's site and activated them, updated all the drivers and made sure everything is ok.

On Friday between 2-4 PM (GMT +2) my PC started randomly disconnecting from the Internet every 15 minutes only to reconnect itself. During that Netflix was streaming on my TV but I don't think that's the issue.

On Saturday everything was fine until I was unable to load any pages for a solid 2 minutes after which my PC froze for a second and then everything was fine and I had no Internet issues.

On Sunday, yesterday my brother started playing an online game on the PS4 which made my connection slow (3-7Mbit instead of 30) so I called my operator and they fixed it temporarily.

Today my PC started disconnecting again between 2-4 PM every 15 minutes just like on Friday only to reconnect itself. And it's disconnected 3 times since 8 PM.

I've booted up my old PC plugged in my Wireless Adapter and everything was fine on it. I've noticed that every device in my home including my old PC runs at 27-30Mbit while my new PC is at 18-24Mbit.

So far I tried, restarting my PC, restarting the router, plugging the adapter into a different socket and reinstalling the driver and nothing worked.

The thing is, a month ago I ordered a new PC from some shitty company and it had hardware errors. Long story short they send me another PC which didn't work so I got a refund. I was dealing with them for a month and I really don't want to send this PC back as I only noticed connectivity issues and nothing wrong with the software/hardware. Honestly, I'm spent in the head from sending the other PC back and worth and I've wasted a month of my life. This one has been ordered from a company from which I had no issues for 2 years so I doubt it's the PC.

Is this an ISP error and should I give them another call or is something else the matter?