PNY 32gb USB appearing as a CD ROM

I'm using Windows 7
I tried all things on multiple computers

So I bought a 32gb PNY flash drive and well after the warranty expired took it on campus to put a program called SAS on it so that I could transfer it to my home PC. The file was huge and completed. When I plugged the USB into my home PC it worked as a USB, said it was 22gb full, but when I opened the file it nothing was there. I tried everything to fix this, first I hit tools and folder options then tried viewing every file type. That revealed a folder called 'Found' but in the folder was a bunch of jargon I did not understand. So then I decided ok whatever I don't care about anything on the drive I will format it! Formatting it took like 5 seconds which seemed extremely fast considering it took about an hour to get the files onto the drive. So suspiciously I tried to put files onto the drive. After adding the files the names appeared in smears and messed up words or something, they were not normal letters and not another language. So I decided to format it again and this was when the BIG issues started.. Now every time I plug in my USB to any computer it does not come up as a USB. When I try to open it I get the message "Please insert a disk into New Drive (E: )". If I go into computer management/disk management, the usb appears to be showing up as a disk.. it is not in the top list it is in the larger list on the bottom named: Disk 1 Removable (E: ) No Media.

I don't know what to do!! please help, I would like to get my USB back:)
  • Thread Starter Thread Starter
  • #4
I downloaded the tool but cannot select the drive. When I plug it in it does not come up as a drive or anything at all anymore.


Posts: 19   +5
If it is not already detected when you plug it to your PC then it's probably defective and unusable anymore.
  • Thread Starter Thread Starter
  • #6
Okay so now the USB comes up as a "Removable Disk (E: )" and when I click to open it it says "Please insert a disk into Removable Disk (E: )." The PNY Ufix-II software does not pick up the drive.