Primary hard drive boots in laptop but isn't recognized when used as external drive


I have a Dell Inspiron 1520 laptop. I have an image of the entire hard drive that I created when I first got the computer (using Acronis TrueImage), and I'd like to restore that image, returning the laptop back to that fresh, clean original state. I've done this two or three times before and it worked great each time.

But now there's a problem. Normally I would connect to the laptop a USB storage/backup drive that has the disk image, boot the laptop from a Rescue Media CD created by Acronis, then restore that disk image from the back-up drive onto the laptop's HDD.

When I tried it this time round, the laptop's HDD was not listed in TrueImage at all. I created a new rescue media disk, tried it again, and got the same result.

I then took the HDD out of the laptop, connected it to an adapter kit that let's you power up and plug in the drive via a USB port and external power supply, and tried the same procedure using my desktop to run the operation. Same result. The drive was not detected by Acronis.

The drive does not seem to spin up at all when it is connected.

** Keep in mind the drive still works when installed in the laptop -- it boots into Windows XP etc. **

When I plug the drive into my desktop, the drive does not show up in Disk Management (Start | Right-click My Computer | Manage | Disk Management). It doesn't show up in either of the two right-side windows. (so there's no way I know of to format it or do any work on it in Windows)

When I go to Device Manager | Disk Drives, I see "USB Device" for that drive, and under Properties it is listed as "Disk Drives" for "Device Type" and its status says it is working properly.

So what I don't get is, it works fine when it is in the laptop (boots into XP, etc.), but when connected as an external drive or when the laptop is being run off of CD, the drive can't be detected... and not on just one computer, but multiple.

Is it junk?

Any ideas?


Total junk answer. I have a Dell XPS 18 and used Acronis True Image 2015 to backup the system to USB flash drive (128 GB PNY). I backed up the entire partitions (all of them) on the main Dell 500 GB boot drive.

Then I had to upgrade to Windows 8.1 from Windows 8.0 and now the system when booted to the CD drive (bootable CD media created in Windows and how I backed up the system the first time) WILL NOT recognize the Dell 500 GB boot drive or the 32 GB SSD drive. It says 'unsupported drive'.

All just from upgrading from Windows 8.0 to Windows 8.1 so that I can take advantage of the upcoming free upgrade to Windows 10!!

I hate Windows and I hate Acronis. They are both boneheads! Simply no excuse why this should be happening and totally making it impossible for me to restore my Windows 8.0 backup--which the Acronis bootable CD will not recognize the Dell boot drive for a restore either!!

So I can't backup Windows 8.1 or restore Windows 8.0. Talk about screwed.

The only good thing? Windows 8.1 is still booting normally from UEFI and no errors after the upgrade.

Paragon seems to be able to do a backup using WINPE environment. But haven't tested a restore yet.


connected it to an adapter kit that let's you power up and plug in the drive via a USB port and external power supply,
While the approach is correct (done this myself), I would suspect this usb device, as clearly the HD is ok. My device has a power switch inline with the power cord, so make sure you've got it on :grin: