Print function not working after Windows Update

By rwnewson
Sep 17, 2009
  1. Hello all,

    I have Windows XP and MS Office 2003. Recently I realized I haven't updated Windows or Office in years so I upgraded to Windows XP Service Pack 3 and even did an update on Office 2003 (don't recall the details). After that when I ran Office an error message said that my Adobe Acrobat 5 was no longer compatible with it (which is understandable since it is so old)... So I uninstalled Acrobat 5 and installed Acrobat 9.

    After all that, I realized my printer no longer worked. I don't know which step caused it, but I can't print at all. I figured it was a driver problem, so I reinstalled the current drivers from the Dell website (my printer is a Dell 922 all-in-one) but the problem remained. The curious part is... I don't think its a problem with the actual printer, because:
    a) In most programs, an error occurs before I'm able to select any printer, and it won't let me even choose another printer like the Adobe PDF maker ("virtual printer").
    b) Scanning from the same printer works perfectly.... verifying the connection seems fine.

    Take a look at these crazy error messages. One is from notepad, one from word, one from internet explorer, and one from when I click on "printer properties". Isn't that messed up? It's a different error each time. And they remain even after multiple attempts to reinstall drivers and multiple computer restarts.

    Can somebody PLEASE help??? It's a mystery!!
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Can you completely delete the printer(s), reboot and do a reinstall?

    Sometimes a simple solution is just to add the printer as if it was a new printer. If it is a USB printer be certain to follow the correct procedure, which is documented in the printer bumph.

    It can be install the software before plugging in the printer for instance, ot sometimes quite the opposite.

    Then delete the older version and the dud drivers go with it.

    Occasionally, the culprit is DEP protection.

    ) Stop Print Spooler service.
    2) Go to C:\WINDOWS\system32\spool\drivers\w32x86 and delete content of this folder.
    3) Start Print Spooler service.
    4) Download last version of drivers and install again.

  3. rwnewson

    rwnewson TS Rookie Topic Starter Posts: 44

    Thanks for your help. I actually tried uninstalling the printer drivers and reinstalling them a few times to no avail. It was only when I used the Dell "cleanup utility" (from Dell website) that the affected files were truly deleted and that allowed the reinstall to be successful. My problem is now fixed.

    Thanks again.
  4. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Thank you for that valuable information
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...