Problem booting Windows 7 Pro x64

By ZeroOP ยท 20 replies
Feb 3, 2011
Post New Reply
  1. I have a problem booting. I reformatted my hard drive and installed windows. The problem is not that Windows does not boot. The problem is that it does not boot without direct input from me.

    Every time my computer boots it forces me into Windows Boot Manager... (See attached file:WBM Full) It's something I've seen before I'm no stranger to it... But usually I request to see it. That is not the case here. When I see it there is no time out.. I've waited upwards of 5 minutes before hitting enter. I MUST hit enter each and every time.

    On top of that there is only one possible OS to boot into: Windows 7 (See attached file: WBM OS List). So theoretically I should not see this prompt at all. Also, this does not happen on my new laptop which has Windows 7 pro installed does not have this problem. Both copies of Windows 7 were installed with the same disk.

    My first thought was msconfig. I scoured it to see if ANYTHING was odd. It looks completely normal. (See attached file: MSCONFIG)

    Then I resorted to looking at bcdeit. Nothing looks odd there... Except one thing... The timeouts are different between MSCONFIG and bcdedit. One says 3 seconds, the other says 30. I was thinking a "gimp" way to fix the problem is to set the timout to 0. Can't do that on msconfig, and did it on bcdedit, it did not work... (I also tried 3 on both The min Value for MS CONFIG) So i changed it back.

    Any help would be GREAT :)

    Attached Files:

  2. greypigeon

    greypigeon TS Enthusiast Posts: 29

    Hi, the only odd thing I see is the "usefirmwarepcisettings" in bcd
    Maybe try to enable or remove it?
    You can always set it back if this doesn't work!

    To enable:
    bcdedit /set {current} usefirmwarepcisettings ON

    To disable:
    bcdedit /set {current} usefirmwarepcisettings OFF

    To remove entirely:
    bcdedit /deletevalue {current} usefirmwarepcisettings
  3. jdillman1502

    jdillman1502 TS Enthusiast Posts: 120

    Try this:

    -Right click Computer and select properties
    -On the left side, click Advanded System Settings
    -Click the Settings button at the bottom (In the Startup and Recovery section)

    You should be able to set the settings you need in there.
  4. ZeroOP

    ZeroOP TS Rookie Topic Starter

    In the startup and recovery settings the check box that says "Time to display list of operating systems" in unchecked and even if it were, the value is set to zero...

    Time to display recovery options when needed is unchecked also. (That grayed out value is 30)

    Enabling "usefirmwarepcisettings" did not help. And in fact i think it broke my second PCI-E Video card. Because all of a sudden the second card is not displaying any monitors (no hardware changes have been made)

    Completely deleting the value, has returned my other video card but it HAS NOT fixed the boot problem. I have set the value back to OFF (returned it to before screwing around).

    On a whim i Started trying different configurations of the check boxes in "advanced system properties"... No combination seemed to make a bits worth of difference.. :(
  5. greypigeon

    greypigeon TS Enthusiast Posts: 29

  6. ZeroOP

    ZeroOP TS Rookie Topic Starter

    Starup repair on the CD, as well as the various fixboot commands make no progress... The diagnostics dont' see any problem what so ever.

    I didn't think about this as a mother board issue... Is it possible that flashing the bios would help? I don't like fiddling with the bios unless i have a very good reason to suspect it is the problem...
  7. greypigeon

    greypigeon TS Enthusiast Posts: 29

    Can you give a complete BCD list
    bcdedit /v /enum all >c:\booting.txt
    This creates booting.txt on your c:

    Or try this:
    start from your OS bootdvd like you did for Startup Repair, and choose Command Prompt
    type bootrec /fixmbr

    There is also the option to rebuild the BCD
  8. ZeroOP

    ZeroOP TS Rookie Topic Starter

    bootrec /fixmbr was of no help :(

    i'm attaching booting.txt :)

    Attached Files:

  9. greypigeon

    greypigeon TS Enthusiast Posts: 29

    Seems nothing wrong with that!

    Control Panel > System >Advanced System Settings > Advanced>Startup and Recovery >Settings

    Maybe uncheck "Time to display list of operating systems"

    And check if there are errors:

    Start > Run
    type eventvwr
    in center pannel Summary of Administrative events
  10. ZeroOP

    ZeroOP TS Rookie Topic Starter

    Maybe uncheck "Time to display list of operating systems" <-- already unchecked.

    There is nothing strange in the event log. :( This seems like something that is particularly difficult.
  11. greypigeon

    greypigeon TS Enthusiast Posts: 29

    Check that Time to....... again
    What is your Motherboard brand? Or PC,
  12. ZeroOP

    ZeroOP TS Rookie Topic Starter

    PC is a home build.

    Motherboard is ASUS P5N-D. Certain parts of it, including a couple of USBs are starting to act wonky (work sometimes, and not others).... I'm wondering if this isn't a hardware problem that nothing can be done about.

    Also, it was suggested earlier that I should flash my bios. As a general rule I try not to do it unless it's necessary. Would this be a good time to try?

    Is it probable or even possible this is a motherboard/BIOS related issue?
  13. greypigeon

    greypigeon TS Enthusiast Posts: 29

    It can be hardware related.

    BTW did you install the latest drivers from Nvidia? (nforce 15.51 WHQL)
    If not , try this firrst!

    And there's nothing wrong with flashing the bios!

    Your latest bios is 1401
    Your MB has
    ASUS CrashFree BIOS 2
    ASUS EZ Flash 2

    I also have an Asus board and flashed it like 4 or 5 times with EZ flash
    Download the bios file > extract the 1401.bin to c: or an USB drive
    From bios start EZ flash and........(see your manual:approve:)

    Hope it helps!
  14. ZeroOP

    ZeroOP TS Rookie Topic Starter

    Apparently I already have the latest bios version.....

    Also, after installing the latest forceware drivers nothing comes up on any of my monitors.

    Correction... I don't see anything before windows.

    I still had to get enter to get past the prompt and once I did I got to the login screen of windows. However, this is not a change for the better... :(

    Correction #2... I was on the wrong input on my TV.... (that is where all the bios stuff displays) So no change for the negative, but.. No change for the positive either.

    Correction #3: BIOS isn't up to date, that's the next thing to try.

    I can't get EZ Bios to recognize any file on my computer's internal hard drive, or my external USB drive. I do not have a thumb drive :( Is there a way around this issue?
  15. greypigeon

    greypigeon TS Enthusiast Posts: 29

    Do you see your drive on the left?
    If not check bios settings
    OnChip SATA Type: IDE or AHCI ?

    Did you put 1401.bin on the drive?

    If you still have a floppy drive, use it!

    EZ only recognizes .bin or .rom (in my case) and DIR's
    For USB I guess it has to be fat32
  16. ZeroOP

    ZeroOP TS Rookie Topic Starter

    If not check bios settings
    OnChip SATA Type: IDE or AHCI ?

    I looked though bios, I could not find those settings could you be more specific please?

    Neither drives show in EZ Flash. I do have the.bin file on both drives. I do not have a floppy drive.

    The external drive is NTFS, if i have to as a LAST resort, i can reformat that to FAT32 but I really don't want to.

    Are there any other ideas?
  17. greypigeon

    greypigeon TS Enthusiast Posts: 29

    Ok, forget the AHCI, your MB doesn't support that.

    Strange you don't see your internal drive?

    Try to boot with external disconnected.
    Can you see drive in EZ now?
    Can you boot normal without external?

    You can also flash with Asus Util (on the cd)
    This runs in windows, but I don't recommend this,
    In case something went wrong you can boot from the cd and original bios will be flashed.

    Don't you know somebody with a thumbdrive?

    Guess that's all I can think off, sorry.
  18. ZeroOP

    ZeroOP TS Rookie Topic Starter

    I think my motherboard is on it's way out.

    I don't see the internal, removing the external does not help. The app to flash bios that runs in windows does not flash the bios properly it says my current bios is newer then the bin file i have (which is not true).

    I may try it when a friend comes over with a thumb drive...

    Until then I'll just deal with this problem, honestly it's not that bad a problem.
  19. robin_bga

    robin_bga TS Rookie Posts: 171

    Do you finally get to the desktop?
    I suggest that you do a system diagnostic check, it could be you Hardware, like RAM...
    Hope that helps
  20. ZeroOP

    ZeroOP TS Rookie Topic Starter


    I fixed this problem, I just wanted to let everyone know what the problem was and how I fixed it.

    The problem was in fact my KEYBOARD.

    I have a Logitech wave wireless desktop (KB and mouse). On windows a while ago I "secured" the KB. Logitech has some kinda thing where you can secure the keyboard so that keystrokes can't be read over the airwaves. (I don't know if it works or not). I decided to give it a try, then I reformatted my computer....

    So the keyboard was secured, but not with the OS...

    When this occurs it seems the keyboard repeats a key at random times.... the first one of which is always F12 & boot up. That's why it was forcing me into the boot menu. I used to see Tab repeating a lot and I din't understand why.

    I took the batteries out of the keyboard for 10 minutes (I took the keyboard apart to see if there is an internal battery to keep the security info (there is not)). Then I booted (the boot was normal) and secured the keyboard to this OS.

    Problem solved... Now when I boot I don't even see the boot options screen.
  21. greypigeon

    greypigeon TS Enthusiast Posts: 29

    glad you found the solution an thanks for telling us!

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...