Problem with USB flash disk

By m91mm ยท 9 replies
Apr 2, 2009
  1. I have windows XP, and it recognizes the drive. It's recognized as "Healthy" in Administrative Tools --> Computer Management --> Disk Management.
    But when I try opening it, it prompts a message box that says that the disk is not formatted. When I try to format it, I get a message box that says "Windows was unable to complete the format". I tried to choose FAT or FAT32 in the file system field, and it does the same thing. It doesn't have any other options.
    In the properties window it says that the file system is RAW. It also says that it's capacity is 0 bytes and that it's full. The disk is supposed to have 2GB.
    It doesn't happen with other flash disks on this computer, and with that specific one it happens on other computers. It worked fine until once I tried to put on it more than 2GB and then it started doing problems.
    Do you think it's possible to fix it or should I just buy a new one?

    Thanks ahead =)
  2. tuant

    tuant TS Booster Posts: 202

    Inssert the flash drive into the computer. Right click => properties => run 'error checking'. Also check to see if your flash drive is not 'write protected'

    good luck
  3. m91mm

    m91mm TS Rookie Topic Starter

    I don't think it has the option to be write protected - it doesn't have any button or something on it. Anyway, it doesn't do problems when I try to write to it - It doesn't even agree to open it, in the claim that it's not formatted.

    I went to properties --> tools --> error checking --> check now, and I clicked on "Start". It didn't do anything except of closing the window (just the little one, the properties window remained open). It didn't change when I checked some or all of the check-boxes (I tried all 4 combinations).

    I also noticed that in the properties window, it recognizes the capacity as 0 bytes, and in the Control Panel --> Administrative Tools --> Computer Management --> Disk Management, it recognizes the right capacity (1.97GB).

    Is it possible that the problem is that the original file system is RAW and I tried to format it to FAT/FAT32? (in the format window I had only FAT and FAT32 and I tried them both)
    Is there any downloadable program that can format the drive to RAW file system?
  4. uch

    uch TS Rookie

    the last time this happened to me, the flashdirve was infected with a might also be corrupt which is possible with a new flash drive.

    if possible run an error check like he said or use an antivirus on it
  5. tuant

    tuant TS Booster Posts: 202

    Try initializing and reformatting the flash drive within disk management.
  6. m91mm

    m91mm TS Rookie Topic Starter

    I already tried to do what you both said.
    It doesn't recognize any problem, it doesn't agree to format it, and it doesn't agree to do anything else because it's not formatted =(

    Do you know how can I format it to RAW file system?
  7. tuant

    tuant TS Booster Posts: 202

    You tried partitioning the drive from disk management?
  8. m91mm

    m91mm TS Rookie Topic Starter

    How can I do that?
  9. tuant

    tuant TS Booster Posts: 202

    In disk management, I believe if you right click on the USB it'll show an option to partition.
  10. m91mm

    m91mm TS Rookie Topic Starter

    OK I fixed it!

    I used 2 programs that I found when I searched "format usb flash drive download" in Google, the first 2 results. It doesn't let me publish links because I'm a new member.

    And now the flash drive works!!

    I'm not sure if using the first program was necessary, maybe it would work if I used just the second one.

    Anyway - thanks for trying to help :)

    Now I'm supposed to have enough messages to publish links, so this is the first program and this is the second one.

    I saw some other threads in other forums with the same problem, but they all didn't have any solution... So good luck for any others having the same problem!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...