Problems after using Sandisk Micro flash drive

By tammyncook · 38 replies
Mar 3, 2009
  1. Hi Everyone!
    This may get lengthy. I'll try to give all the info I can...
    I rec'd an 8GB Cruzer Micro flash drive for my birthday.
    I plugged it into my laptop yesterday to transfer some stuff. At first I rec'd the messages that my laptop couldn't install or wasn't recognized or something- sorry I don't remember exactly what it said. So silly me I pull it out and put it into a different USB port when it promptly shut down my computer.
    Well, after some searching, I find that you can't have a CD or a DVD in your drive or it causes a conflict. So, after I remove the DVD from the drive & shutdown & restart the computer, I plug the flash drive in and it works flawlessly.
    But, I go to run a game from the start, all programs, games, spider solitare, and it opens, but doesn't deal. When you click on the window, it turns to white screen and displays "(not responding)" in the title bar.
    None of the games work. They all do this same thing. What happened? What do I do to fix this? I've only had this laptop for 2 weeks! Help! I should mention that I am running Vista basic SP1.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Try doing a system restore... This should be easy to do if the laptop is only 2 weeks old
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Attempt the system restore

    However, if that doesn;t help suggest you next
    1. [post=727106]Click here[/post] and follow the instructions to run DriveCleanup. This deletes info Windows has stored for your currently disconnected (but NOT UNINSTALLED) USB drives/storage and CDs.
    2. If step 1 wasn't sufficient, [post=729301]See this post as well [/post]to see if fixes the problem. NOTE: you may need to reinstall your CD/DVD and media applications after removing the filter drivers for your CD/DVD
  4. tammyncook

    tammyncook TS Rookie Topic Starter

    Okay. I tried system restore from a few different points, no success. It goes through the system recovery procedure, then restarts & gives me a message that it did not finish successfully due to "unspecified error".
    I tried using this flash drive again today and it didn't work at all this time- went straight to the dreaded blue screen. And I've noticed that I have no sound now either.
    I'm going to try LookinAround's suggestions next.
    Please, please let me know if anyone's heard of this!

    Okay. I ran the diskcleanup, but at the end it says
    5 USB devices not removed 3 disk devices not removed
    1 CD rom devices not removed
    4 storage volumes not removed
    I'm thinking it wasn't successful just like the system restore?
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    sounds like you entered drivecleanup -T? as that displays (but doesn't remove)

    enter drivecleanup (with no arguments)
  6. tammyncook

    tammyncook TS Rookie Topic Starter

    I only entered "diskcleanup" then hit enter.
    Nothing after that...
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Does your user id have administrator rights? (admin rights are required for drivecleanup to remove stuff)
    Control Panel->User Accounts. See if computer administrator listed for your userid?
  8. tammyncook

    tammyncook TS Rookie Topic Starter

    Yep, I'm the admin. I'm the only user on this pc.
  9. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    You may have a defective hard drive
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Oh!!! i just looked back and saw you're Vista!

    When you follow the instructions you MUST run the command from an elevated command prompt (otherwise it still runs without admin rights). The post includes a link for how to run elevated command prompt in Vista
  11. tammyncook

    tammyncook TS Rookie Topic Starter

    Okay- ran as admin. They were all removed.
    No changes tho that I've noticed. Still no sound. Games still don't work.
    By the way, I've updated every driver that I have.
    Not sure what to do next.

    By the way, when I try to do the regedit from step 2, I do not have the UpperFilters or LowerFilters in the right pane in that registry key.

    Also I should add that everytime I shut down or restart, even though I may have closed Internet Explorer some time before that, it says that it's still open and "playing logoff sound".
    I'm not sure if this is related to the sound issue or something different altogether.
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmmm….. You have several different issues going on tho it’s not yet clear if they’re all related to the same root cause. Here's a few different things to do:

    1. Click for MS fix about Message when you try to shut down or to restart Windows Vista: "The following programs are still running: Explorer.exe Playing logoff sound" Am curious if this problem just now start?
    2. Have you tried connecting your USB flash drive after you ran drivecleaner? Do you still get a blue screen crash?
    3. Let’s check if Windows is reporting any Problem Devices (and check on Sound in particular)
      • Open a command prompt window, enter: msinfo32
      • Click the + sign next to Components to expand it
      • Click Problem Devices. Anything appear?
      • If yes, click on it, then Edit->Select All, Edit->Copy Paste into next post
      • Then click on Sound Device (also under Components) and copy/paste into next post
    4. Let’s check your Windows Event log
      • Copy the loooong command line you'll find below and then paste it into a command prompt window
      • It will create a file on your desktop Events.txt
      • Attach the report file to a TechSpot post. When you create your TechSpot post, use the paper clip icon to attach the report. (If you don't see it among your icons, you need to click the TechSpot Go Advanced button towards bottom of window)
        wevtutil qe system /c:100 /rd:true /f:text /q:"*[System[(Level=1 or Level=2 or Level=3)]]" > "%userprofile%\desktop\events.txt"
    And also (just fyi as you're a new member) when you want to add info to a last post (before you get a reply to the post) you can click the Edit button and do something as below (helps make the moderator;s life easier as they otherwise need manually combined multiple sequential posts)

    *** EDIT ***
    So you can just do something like this to indicate and EDIT along with any new info you provide in the edit :)

    /* EDIT2 */
    Corrected the syntax in the code box above
  13. tammyncook

    tammyncook TS Rookie Topic Starter

    Okay. The internet explorer thing just started with these problems. I read the fix for it and tried it, it didn't work.
    I just tried the flash drive again, yes it killed it again after I ran drivecleaner.
    No problem devices.
    Here's my sound device.
    Name Conexant High Definition SmartAudio 221
    Manufacturer Conexant
    Status OK
    PNP Device ID HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_103C360B&REV_1000\4&21B0E903&0&0001

    Name Intel(R) High Definition Audio HDMI
    Manufacturer Intel(R) Corporation
    Status OK
    PNP Device ID HDAUDIO\FUNC_01&VEN_8086&DEV_2802&SUBSYS_80860101&REV_1000\4&21B0E903&0&0201

    For some reason I can't paste into the command prompt window. Not sure why. I'm sure there's something special I have to do to do that too?
    I tried to enter your code, but it says "A syntax error occured at position 41. Failed to open event query. The specified query is invalid." And it just creates an empty "Events" document on the desktop.
    Thanks for the EDIT info! Good to know! I will do that from now on!

    03-09-08 I think I've made some headway on my own. I went through and disabled all the devices that I thought may have been giving me issues and restarted. It was one of them because everything worked flawlessly on restart. Well, except no sound, of course. I had disabled my cd/dvd rom, both audio devices and all the USB ports. So I enabled all the USB ports, restarted, worked great. Enabled the CD/DVD rom, restarted, worked great. Enabled one of the audio devices, worked great. Enabled the other, same problems show up on restart. So, I've got it narrowed down to that device. So, I go online thinking that maybe there's another driver I can use. I find one for that device and when I try to install it says it cannot find the media device. It is enabled, and windows shows me that it's working properly...where do I go from here?

    The device in question is the Conexant High Definition SmartAudio 221... I'm wondering if this is the actual speakers, or the sound card? Could this mean that the card or the speakers are not working at all? But it says that the device is working properly...
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    glad you just posted again! Sorry, i must have missed your prior post. Will give a look and get back to you over next few hours

    /* EDIT */
    OK. So here's so updated info so far
    1. I'm not sure if you indicated before.. but what make/model is your computer??

    2.. Apologies. I was missing a closing ")" in the command I provided earlier. I'll provide it again. In fact, here's two commands so we can look at both your Application and System event logs). Attach both SystemEvents.txt and ApplEvents.txt files from your desktop
    wevtutil qe system /c:25 /rd:true /f:text /q:"*[System[(Level=1 or Level=2 or Level=3)]]" > "%userprofile%\desktop\SystemEvents.txt"
    wevtutil qe application /c:25 /rd:true /f:text /q:"*[System[(Level=1 or Level=2 or Level=3)]]" > "%userprofile%\desktop\ApplEvents.txt"
    3. Both of the audio devices you listed are devices internal to your computer. (Have you tried unplugging speakers to see if you have sound from internal speakers?)

    It appears your drivers are all OK so you should check other settings. Here's a couple troubleshooting links (even if not your exact make/model most of these steps are generic to any computer running Vista)
    Tips for fixing common sound problems
    Sound cards: frequently asked questions
    Resolving Sound Problems in Windows Vista
  15. tammyncook

    tammyncook TS Rookie Topic Starter

    I'm at work so I can't do the events logs yet, but here's a little info until I get home...
    My computer is a laptop- Compaq Presario CQ60-211DX.
    I have the sound Conexant card disabled right now so the computer behaves.
    I don't think I would be able to unplug the speakers. But, I do know that it makes sounds when my 2 year old son pushes buttons while running by. Internal sounds, I would guess? Also when I have new email it beeps.
    I'm looking at the help links you gave. I will try them when I get home and let you know. I just wonder if it is the card since when I tried to install the driver I had downloaded it said it could not install because it could not find the Media Device...
    By the way, thank you for all your help. I really do appreciate every bit of it!

    Okay here are the events logs.
    Tried all the stuff in the links you posted. No go.
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OK. I’ve gone back to the beginning and re-reading. Boy, you sure do gotta lot of problems for a new computer! I’ll try addressing things as I re-read issues
    1. I understand you are running Vista SP1. The support site for your computer asked if 32 or 64 bit Windows. Let’s verify whether you run 32- or 64-bit Windows. Click for instructions.

    2. Just a note: not that it should’ve caused your problems (and maybe you already know) but always, always, always make sure you’ve stopped your USB device before you remove it. (You can use the Safely Remove Hardware icon to do so). Removing it without first stopping it can cause your flash drive to get corrupted and potentially you lose part or all data on it!

    3. A comment: You mentioned problems inserting flash while you have a DVD inserted. I haven’t heard of that being a problem before. I know inserting flash CREATES a CDROM device in Device Manager but never heard it's a problem if DVD is in when you insert the flash. Hmm. Will have to look into that one further myself…

    4. Are Spider games still a problem? I see no error reported since mar 9 (but maybe you just haven't tried it?)

    5. Have you tried running/assuring all windows updates have been applied?

    6. Here's a tool that will let me see all your current installed drivers and versions. Download DriverView To generate a report (you can then attach)
      • Edit=>Select All
      • File->Save Selected Items
      • Change the SaveAs Type pulldown menu to: Tabular text file
      • Then save to a text file

    7. Are you sure you don't have any upper or lower filters on your CD/DVD device?? Here's a cool tool to at least see if you do (and i'm guessing you should). Download Filter Load Order. Just click to run it, then click on your CD/DVD device and it will display your upper/lower filters if any (if none that may be part of the problem, i.e. you need resinstall your media players and stuff. if they do exist, try removing again. Once in regedit and after you get to the point where you expand on the subkey Class, it's real easy to confuse all those looong hexadecimal numbers that appear next. So try copying the hexadecimal number from the instructions, then back in regedit click edit->find to paste the number in the Find box. Then regedit will search for the matching number (to assure you're looking at the right hexadecimal subkey) Also here's more info about the tool i suggested

    8. As for copy/paste into a command prompt window, you may need to set it to QuickEdit mode, see this post for instructions

    9. Finally, for the moment at least, the System Event log report i had you generate included an argument such that it only generated the last 25 events (which by now doesn't include the system crashes you had a week ago. I'm giving you a new command below that dumps everything. This file may be HUGE (i can't predict). So if you could edit it to start on the date when the crashes began a week ago should help get it manageable size you can then attach again.
      wevtutil qe system /rd:true /f:text /q:"*[System[(Level=1 or Level=2 or Level=3)]]" > "%userprofile%\desktop\SystemEvents.txt"

    /** EDIT **/

    ONE MORE IMPORTANT NOTE: Have you built your recovery CDs yet? HP should have included a recovery partition on your hard drive, useful to help recover from certain events. At the same time, it supports your being able to build one cet of recovery CDs from it. THESE ARE CRITICAL and you should look through HP web site/support/documentation to build them. As these also cover you in the event your hard drive ever goes bad you can still recover.

    /* EDIT2 */
    You should also try running vista System File Checker (verify integrity of system's files. replaces them if needed)
  17. tammyncook

    tammyncook TS Rookie Topic Starter

    It's 32 bit.
    I always use the stop hardware, eject thingamajiggy for my camera, cell phone, everything. And when the flash drive worked correctly that ONE time, I stopped it that way also. But, when it killed it to the BSOD, I had no choice but to just pull it out, it wouldn't restart until it was out.
    This is from the SanDisk website knowledge base:
    Computer freezes when a U3 device is plugged in

    My computer freezes when I plug in my U3 device

    Freezing of your desktop is a recognized issue that may originate from a couple of sources.

    STEP 1 - Check for CD’s or DVD’s inserted in the media drives
    The first thing to check is to make sure you do not have a CD or DVD inserted into one of the media drives at the same time that you insert the U3 device.

    STEP 2 - Disable devices
    Try to remove or disable all devices except for your hard drive, monitor, keyboard, and mouse and see if the problem persists. Even disable the printer if it has a memory card reader installed on it. If that allows you to run the Launchpad, one of these devices probably is using software that is probing the CD-ROM partition of your smart drive, not finding what it expects to find, and behaving badly in the aftermath.

    STEP 3 - Check if there’s software conflict
    Please check our Software Compatibility article for more specifics on applications known to produce this behavior.

    I did find something later that said that this device uses the CD-rom drive to work so if you have something in it, it causes a conflict. I did have a DVD in when I tried it the first time. But, after I found this in the knowledge base, I took it out, restarted then plugged in the flash drive and it worked fine. Then it never worked again!
    The Driverview .txt file is attached.
    Filter load order shows "no upper filter drivers specified for this device" & "no lower filter drivers specified for this device". So that means I need to re-install my "media players & stuff"? I'm worried now because I didn't get any software with this laptop. When I got my pc 6 years ago, I got all kinds of software disks with it- this laptop I got nuttin! So, if I uninstall my sound card (I assume that's what you mean by my media players & stuff) how do I re-install it??
    When my sound card is disabled, everything works properly including the games that I can't get to run when it's enabled.
    I have automatic updates running. In fact, it just did another automatic update when I started it up today. I will check, but I'm pretty sure it's up to date with updates.
    I've attached the system events back to the date I first used the flash drive.
    No, I haven't built recovery CD's yet... do you think I should do that now given the problems I'm having?
    I'm going to go do the System File Checker right now...
    Ran the System File Checker... this is from the cmd window:

    C:\Users\Mom\Desktop>sfc /scannow

    Beginning system scan. This process will take some time.

    Beginning verification phase of system scan.
    Verification 100% complete.
    Windows Resource Protection found corrupt files but was unable to fix some of them.
    Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example


    I've also uploaded a zip file with the CSB log in it. I took out everything before today's date so you could see what happened with the corrupt files blah blah blah.
    Hope it helps.
    Thanks again,

    I checked to see if computer still behaved badly when the sound card was enabled after System File Checker fixed files... same problems. I was hoping maybe that fixed it! Ha!
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    i haven't had time to yet look through all your data..but based on your last post do the following

    => Open Control Panel-> Add/Remove Programs (or whatever they call it now for Vista)
    => Do you find an entry here about your sound? If yes, click Remove (and let me know if you found an Add/Remove Programs entry or not.)

    /* EDIT *
    And i'll update later on how to reinstall next
  19. tammyncook

    tammyncook TS Rookie Topic Starter

    Okay! Will do as soon as I get home tonight.
  20. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1. fyi.. for your sound card stuff in Add/Remove
    => When you uninstall via Device Manager the only thing that gets uninstalled are the drivers
    => Many sound card installers (not all) install Sound applications along with the drivers. In such case, they'll also create the Add/Remove programs entry which will uninstall any Sound card application software AS WELL as the drivers
    => So if your problem is actually the sound application vs. the driver, etc....
    => Also to do a really clean sound card re-install you want to remove any of sound card application software first as well​
    2. As to DVD inserted when you insert the USB flash
    => Well, thank you. I never heard of that one before! In general, there's issues between the DVD/CD device and USB flash (but hadn't heard specifically of DVD inserted)
    => I was going to also recommend uninstalling any CD/DVD creation/burning programs as well (and even more so now that i can now find links about bugs with USB sticks, e.g. for example i see AnyDVD talks about "fixing compatibility issues with memory sticks", etc.
    => What application do you use (do you anyway to reinstall it? if it's a freeware/trial version we can probably also find a copy to download online)​

    3. Lets check if you have a "hidden" recovery partition on your hard drive
    => Start->Run, diskmgmt.msc to open Disk Management
    => Look at the partitions defined on your hard drive. Do you see more then one? (It might not have any drive letter assigned)​
  21. tammyncook

    tammyncook TS Rookie Topic Starter

    Okay. I uninstalled via Control Panel, uninstall programs. The Conexant device was listed in the programs. Weird thing tho, I chose uninstall/change and it showed that it was configuring drivers & installing and told me it was installed & ready to use. But then it disappeared from the program list when it was finished. So I assume it really did uninstall vs. install.
    This computer is so new to me that I don't even know what programs it came with for CD/DVD creation/burning besides Windows Media Player...
    I ran disk management. I have C: which I assume is my hard drive, Audio CD (E: ) primary partition and Recovery (D: ) primary partition, all of which show that they are healthy, whatever that means.

    Since I uninstall the Conexant device, it now shows High Definition Audio Device. Shouldn't it show nothing since I uninstalled it? I tried re-installing the Conexant driver/software package I found, it goes through the whole frickin process then at the end says it can't install drivers because it can't find the MEDIA device. ARGHH! And now it's misbehaving again- games won't open, the Sound window from Control panel freezes, etc like before. I assume it's because whatever device it says it's using is the problem. I'm so confused at this point!
  22. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    My comments embedded below in blue
    /** EDIT **/
    And, btw, when a device is connected Windows should ALWAYS be able to detect it. Drivers are not needed simply for detection (they're needed to to allow you full function, i/o and control of the device. Windows actually gets the device name from the driver it finds. It's probably finding a DIFFERENT generic driver now that we removed the Conexant driver. in any, case is ok for now. (If Windows finds NO drivers at all, you should expect it to be called Other Device or Unknown Device but should still appear whenn connected!
  23. tammyncook

    tammyncook TS Rookie Topic Starter

    Here's my program list. Can you take a look at it and let me know if you see something? I don't see anything for creation/burning of CDs or DVDs which seems odd that they give you a CD/DVD burner but no software to use it? I am going to see about building the recovery disk set as soon as I actually get out of bed...
  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Here's a couple quick things as i start to go through stuff (you might also try looking thru HP site for instructions to create install disks from their recovery partition. If you can't find it, let me know and i'll look as well)

    In the meantime,
    1. The SFC command txt file you sent me only reported 2 problems: both were for the Windows Sidebar initialization. Don't know that it's related to your problem, but try disabling Windows Sidebar from starting for now.

    2. We should also let Vista scan your C: drive to look for/fix any filesystem corruption (just good housekeeping as well as diagnostic/repair reasons). See this link . Check all the fix/repair options and let it run. NOTE: It may take a looong time to run (even appear to hang as it can be slow) but give it at least 30+ minutes on the same screen display before suspecting a possible hang.
  25. xehqter

    xehqter TS Rookie

    I did a quick skim, if I understand this is a new laptop, if there isn't a lot of data perhaps the easy way out is to backup your data and reload windows with your recovery CD/partition.

    not that I'm a big fan of giving up but it may be the quickest way out.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...