Remote Desktop freezing issue with XP Pro SP3

By tycho1974 ยท 5 replies
Jun 10, 2010
  1. Hey, folks. I'm having a remote desktop issue here that is driving me certifiably insane. I'm working on a PC running XP Pro SP3 that's part of a small office network. We'll call this computer "Janky". I can connect to other computers on the network via remote desktop with no problem - Janky to Accounting; Janky to RIPMachine; I can even connect from Janky to my home computer which is running Windows 7.

    The problem is that Janky won't accept any incoming remote desktop requests. Well, I guess he does, but he won't complete the requests. For example, when I try to connect from HomePC to Janky, I see the login screen, and after a successful password entry, all I see is a black screen. I can quit the RDP application, but now Janky is frozen and needs a hard reboot. This same scenario occurs when I try to connect to Janky from a computer inside the office LAN as well - RIPMachine to Janky; Accounting to Janky - you get the idea.

    The router is already configured to forward port 3389 to Janky, but that's not the issue if I can't connect to Janky from inside the LAN. Besides, the problem's not that I can't connect, it's that RDP freezes every time I do.

    I'm at the end of my rope. I've disabled all "extras", I've turned down all graphic effects and basically running it as bare-bones as possible. Does anyone have any ideas about what to do?

  2. tipstir

    tipstir TS Ambassador Posts: 2,475   +126

    Are you on a domain or workgroup?
  3. tycho1974

    tycho1974 TS Rookie Topic Starter

    Um, work is on a workgroup for filesharing and messaging purposes, home pc is not. No domains to speak of, I think.
  4. tipstir

    tipstir TS Ambassador Posts: 2,475   +126

    XP Pro you need to invoke IPV6 if you're going to use 7 boxes with XP Pro SP3. On the XP Pro SP3 you my have to force the router to be seen on the wireless client also uses UPnP.
  5. tycho1974

    tycho1974 TS Rookie Topic Starter

    I'm not sure what you mean here. As stated in my original post, no machine - be it 7 or XP - can successfully connect to the XP machine. I've tried over the LAN and via the router's IP address to no avail.

    Also, I don't know how to invoke IPV6, and I'm not sure what you mean by your second sentence. Can you elaborate?
  6. tycho1974

    tycho1974 TS Rookie Topic Starter

    Okay, so I looked into this IPV6 business, and apparently it wasn't installed on Janky, my first office PC. Installed it via Windows, and tried to connect from computer in same office - success. Then, I remote desktop'd over to my home PC, then from there, remote desktop'd to Janky - success! Thanks for the tip...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...