Shift key typing * and +

By luarna ยท 13 replies
Mar 23, 2011
Post New Reply
  1. i have somehow bumped something on my keyboard - when i hit the left shift key it deletes the line of text and adds the star icon above the number 8. and when i hit the right shift key it adds a + and will delete text in the next row.
    how can a undo this silly shortcut i have activiated.
  2. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Is this a problem in 'MS Word'? Or generally using the keyboard?
    Which version of windows are you using?
    But anyway, try ' Start', 'Control panel', 'Hardware', 'Devices','keyboard'
    Then right-click on it, choose 'properties'
    Then click on 'restore defaults'
  3. luarna

    luarna TS Rookie Topic Starter

    more info please

    firstly, mike 1959 - thanks for your reply.
    i have tried your instructions, but a little lost - i can't seem to find the option to restore defaults. i think i am following your instructions right.
    under control panel i have harware and sound - or via the small icon setting i have just the keyboard icon. i can't see your suggested path of hardware, devices, keyboard. - clicked on a few variations.

    i'm using windows 7 and yes, it's happening in all programs, office and in email - even in this reply.

    any further assistance will be appreciated,
  4. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Keyboard issues....

    Ah yes, sorry about that. I normally use a wireless keyboard with MS 'intellitype' software installed, so I get different software to adjust. (Have removed it for this problem).
    There are three things you can try. If you have two different keyboard layouts enabled, you can switch between them by pressing 'Ctrl' and 'Shift' together. Repeating that will go back to the first one.
    If it's not that, do you have a small keyboard icon showing in the taskbar (lower right of screen)? Or maybe two letters such as 'EN' or 'US'? Move cursor onto it, and right-click, select 'settings'.
    In the 'General' tab, you will see the languages of the keyboard layouts you have installed. In the box you will see the options, the top one is the 'default' for your computer, in my case 'EN English (United Kingdom), then dropping down below are some options, depending on if you are using a laptop or full keyboard (extended).
    Click once to highlight the wanted one, then click 'OK'.
    In my case it's 'United Kingdom extended'
    Now your keyboard should be standard layout.

    *(If you don't have the keyboard icon showing in Taskbar, move cursor down onto the Taskbar, right-click.
    Move cursor up to 'Toolbars', a box will fly out to left, move cursor across to 'Language bar' and click on it once. Now you will have ticked it, and a keyboard icon will be in the taskbar).
    Hope that helps,~and works.
  5. luarna

    luarna TS Rookie Topic Starter

    still no luck

    thanks mike 1959 for your suggestion but i do not have the paths you suggested on this laptop. i went through your instructions just hours ago on my work computer and i could follow them and find the restore default button with easy - as you suggested. so i have faith in what you are teliing
    i'm not sure why this laptop is different, when i right click on the tool bar and go to toolbars, i have no language bar option. i only have address, links, tablet pc input, itunes and desktop.
    any chance you have the time to look at another possible solution.
    thanks so much for offering your help so far.
  6. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    No trouble. You can't see the language bar or keyboard icon, because it's been 'hidden' in the options.
    To force it to show in the taskbar, and to reset your keyboard layout, click on your
    Start icon, and in the 'Search programs and files box' Type; Language
    Then under the blue heading that appears, click on; 'Region and Language'
    In the new box that appears click on the 'Keyboards and languages' tab.
    Click on 'Change keyboards'
    Click on 'Language bar' tab
    Click on the radio button 'Docked in the taskbar' Then click on 'General' tab
    You will see a small square dot to the left of your keyboard language, so in my case it's .United Kingdom extended.
    Click on your preferred choice, then ok.
    Now you should have a small keyboard icon in the taskbar, also your keyboard layout should be back to default layout.
  7. luarna

    luarna TS Rookie Topic Starter

    shift key

    thanks so much for your help. i found the keyboard with your help and clicked restore many, many times. sadly this has not fixed this silly issue. i changed around between english uk, us and australia - restarted and fiddled in every area i could see.
    i have no idea where to go from here, my keyboard and computer is all working fine - no virus, nothing else i can think of. still having the left shift key insert the symbol above the number 8, it also deletes the current sentence and goes back to the start of the line. the left shift key inserts a plus and deletes the next sentence - if there is one there.

    i thank you for your time - any other suggestions - would insert a question mark here but don't want to delete my line -
    thanks again
  8. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Ok, so it wasn't that. I would suggest that you uninstall the keyboard driver, and then restart the pc, which will then force windows to re-install the keyboard driver from it's own store. It should then be as new.
    To do that, go to 'Start', 'Control Panel', 'Hardware and sound', 'Device manager'.
    After it opens, click on the small white arrow to the left of the 'Keyboards' line.
    Click on 'Keyboards' and a new line will appear below, ' HID keyboard devices'.
    Right-click on that, and a menu will appear, point to 'Uninstall', click on that.
    Restart the computer. When the desktop has finished loading with your icons, you should see a notice appear, 'Installing device drivers', ' Then another, ' Windows has successfully installed driver'. Now it should be as default keyboard layout.
    (I have just done this on mine, it worked as described.)
  9. luarna

    luarna TS Rookie Topic Starter

    hi mike, i haven't been brave enough to try this, will wait till easter holidays when not rushed. thank you so much for all your help. i'll llet you know how it goes.
    thanks again for your time.
  10. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    No trouble. I did try the steps I described on my pc first, before I typed it up, it will re-install your keyboard driver from the standard Windows driver store, that was installed with Windows. The idea is, it will reset any shortcuts that have been set and take it back to 'as new'. If the problem is still there after that, then it's just possible you could have a problem with the matrix mat under the keys, or in the chip that 'reads' the keys, but that's an unusual fault.
    (* If you have a USB keyboard around, from a different pc, you could try that and see if it makes any difference. If you can use it plugged into your 'problem' pc, and the fault has gone, it will show up a fault as being in the keyboard matrix or chip relating to it. If the fault is the same (lines of text deleting etc, it will show a fault in the software of your pc. i.e. probably drivers.) This isn't 100% foolproof, but it's easy to try.
  11. CAMusing

    CAMusing TS Enthusiast Posts: 179

    Did you try a system restore to a date prior to this happening?
    Pan Wah likes this.
  12. Richpickings

    Richpickings TS Rookie

    Have you found a solution for this yet? I have a similar problem.


    Same problem here, can anyone help \*/ lesson learned is never think that a 9 month old can not make damage to a computer.
  14. Richpickings

    Richpickings TS Rookie

    I found a solution to my issue. It was a new laptop and I upgraded the BIOS. After I had done this the problem occurred, it must have been a corrupt BIOS update. I returned the laptop to the manufacturer and they replaced the motherboard.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...