1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Sony Optiarc AD7580a

By surfersaiyan · 7 replies
Feb 1, 2011
Post New Reply
  1. ok, so i've gone and done something a bit daft, as always when i ask for help here on TS.

    my ever reliable NEC ND6750a DVD drive finally gave up, so in my inifinite wisdom i went to the store and bought something off the shelf which looked like it would do the job (brow becomes furrowed).

    i bought a Sony Optiarc AD7580a.

    which now seems a mistake. having read up a bit on the internet it seems that Toshiba laptops don't like 'em that much and mine won't even recognise the drive or power it up so i can even open it.

    anyways, some people have pointed out that i may need to change the IDE settings with a utility.

    but the utilities usually point to the drive being an AD-7590a...

    so, the question is; will that utility work or can anyone recommend another tool or another way to proceed..?? p-l-e-a-s-e-!!
  2. Arris

    Arris TS Evangelist Posts: 4,686   +350

    I'd have thought that even if the Toshiba laptops had an incompatibility with the drive it should still be getting power for the eject to function. I've never had to switch out a laptop drive, my father has and got a replacement that was a slot drive and spend a day trying to figure out why "eject" from My Computer wouldn't open the DVD tray :D

    If it is like a desktop drive in all but its form factor, then as long as it is getting power it should eject. The connections and power for the drive will be a universal standard and not something specific to Toshiba (at least I wouldn't think they would have put a proprietary connection in their laptops). See if you can test it on another machine, or get them to verify the drive itself is working in the shop you bought it from.
  3. surfersaiyan

    surfersaiyan TS Enthusiast Topic Starter Posts: 100

    i also get an error ide #1 error when i restart the laptop, but then it ignores it and starts normally... if that helps!
  4. Arris

    Arris TS Evangelist Posts: 4,686   +350

    Still, the first thing I would rule out is the new drive. Get the shop to verify that it is working, if it is working and still won't work with your machine you should be entitled to a refund if you have the receipt and packaging. I wouldn't spend too much time trying to get something working that you have read had compatibility problems. There isn't much performance difference between DVD drives as most are 24x read (which I believe is about as fast as DVDs can be read) and max write speeds for burning. Unless it was a much cheaper purchase than another available replacements just grab a different unit.
  5. surfersaiyan

    surfersaiyan TS Enthusiast Topic Starter Posts: 100

    yeah i bought it in japan the other day but i'm not there anymore.. it was cheap tho, so might be time to give up. or someone else suggested maybe stick it in a dell and see if i can change the master/slave settings. my mate has one so i'm not beaten yet! (but could be soon!).
  6. Arris

    Arris TS Evangelist Posts: 4,686   +350

    If you can't take it back I'll have a look and see if I can find some information about the problem. Hope your friends Dell can help ;)
  7. surfersaiyan

    surfersaiyan TS Enthusiast Topic Starter Posts: 100

    Arris, my mates Dell looks like a 12-step to strip the gubbins off his drive so we can test mine.. so for now we've shelved it as a last resort.

    just wondrin if you came up with anything..
  8. surfersaiyan

    surfersaiyan TS Enthusiast Topic Starter Posts: 100

    ALL SORTED!! hehe..

    it took a little while but i managed to get the stoopid thing working now and it seems like an ok drive. i haven't worked out if its region free, but i'm not really worried about that.

    so here's how i fixed it.

    1) drive came from Japan, so i searched Google Japan for some info
    2) some guy showed himself changing this drive into an older model laptop, but had to connect somehow pins 47 & 45 together (as shown here http://blog-imgs-19-origin.fc2.com/m/a/h/mahito9/DSC_0832_2s.jpg). the top and bottom pins are the same on this model so i just dropped a blob of solder between them on the PCB.
    3) so, now i got a green light on the drive but no recognition or response (in my laptop).
    4) check Google again and find this guy (http://club.myce.com/f86/ad7580a-utility-switch-master-slave-cable-select-302492/)
    who recommends this utility (http://redirectingat.com/?id=49X493...lity-switch-master-slave-cable-select-302492/).
    only trouble is, when you download and unzip the utility the file formats shows as .exx and totally unusable - i'm not sure whose bad that is but i just changed it to .exe and hey presto! the tool to change the master / slave / RCS settings actually works!
    5) FINALLY! since my laptop was STILL NOT recognising the drive, i had to pop it into someone elses laptop which would recognise the drive and use the utility to change the setting FROM CS --> TO RCS.
    6) put the drive in my laptop, works like it was meant to be there!

    so i saved probably 50% on the purchase price but gave myself a 3-week headache in the process!

    anyhoo, just in case ur interested, thats how it went.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...