Stereo mix enabled; yet produces no sound

By Teh JeY
Jan 20, 2011
Post New Reply
  1. I recently came to a sound hiccup when I wanted to set my live stream to record audio and video from my desktop (video works fine no question), but speak to my viewer(s) on skype with my microphone. I've always had stereo mix enabled and I believe it's worked fine in the past, but recently it's acting up.

    For some reason, only the Microphone or Stereo mix work one at a time. I either have to disable one to get the other work, or set one as the "Default Device". When setting as the default device, that particular option will work, and the other will not. When stereo mix is set, the microphone levels (the little green bars) are nonexistent as I run my finger past the mic or blow into it. Same with the stereo mix if the Mic is set to default and I play sounds.

    What's weird was, when I was in Skype, pressing one function to be the default did not change what picked up sound. That is when I had to disable the other in order to get one to work.

    I am on Realtek High Definition Audio and my driver is all up to date. I have done countless searches, most of them lead to how to enable stereo mix and the few that actually recognize the problem I have seem to not have a posted solution.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I don't know if this might apply or you've checked (i've seen posts about it) but if you're running Vista or Win 7 check the tabs under Control Panel->Sound as i believe you find a check box to Allow an application to grab exclusive use of the mic. So i think the first app that grabs it works and others might not
  3. Teh JeY

    Teh JeY TS Rookie Topic Starter

    Disabling this does nothing.

    Edit: It seems I've fixed the problem: There was a feature in Realtek saying "Acoustic Echo Cancellation" which reduces speaker volume during recording. Disabling this allows both the microphone and Stereo Mix to pick up sound regardless of what is set to default device.
  4. SrPilha

    SrPilha TS Rookie

    I joined this forum just to say this: Thank you SO MUCH for this solution. I was going nuts looking for an answer and all I got was the same results as you. Now it's fixed, and no reinstall needed (as I was starting to fear).

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...