Strange monitor situation

learninmypc

Posts: 9,196   +670
Yesterday for the first time in about 3 weeks I plugged my Lenovo laptop in, powered it up , & in the process of updating Google Chrome, the screen suddenly looked "smashed" but moving. (It was frozen) I was forced to press power button to shut down. Waited a few minutes & powered it back up & this time I was able to update Google Chrome & much much more till it happened again.
Powered it off, waited a bit & booted it back up. No problem. Went into Device Manager & once I EXPANDED everything, I saw no indication of anything wrong. Then, as I started backing things up, it happened, smashed screen, frozen, powered off. Got it back up, got things backed up & did a reset keeping documents/pictures.That was successful.
Got Google Chrome installed & in the process of signing in, it froze again. Still nothing negative in Device Manager.
As I post this, I'm trying to reset it to factory settings . Any suggestions ??
 

learninmypc

Posts: 9,196   +670
  • Thread Starter Thread Starter
  • #2
@Cycloid Torus , I finally got it reset to factory settings but the weird screen/monitor situation has not stopped. Confused & ready to give up
 

Cycloid Torus

Posts: 4,648   +1,447
The list of possible issues is long.... on top I would put malware... followed by heat or connection issues with GPU/ribbon cable..
Anyone else?
 

learninmypc

Posts: 9,196   +670
  • Thread Starter Thread Starter
  • #4
The list of possible issues is long.... on top I would put malware... followed by heat or connection issues with GPU/ribbon cable..
Anyone else?
Ok, I thought malware possible too till I reset it to factory, I don't think heat can be it since its fairly cold to the touch, Not sure about what the GPU/ribbon cable is but not going to argue. Thank you for your input, guess its time to recycle it :)