System lock-up when plugging in external USB-HDD

By Lokalaskurar
Dec 20, 2010
Post New Reply
  1. Ok, the problem has already been stated in the topic. This might be a pretty long post, but please have patience, and I'll be ever grateful. The details are the following: (I am actually helping out a friend on this one, by the way)

    My friend bought a new laptop (Acer Aspire 5738zg) about 6 months ago, and it worked like a charm. However, he never ran it on battery, only socket-charge... thus the battery quickly became electro-exhausted, and the laptop's battery weakened severely. The laptop can currently only run for 10 minutes at any given time without recharging.

    He does not need the laptop to be mobile, though. But he wants to be able to utilize a particular external USB-HDD. I do not remeber the model, however the HDD is fully functional and works with every other computer he has plugged it into (about 10 different PC's).

    The laptop boots up and runs fine on socket-charge. The USB-HDD is plugged in... and the system freezes instantly. No respons comes from the PC, whatsoever. A forced reboot (pushing the start-button for 5 seconds) is required to restart the laptop.

    Of course, my first guess was that his battery lacked the power required to run the external HDD through a USB-port. But my friend recently bought an entirely new battery from the vendor (warranty had expired for the old battery), yet the problem remains.

    And of course, he's rather purky since the new battery costed $80 after all.

    What on earth can be causing this problem?

    By the way: warranty for the laptop is STILL applicable, in case it comes that far. But he cannot hand it in to the vendor's right now because he has a major school-assignment going on.

    Oh, forgot to mention: the problem occured with USB-flashsticks as well, but only when he had the old battery plugged into the laptop. With the newer battery plugged-in, USB-flashsticks work like a charm, but not the USB-HDD.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    There may be a setting in the bios that you can use or enable. It is named something like legacy USB enable/disable... Try playing with this setting
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Also, these may be long shots but they're easy to try and have sometimes worked

    1. Remove battery from laptop and unplug from socket. Leave the computer like that overnight then replug and try in the morning

    2. Also does the USB HD have its own AC power? If so, turn it off as well. Plug the USB cable into the laptop first then turn USB HD power back on

    If still problem, this just a curiousity thing to try.. but you might try plugging the HD into a self powered USB hub and connect the hub to the laptop to see if problem still the same

    /* edit */
    or even try using a bus powered external USB hub
  4. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    Sorry for the delay dear helpers, but he turned it in and got it replaced - faulty USB-controller they said. Oh well, problem solved then.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...