TF2 opens but disappears after showing startup screen for few seconds

By Archean
May 14, 2011
Post New Reply
  1. Hello Everyone:

    Recently, I had to dump (due to issues with nVidia chip) my old notebook and get a new one, so I thought I get at least a half decent notebook which can handle what little gaming I do.

    The specs of this notebook are:

    i7 Q2630 Processor
    4 GB DDR3 RAM
    1GB Radeon HD 6770M
    640GB HDD
    LED 1366x768 Display
    along with all other little bells and whistles.

    Anyway everything went well until I tried to test 3-4 games I usually play when I can get some free time, e.g. Q3A, TF2, Half Life etc. With minor adjustments I was able to run HL, however, Q3A and TF2 just didn't wanted to run. Q3A was giving some weird OpenGL error, anyway, after reading a lot of forums I ended up having to edit the q3config and it fixed the issue.

    But I have failed to identify what the issue is with TF2, when I open it, the start screen splashes for few seconds before returning me to desktop, no error message shows up, so I am clueless so far.

    I have manually tried to set the resolution by using -width and -height switches in launch properties, but to no avail. I've also de-fragmented game cache, and ran steam with administrative privileges, but no joy. Any help will be highly appreciable. Thanks

    I also updated the driver (provided by HP) but it didn't solved any thing.
  2. Archean

    Archean TechSpot Paladin Topic Starter Posts: 5,690   +96

    A little update:
    I uninstalled steam and erased any remaining data. Then re-installed and copied steamapps folder on this notebook from my desktop pc. Now TF2 runs perfectly well on the desktop (by the way I did the same on another DV5 and the game works perfectly on a much weaker 9200GS graphics). Anyway, it didn't helped so I am still exploring all possible avenues.

    I have discovered another unrelated issue, that is, Broadcom 4313 WLAN adapter is probably crashing connectify's setup, which I have been using for so long on almost every computer I have (to convert it to WiFi hotspot, so I can be lazy and don't have to bother with the router :D).
  3. Archean

    Archean TechSpot Paladin Topic Starter Posts: 5,690   +96

    Update 2:
    Okay guys I have absolutely no idea why, but downloading TF2 Beta (whatever the heck it is) appears have solved the issue. I haven't played as such but the games opens and connects to server, so it should play okay IMO (hopefully). Thanks
  4. Issun

    Issun TS Rookie Posts: 17

    TF2 Beta is for testing how new unreleased weapons work in-game (i guess), and for the normal TF2 crash, try "-autoconfig" when you set advanced launch options.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...