Toshiba A300 Satelite cannot power on (first day I bought it)

By delk ยท 4 replies
Aug 8, 2009
  1. Hi folks,

    This is my first post over here but it isn't for good reason Unfortunately.

    Today I have bought a new Toshiba Satelite A300 1TM.

    But It cannot power on.

    I am curious if I am the only one I have met with such a problem.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "Today I have bought a new Toshiba Satelite A300 1TM, but It cannot power on"...

    Are you kidding us? Have you plugged in the AC adapter and charged the battery? If so, take it back to where you bought it and have them fix or replace it for you
  3. strategic

    strategic TechSpot Paladin Posts: 1,020

    Where did you buy it?
    I'm surprised an associate didn't power it up at the store before purchasing it. :suspiciou
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    if the battery is fully charged and it won't power on, your system is DOA. return it for a replacement.
  5. delk

    delk TS Rookie Topic Starter

    Thanks all guys for your responses,

    I bought the laptop saled in a box. I opened the box in my house and I plugged it in. After a while I tried to open the laptop but it couldn't.

    The only thing happened was a breif oppening of the Power led and it turned off on the spot.
    I left it in the plug for more and I tried a lot of times but I couldn't turn it on.

    Yeah I will go to the store I bought it and I will ask for replacement.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...