Build a PC Toshiba Satellite won't power up

Not open for further replies.
Hello guys. This is my first post here. First at all, thanks in advance for any help you can give me. I'm from Costa Rica so excuse me if my english sometimes gets messed up.

I know this is an old thread. I double checked any possible option before i decide to post my situation. But none of them seems to work for me.

My problem is this:
I got a laptop Toshiba Satellite A105-S4334
Model number: PSAA8U-14M02K
Systemboard Toshiba number is: V00068590
Systemboard number is: 1310A2041316

What happened to my system is the like you guess it wont power up. Last time my brother used, it was working fine, he let the battery run out of power so we could start charging it back from 0. But when we plugged nothing happened, no lights, no charge no anything.

i tried everything, from removing the battery to replace hard drives an other components.. (with the help of a expert). Eventually i took it to the toshiba support center and the guy only tells me that is the systemboard what is wrong with the computer.

Now, i will like to know what exactly went wrong but they wont tell me. they just tell me that i have to replace the component.

Now here comes the thing.... is the second time in less than a year that i will have to replace the motherboard. First time it was under warranty so they change some defective systemboard along with some memory. 6 months later it happens again.

The first time it wasn't so drastic. it gave me some signs of failure so i took it right away. But this time nothing.

So one my questions is.. Does any one of you guys knows something about some specific problem with that toshiba model? could it be some sort of manufacturer's problem what is causing my system to fail.
Or am i just a clumsy guy who doesn't know how to use the laptop?

i was thinking on the battery pack replacement program, but my battery pack serial didn't matched the ones they listed.

so my second question: Could it still be that a possiblity? some defective battery pack? i tried to research for some symptons that the computer could give away with that but didnt found anything yet.

And well third question... is really the systemboard? is replacing it again the only chance i have, can something else be done? something i haven't see yet?
If i have to replace it... is it worthy? replace it a second time or should i start thinking on getting a new laptop.?

Sorry for all the questions... i just dont know what happened and it make feel frustrated.

thanks in advance guys..


Matthew DeCarlo

Posts: 5,271   +103
Do you not get power with only the AC adapter? Have you tried another AC adapter?

If your answer to both of those questions is yes, try bringing it to that "expert" friend of yours and ask him if he can desolder your current power jack and solder a new one on. Might work, might not, either way it's probably cheaper than a new motherboard is going to be for your laptop if he has the equipment. You'd just need to spend a few bucks and get the jack and maybe solder.
Thanks Zenosincks, that's also the hunch i have, maybe i could give it a try, what's the worst that could happen? that i have to replace the motherboard?

i will let you know after i tried to see what comes up from that.
I've been having a similar problem with a Toshiba Satellite. The laptop is my boss' and he brought it in to see if me and my co-hort here in the office can figure out what's wrong with it.

The other guy took it apart, checked it all out and it all seems to be in order. The plug is not the problem here, because the indiactor lights on the front do come on. The AC light is on (green) the Battery light is one (amber) and when you press the ON button the Floppy/CD Rom light comes on for just a second, while the Battery light goes off, then the Floppy/CD Rom light turns off anf the Battery light comes back on and it does not power up, nothing. He tried it with the Floppy and CD drives out, and still nothing. We tried it with the battery out, nothing. :(

We're beginning to think the Motherboard just crapped out. Do you guys have any other suggestions? Thanks in advance. :)
Not open for further replies.