Trouble with Ethernet Controller

I am working with a Dell laptop N5030 Win 7, this problem just started recently and is driving me nuts.

It will hook up to my WiFi just fine but not the internet. 3 other computers on the same network can access the internet. I did try downloading an updated driver from Dell off another computer via thumb drive with no luck. It worked fine a week before, never any trouble. Did all the normal steps, Clean and Defrag, ran a Virus Scan, tried to restore to an earlier date but would not restore.

If I go into Device Manager, it shows Network Connections just fine. Below that is Other Devices with Ethernet Controller under that with a yellow eclamation point. If I click on it, it says device is not installed.

I tried doing a ping test in command prompt, no luck, tried resetting the TCP/IP but tells me I need to switch to administrator, there is only one user. I went into Internet Options and it is set for Broadband connections but will not allow me to make any changes.

Any help would be appreciated.
 
I know u said u did it but im sure that is the problem as it showing not there in your device manager



By sound of it your ethernet controller driver is missing go to dell website I think www.dell.co.uk/support and download latest ethernet controller driver straight from there


I have downloaded the most recent driver they had but it did not help at all.

As much as I hate too, it may be time to take it to a shop.
 

LookinAround

Posts: 6,429   +186
Look in CtlPanel->Programs and Features. Is the network adapter also listed there? Uninstall it from there first then try to reinstall the new driver