Ubuntu on thumb fails to boot with Gateway 4525gz

By B00kWyrm ยท 14 replies
Sep 13, 2010
Post New Reply
  1. Hi Leeky, jobeard, (et al)

    I hope one of y'all can help.

    My first excursion into linux;
    decided to explore it as a tool for accessing otherwise inaccessible data on an unbootable system...
    seeing it as a tool for helping others with troubleshooting.

    My difficulty is this...
    I built a thumb installation of Ubuntu,
    using the Ubuntu on-line guide and the latest distro from Ubuntu.
    When I set up my system to boot from the thumb, it started to boot,
    but then "black screened".

    First I lost my signal to my external monitor,
    so I just unplugged it and turned off the computer, and re-powered-on.
    This time the boot process showed on the normal laptop screen, but again it black-screened.

    So, I tried again this time using Leeky's guide here.
    Similar results, though Leeky uses a different USB creator.
    This time I get the Ubuntu loading screen... with the dots underneath,
    then it changes breifly to a black screen with a few rectangles of differing heights,
    (burgundy/reds mostly, with horizontal lines through them) dead center in the screen,
    before quickly going completely black.

    I notice that "Lili" is stating...
    Are the Lucid Lynx parameters actually for Mac hardware?

    My guess is that Ubuntu is not correctly recognizing and (loading drivers for) my video card,
    but I am at a total loss as to what I should do about it.

    Try a different distro?
  2. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    It most likely is a graphics display problem.

    Whats the full filename of the Ubuntu.iso you downloaded?

    From the black Ubuntu screen on startup, press F4 and try and boot into "Safe Graphics Mode" and see if it then boots. Its probably the screen blackening due to the refresh frequency being set out of range of the monitor.

    If your dead set on installing Ubuntu to your hard drive, and your finding the live CD isn't working correctly, its possible to use the "Ubuntu Alternative" CD which provides a screen based installer to directly install Ubuntu rather than run a live desktop.

    The complete mirror list can be found here. Choose a mirror closest to you, and then head into the 10.04 directory, and choose the linux alternative install for either i386 (32 bit) or amd64 (64bit).

    For PC based live versions, the filenames are:


    For PC based alternative install versions, the filenames are:


    Lucid Lynx is the current version name of the 10.04 'Buntu releases.
  3. B00kWyrm

    B00kWyrm TechSpot Paladin Topic Starter Posts: 1,436   +37

    Thanks for clarifying re: "Lucid Lynx".

    I tried each of these
    • ubuntu-10.04.1-desktop-i386.iso
    • ubuntu-10.04-netbook-i386.iso

    Neither worked.
    (My Gateway is a laptop, not netbook, with Centrino / Pentium M. so, no I did not try the amd)

    I'll try the f4.

    I did not want to install ubuntu (yet)...
    (for now) just wanted try it out from the thumb,
    to investigate its use as a tool for helping people get to minidumps,
    (when they could not otherwise get at the minidump directory.)
    Right now, I am concerned that getting them up and running with ubuntu (or other linux distro) could be a challenge only for the intrepid, and they already have enough problems with their down system.

    So... I am still thinking.
    I'll get back to you on the f4.
    Thanks again.
  4. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    Booting from a thumb drive can be a real challenge - - I've never got it to work yet on my
    Toshiba laptop either. While the bios has an option for it, the system fails and just timesout
    and falls into the HD.
  5. B00kWyrm

    B00kWyrm TechSpot Paladin Topic Starter Posts: 1,436   +37

    Thanks jobeard...
    Ubuntu really does try to load in my case...
    I see the whole string of steps as it goes through the load process.
    (Or sometimes the Ubuntu "load screen" with the dots that light sequentially under the Ubuntu name and logo)
    It just gets to the last(?) step, and instead of a "desktop", I have a black screen.

    Even f4 did not work, (neither with external monitor, nor with only the native laptop display.)
    I will now try the alternate distro mentioned by Leeky.

    I'll keep you posted, though it may be a couple of days before I can get back.

    btw Leeky...
    No "Safe Graphics Mode" listed

    After re-reading... looks like the alternative is install only, not live... bummer.
    So... how do I get to "live"?
  6. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    is there a prompt on it?

    try entering login user which should prompt for the password; then enter startx
  7. B00kWyrm

    B00kWyrm TechSpot Paladin Topic Starter Posts: 1,436   +37

    No... the screen is completely black.
    No prompt.
  8. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    Alternative is install only I'm afraid.

    As for not seeing the menu, thats partly my fault as missed one important fact!

    As The disc first starts, you'll see a purple backround, with a keyboard icon at the bottom of it alongside a star...... I usually hit spacebar, or enter (I think both work) and it will then drop into the menu where you can (hopefully) select F4 and then safe graphics mode.
  9. B00kWyrm

    B00kWyrm TechSpot Paladin Topic Starter Posts: 1,436   +37

    Okay Leeky... I am stumped... TWO areas of Question...
    The first is Ubuntu, and the second is Knoppix and "mounting" an NTFS volume.

    Re Ubuntu
    I formatted the Key with "HP USB Disk Storage Format Tool".
    When I try to boot Ubuntu with the thumb, I never see a star or keyboard.
    The first screen I see has the Ubuntu name and logo, is labeled Installer Boot Menu
    and offers these options...
    • Persistent Mode
    • LiveMode
    • Install
    • File Integrity Check
    • Memory Test
    • Advanced Options
    Selecting Advanced options, I have none available, esc returns to previous menu.
    Selecting Persistent Mode, or Live Mode, I have several screens of text scroll by before coming to a screen with the Ubuntu name and logo, and the dots that change from white to red and then back again.
    In Persistent Mode, the garbled graphics are at the center of the screen before the screen goes dark. (a few "larger" red and white rectangles)
    In Live Mode, the garbled graphics are scattered all over the screen (many "small" red/white rectangles or squares).
    I don't know what to do next.

    But, meanwhile I have tried the Knoppix approach put forth by LookingAround as a tool for filesystem recovery.
    The Knoppix would load, but I could not "mount" sda1.
    Do you know if that was because my c drive is NTFS?
  10. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    Ref: Knoppix...
    Could you open terminal and type the following:

    the l after the - is a lowercase L.

     sudo /sbin/fdisk -l
    cat /etc/fstab
    I just want to make sure its setup before advising you further.

    Linux, as far as I am aware reads pretty much all partitions you could throw at it. In my Linux installs I've always had my Windows NTFS partitions readable. Its most likely a "noauto" option causing the NTFS partition from not automatically mounting on bootup.

    Ref Ubuntu:

    I'll have to have a look, as the recommended advice above is how I did it. I'll fire up my USB stick and see exactly how it does it on my laptop.

    EDIT: Using the USB stick, when you get to the Installer menu (with persistent etc on it), hit the tab button (a load of text will appear at the bottom of the screen) and add the following:

    There is no need to add the leading - as its there already.
    You can also try the same approach as directly above using this command:
  11. B00kWyrm

    B00kWyrm TechSpot Paladin Topic Starter Posts: 1,436   +37

    Re: Knoppix
    This looks scarey! This is a good disk that I am trying to look at; I do not want to fdisk it!
    I am not sure what the "-l" switch is supposed to do. :confused:
    Please tell me what this is doing.

    I'll get back to you on the Ubuntu.
    Thanks for the support. :grinthumb
  12. Leeky

    Leeky TS Evangelist Posts: 3,797   +117


    The first command is to show me your discs according to fdisk. It makes absolutely no changes, its just so I can see what discs you have so I can ensure I tell you the correct disc. If your 100% confident its sda1 I can assume this as well. If its been partitioned by default with W7 though, its likely your C is in fact sda2. I swore I read it was XP, but I now can't find where I read it. :haha:

    For example, the command on my PC (Slackware 13.1):

    root@(none):~# /sbin/fdisk -l
    Disk /dev/sda: 16.1 GB, 16106127360 bytes
    255 heads, 63 sectors/track, 1958 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x741a55de
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1        1698    13639153+  83  Linux
    /dev/sda2            1699        1958     2088450   82  Linux swap
    Fdisk is only dangerous when you write changes to it. But your not actually using it in the manner in which your believing - if that makes sense. lol. (You want to be worried when your using the command "fdisk /dev/sda" as your then telling fdisk to open up with your 1st hard drive, to make changes).

    The 2nd command is to display your fstab, so I can see if your partition is there like I suspect, but needs manually "mounting" in order to be readable.
  13. B00kWyrm

    B00kWyrm TechSpot Paladin Topic Starter Posts: 1,436   +37

    a-HA! -l = list! <whew / relief>
    That makes sense now!
    I am running an xp system, and (at one point) had an option to mount sda1 but it failed.
    I will see what happens and get back to you.
    Might take me a while though.
    Again, I appreciate the support!
  14. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    No worries, when you do the command "cat /etc/fstab" in terminal, you'll open up your fstab file with all your media devices (hdd/floppy/cd/dvd etc etc). Hunt for sda1, if its there, check to see if the option "noauto" is written. If it is, its basically not mounting on entering X.

    So you just need the following command to mount it...

     mount /mnt/sda1
    It should then mount, assuming sda1 is correct for your XP partition.

    If you want it available all the time, then with your favourite editor, open up the file, and remove the "noauto" tag to make it mount when X starts. :)

     sudo gedit /etc/fstab
    will open it up in gedit for you to remove the "noauto" tag should you need too. I would recommend leaving it to mount on demand rather than automatically though, unless you specifically need access to it all the time.
  15. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    using just mount will show what IS currently mounted

    cat /etc/fstab will show what known devices can be mounted.

    /var/log/boot.log or /var/log/messages
    has the device discovery messages were the SDAx & HDAx are discovered and the
    logs can be reviewed using more /var/log/$thelogname (provide the specific file name as the argument)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...