Unable to install drivers on Optiplex GX280

By bwarren97 ยท 10 replies
May 10, 2014
Post New Reply
  1. I have upgraded a Dell Optiplex GX280 to Windows Vista successfully, however I cannot get a couple drivers to install correctly.

    First off, I have no idea why, but I was able to install the SoundMAX audio driver perfectly fine on the first time I installed Vista (I had to reinstall with a bigger hard disk), and this time I have to manually run the setup program and it comes up with "The audio drivers do not support your computer hardware". I have tried rebooting the machine multiple times and still get the same result.
    Driver I use: http://support.lenovo.com/en_US/detail.page?LegacyDocID=MIGR-68015

    The other issue is the video driver. I have AMD Radeon X300/X550 Series (as stated by the machine. The graphics chip doesn't have any label on it whatsoever as far as I have seen), and it is currently using the Microsoft version of the driver. That's fine and dandy, but all it does is run the basic functions and I can't get the TV output to work. So downloading and installing AMD Catalyst automatically gives me the correct driver software. All goes well until it starts doing the Install Manager, it says "Application Install: install package failure!". Here is the log that it comes up with: http://puu.sh/8HyCq.xml

    ... I am still downloading updates (still in SP1 at the moment), so that might explain the video driver problem, but that doesn't explain why the sound driver suddenly won't work.

    One thing to note: I know this isn't the best machine to be using, but getting a better one is not an option at the moment. I deal with what I have.
  2. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +242

    Why have you not tried the Dell Support Site? You maybe able to find drivers their for your computer.
  3. bwarren97

    bwarren97 TS Enthusiast Topic Starter Posts: 60

    I looked on the support site, and they do not have drivers for Windows Vista. Just up to Windows XP
  4. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +242

  5. bwarren97

    bwarren97 TS Enthusiast Topic Starter Posts: 60

    I'm sure it would be best if I was able to use the AMD software somehow... but I'll see about that as soon as I can. Doing another round of updates right now
  6. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +242

    Ok Slimdrivers will give AMD Drivers for your video chip. Well good luck . Let us know if it helped you out.
  7. bwarren97

    bwarren97 TS Enthusiast Topic Starter Posts: 60

    Well, Windows seems to have found the correct drivers after another set of updates. LOL Windows update is so helpful.

    Thanks for the advice, though. :D I think I have the problem fixed

    EDIT: Okay, so it turns out I still don't have the Catalyst Control Center, which I believe I need in order to get the TV output working. I'll wait a while for updates to work and stuff, and then I'll try installing again. If all else fails, I will try that third-party driver
    Last edited: May 11, 2014
  8. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +242

    Cool good to hear, Have you tried the AMD site for the Catalyst Control Center?
  9. Ricky Morawski

    Ricky Morawski TS Member

    Usually, you won't need CCC unless you are getting pretty deep into the settings of your card. I'm pretty sure Win+X or Win+P should work fine for getting an external monitor working, that is, if it didn't do it automatically. Those keyboard shortcuts work for Windows 7, but I don't know about Vista. I'd imagine they work on Vista too. As for drivers, if you're still having problems, I like to use Smart Defrag by IObit, that usually does a good job of finding all my hardware, I just use it when I'm too lazy to go to the manufacturer's website, or just want the newest drivers. Be careful though, as with all IObit programs, they make sure to do everything they can to get their toolbar in there, and I'm pretty sure you wouldn't want that.
  10. bwarren97

    bwarren97 TS Enthusiast Topic Starter Posts: 60

    That is where I downloaded the software from, and it's the latest version.

    Also, I think I had tried using Windows to output through the S-Video before, and it didn't work. My sister's laptop has Windows XP and I had to use Catalyst to do that.

    It seems now that the video card I was trying to use didn't perform as well as I had hoped, so I switched it out with a newer one. Windows doesn't have a driver for this, so this time I do need Catalyst or some way to get the driver for the chip.

    Do you think it would help if I used a previous version of the software? I know how bad Vista can be with certain software applications (I've had troubles with Minecraft in the past, and that's like the best game ever)

    EDIT: After running the installer with the new video chip, it installed just fine. And CCC works, too. I really don't understand how this is so, but I will not complain. Thanks for helping, though LOL
    Last edited: May 12, 2014
    Cobalt006 likes this.
  11. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +242

    The new card is more up to date. This most likely why it works better. Yes vista can be a pain. Glad it work out for you.(y)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...