Unable to install Ethernet device driver

By joshuamays
Jul 12, 2009
  1. just built a new pc

    mobo - asus rampage II gene

    running winxp pro

    the ethernet device is detected, yet the driver cannot be installed

    all other drivers have been installed

    within the device manger the ethernet is the only driver left with a yellow question

    ive tried to install the driver by aloocating the direct file path to the existing LAN floder on the mobo cd no luck tried to update using winxp disc no luck

    what else can do to get my ethernet driver operational?

  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) Have you gone to ASUS's download page for the drivers for your motherboard?

    2) If problem persists Check if Windows reports any problem devices
    • First make sure all your devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
  3. joshuamays

    joshuamays TS Enthusiast Topic Starter Posts: 137

    was able to download a working ethernet driver from www.usa.asus.com

    as for why my mobo cd wasnt supporting the driver install is beyond me.

    my dream machine is now fully operational

    thx 4 reply
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...