Undeletable file, Ubuntu

By UnWarierMage224 ยท 7 replies
Apr 28, 2008
  1. Hi guys,

    another problem. A file I sent to the trash won't delete. I right-click on the file, say "delete from trash" and get an error "permission denied"...

    I even tried logging in as root: opened up a terminal, typed sudo su, left the terminal open, and tried to delete the file as I did above. That didn't work.

    Scanned with AVAST. No viruses.

    What to do...

  2. Somehow a file owned by root is probably in there.

    Open a terminal and do:

    sudo rm -rf ~/.Trash/*

    Note: Please read up on what this command actually does before running it. rm is a dangerous command when run as root or with sudo.

    Sudo only works within the terminal you have opened until it is closed or until the sudo session expires.

    Ubuntu is a Linux distribution and this is a simple permissions issue, why are you scanning for viruses on a Linux box??!!
  3. UnWarierMage224

    UnWarierMage224 TS Rookie Topic Starter Posts: 69

    Hi caravel,

    I just tried that exact command. The file won't go away. I even tried logging in as sudo su and deleting it, error received is:

    "There was an error deleting temp.linux-i686-2.5. Error removing file: permission denied."

    The program these files came from was a botched installation of listen-0.5.

  4. UnWarierMage224

    UnWarierMage224 TS Rookie Topic Starter Posts: 69

    Update on this problem:

    buried in the listen-0.5 folder is the build folder, in that is the mmkeys folder. In the mmkeys folder there are these two folders:


    It's these two folders that can't be deleted (even while in sudo su)... Right-clicking on them the "Delete from Trash" option is grayed out. Even trying to change their permissions I get the following error:

    "Sorry, couldn't change the permissions of "temp.linux-i686-2.5": Operation not supported by backend".. same error for that lib.linux file. Can't change them even while under sudo su...

    What to do??

    EDIT: More strangeness... output of rm command:
    rm: cannot remove `/root/.Trash/listen-0.5/mmkeys/build/lib.linux-i686-2.5': No such file or directory
    rm: cannot remove `/root/.Trash/listen-0.5/mmkeys/build/temp.linux-i686-2.5': No such file or directory

    Problem is it still shows up that in the trash I have an item (graphically) even though according to this no item exists....

  5. You're trying to remove it from the root user's .Trash. Remove it from your .Trash. Do the following:

    sudo nautilus

    Go to your home folder and CTRL+H to show hidden files and folders. Go into the .Trash folder and clear it out.
  6. UnWarierMage224

    UnWarierMage224 TS Rookie Topic Starter Posts: 69

    Awesome, that worked!

    Thank you!

  7. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    When installing packages on Linux, the process typically goes like
    1. cd xxx
    2. ./configure
    3. make
    4. make install
    If you no longer want that package, or wish to reverse the install, the process usually is
    1. cd xxx
    2. make uninstall

    TRASH is a Windows concept, not a Linux concept and suggest,
    When in Rome, do as the Romans do :)
  8. gnome has a deleted files applet known as the .Trash applet. It is useful for those that might accidentally delete something, because they can restore it later. In Windows it's known as the "Recycle Bin" and is not a Windows concept as even very early versions of Amiga OS had the "Trashcan" which is basically the same thing. The recylce bin was introduced into Windows 95 whereas the Amiga OS Trashcan existed long before.

    The package listen-0.5 is actually in the Ubuntu repositaries, so no need to do a manual install.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...