Build a PC USB 2.0 storage device malfunctioned in Windows XP. Unknown Device!?!

Not open for further replies.
hi, heres my problem:

* USB 2.0 doesnt work when plug in to USB port. XP gives message Unknown USB device. USB has malfunctioned..

* from device manager here is my USB devices.

SiS 7001 PCI to USB Open Host Controller
SiS 7001 PCI to USB Open Host Controller
SiS PCI to USB Enhanced Host Controller
USB 2.0 Root Hub
USB Root Hub
USB Root Hub

I have SP2 installed, did reformat my hard drive and install fresh windows XP. all the drivers are up to date and even the BIOS.

What is causing this problem? Any help would be greatly appreciated...

PS. When i disable USB 2.0 Root hub and SiS PCI to USB Enhance Host Controller. The storage drives work in USB 1.1. My external usb drive is a HITACHI 10 G hard drive.


Posts: 1,994   +1
recently I had a friend who expierienced the same problem with a Nforce chipset after a fresh install of XP with SP2. even though SP1 and SP2 insclude the drivers for USB2.0 his usb 2.0 devices werent working. he ahd to go to the Motherboard makers site and download the USB 2.0 drivers and then it worked.


Posts: 436   +0
i STILL can't get my usb 2.0 to work, even after downloading all kinds of drivers and microsfot updates, etc. when i plug in my microadvantage usb little tiny drive, it says NON HIGH SPEED USB PORT, yadda yadda yadda. never been able to fix it, takes 15 mins to copy a movie to the drive. in device manager, it even SAYS 2.0 hub (or whatever), but it still doesnt work like 2.0. any help?


Posts: 1,994   +1
are you using the USB port on the back of the computer or ones that are located on the front? if they are ones on the front then the problem could be one of two things. 1. the front USB ports are not properly hooked up. 2. the case you are using doesnt support USB2.0 and only has USB 1.1 cables for the front connections.
  • Thread Starter Thread Starter
  • #6
i downloaded the latest SiS drivers for my motherboard still getting the same results.. What i dont get is these usb ports used to work on my computer. tried front usb ports ( 2 ports ) and the back ones.. (4 ports)
I also install a fresh copy of windows xp in a different partition with all the required drivers for my usb 2.0 and still get the same results..

Any ideas?



Posts: 436   +0
it might not help, but microsoft has a usb 2.0 driver on their update site. you will have to search for it, as it will not be automatic.
Hi Liam_mitchell ... wonder if you have resolved the problem. I have been trying to fix this problem for a few days without any luck. Thanks.
Hi, sorry for the delay inm replying!

No i did not manage to resolve the problem with the usb ports!
Have spent hours looking for a fix!
Re-formated :(
Tried default usb drivers
Been messing around and nothing seems to work!
i have sent the laptop back for repair,:(:(

Sorry i could not help :)
Hi Liam,
Thanks for your reply. I have also reformated a few times. I am down to my last try. I will let you know what my result is.
I solved this issue on my machine

After removing and reinstalling all of the USB devices in safe mode (to no avail), I figured out that the "Sis PCI to USB Enhanced host controller" was the problem. In its properties, I disabled it and all of a sudden my computer recognized all of my USB 2.0 devices.

Good luck! I hope this works for you, too

Frank Smith

Posts: 75   +0
usb2.0 I un-installed all usb ports, then used refreshed and then pointed to the MS USB2.0 and have had NO USB problems.. which was corrected for XP SP1.
; Copyright 2001
; Microsoft Corporation
; USB 2.0 Add-On Driver support
; For Windows XP - via Windows Update

signature="$Windows NT$"
;Was DriverVer=11/01/2001,5.1.2600.0
very small file 291kb

Frank Smith

Posts: 75   +0
some older devices are usb 1.1 only (Apacer HandyDrive supports USB1.1 specifications only) make sure your useing the 1.1 slots and not usb 2.0 slots
This works...

Ok, I have a similar problem.
I have a number of USB devices, some work with USB1.1 some with USB2.
I recently found that I needed some extra USB ports in my laptop so I put a standard PCI USB2 card in the docking station.

A USB2 External Hard Drive that works fine in the USB1.1 ports will not work in the new ports at USB2 speeds.

All other USB1.1 devices are recognised and work perfectly in both the old USB1.1 and new USB2 ports.

The USB2 drive still works (albeit at slower speeds) in the old USB2 ports

Following advice on several tech boards such as this, I temporarily disabled the "Standard Enhanced PCI to USB Host Controller" in device manager, I did not disable any of the Universal controllers or any of the new 'ALi' host controllers (Which are the ones for the card in question.).
I did not disable any of the root hubs.

My drive then worked in the new USB2 ports at USB1.1 speeds.

I went to the ALi website and got a driver installation util (Sadly a .exe file rather than just the required driver disk) and ran it followed by the standard reboot.

No Change, I then manually went it to update the driver on the Enhanced host controller via device manager.

It still defaulted to the standard driver, so I had to specify the ALi version myself (So no automatic install).

One more reboot and my drive is working at USB2 speeds.

So, all you need is the right variant of the driver for your Enhanced PCI to USB controller.

As far as I can tell, all the major chipmakers have their own sets, I went through this on one of my other systems (Just for the hell of it) and had to get the VIA chipset version - this now also works.

Hope this helps.


Posts: 10   +0
MShep... u r lucky... ussually this problem in subject happens when hub doesnt have enough power to support all the devices u hook up to it. very rarely you can solve the issue by updating the driver... most likely you would need to get a new hub with a power supply for it... :)... :bounce:
USB Power

True enough, but in my case all of my USB2 devices are externally powered.

Definitely something worth checking before playing with drivers though.


Posts: 436   +0
i had that problem on my msi k8t-neo-fsr motherboard, but now on my asus k8n nforce 250 board usb 2.0 is no problem.
I realise this thread is a couple of months old but I figured I might be able to help people out a little.

I had the same problem this last week. All of a sudden my external USB 2 HDD crashed. Win XP kept reporting a device malfunction and the drive was unrecognised. Device manager kept showing an 'unknown device' and any attempt to reinstall or update drivers would fail. I wasn't very happy as the drive is only six months old and contains all my website backups.

I discovered (by accident) that I was able to plug USB 1.1 devices into USB 1.1 and USB 2 ports without a problem. USB 2 devices, including my HDD, would run (albeit slowly) in USB 1.1 ports but would "malfunction" when connected to USB 2 ports.

Now I apologise to anyone who wants to learn some new computer skills but the solution turns out to be very "non-tech" - but I swear this worked for me as strange as it might sound.

Shutdown your PC. Now physically disconnect it from the mains power supply. This apparently clears any residual power on the motherboard. Leave it disconnected for a while (I recommend 30 minutes as that's how long I waited). Reconnect everything, boot up your PC and enjoy your fully functioning USB 2 ports and devices again!

Right now I'm able to use all of my USB 2 devices in the USB 2 ports without a problem. How long will this continue? No idea. But I know what to do if/when it happens again.

Notebook users with the same problem will need to remove the battery as well as mains power, but I understand this method will still work.


Posts: 51   +0
Umm, i dont if this will work, but on my old pc, i used to get this all the time when i plugged usb devices in, turned out, my power supply was not powerfull enough and there wasnt enough power to supply the USB port, so they we malfuctioning.

I''d recommend taking out all uncessary devices, and if still no joy, upgrade your power supply.

This is only something that could work, i dont know if its the same thing as i had.

The fix/cure I gave relates specifically to machines that have always had a sufficient power supply. In my case, the error occured 'out of the blue' on a PC that had always maintained good power and nothing new had been added that might have exceeded its capacity.

I would agree though that USB powered devices being added over time will put extra strain on a machines PSU and that users should be aware of this being a possibility.
unknown device problem - fixed !!!

I was having the problem of my 2 week old, 2Gb USB 2.0 Flash drive suddenly becoming an 'unknown device' when I inserted it into any one of my USB ports. :confused:

All my other usb devices were working fine (printer, scanner, 2nd usb drive and mp3 players). The device mentioned previoulsy just refused to work.

When I tried the fix suggested by Technophobe, my usb flash drive was detected instantly and recognised as it should have been.

Tecnophobe, you're a champion :angel: Thanks heaps !!!

Matt (bluegreen) :grinthumb
I hate to say Me Too!! but I am also having the same problem with a laptop drive in a usb adapter case.

I worked for about a month on one pc but then I started getting the blasted unknown device messages, so then I started using a different pc and shared out the drive and that lasted for about a month.
well sad to say I am running out of PC's the plug in and share the drive.

I also tried the external power supply and that didn't help.

I also tried the driver disk and a uninstall and reinstall cycle and that fixed one pc but of course not the one I like to.

Just another good reason why linux is such a better OS then win.

Not open for further replies.