USB 2.0 storage device malfunctioned in Windows XP. Unknown Device!?!

By viciouz88 · 73 replies
Mar 23, 2005
  1. Rolfman

    Rolfman TS Enthusiast Posts: 95

    go to your usb's anufacturers website and see if they have a fix for it..
    this happened with my ipod shuffle (error 1480) i went to google and typed the error , and they sent me to the apple , they gave me a software to repare it and
    bamm!!.. good *** new.

    same thing my USB 2.o was giving me unknown device.
  2. totus

    totus TS Rookie

    Identical Issue with SiS

    Did you find a resolution to this problem?

    I'm having the exact issue with SiS controllers on a Shuttle XPS SS51G Windows XP Pro SP2. All USB ports work properly unless I plug in a device classified as a "mass storage device". They all come up as unknown and malfuctioned. The drives are fine and work on other systems.

  3. nork

    nork TS Maniac Posts: 306

    Reading through this thread takes a lot of time, but there is a lot of good info here. In addition, i would say that most of the tricks and ways to repair usb have been mentioned here in this thread.
    The most popular one being technophobe's post, here:

    The bottom line is that often if you unhook all your usb hardware, remove all your usb drivers, let the pc sit for a while, turned off, quite a while sometimes, like a half hour, then boot up and re-install your drivers, that will take care of almost all issues.
    There is one item i see, though, that hasnt been mentioned. I have a few pcs and one pc i have i have trouble quite often when i plug a usb2 hard drive into the usb2 ports on the front of the pc. Yet when the same drive is plugged into the back of the pc then all is well. Now its the same usb2, direct to the mobo, so dont ask me why but it works fine in the back so i leave it there and plug other items in the front, thats how weird usb can be.
    Another thing that i dont think i have seen mentioned here, and if it has then please forgive, but sometimes it just pays to install a usb2 pci card. Sometimes that works better than using the usb on the mobo.
    And i have even see usb problems disappear by turning the pc off, unhooking the pc from the wall or wherever its main cord is, letting the pc sit for a while and then push the case on\off button in and hold it in for a few minutes. What that does is clear the motherboard of any electrical charges in it and somehow i have seen that help with usb and other issues.
  4. Crosscourt

    Crosscourt TS Rookie Posts: 72

  5. gbalkam

    gbalkam TS Rookie Posts: 22

    Unknown Device USB 2.0 Flash Drive error

    From what I see here people, you are barking up the wrong tree. It isn't windows you should be working on fixing, What you need to look for, is a way to restore the usb device to factory default. Most likely, and the origional poster will have to confirm this.. The USB flash drive was removed without shutting it down using "safely remove hardware devise" and it fubared something on the device that allows it to connect to usb 2.0. Try the USB drive in a USB 1.1 port. (like on an older computer) If it works there.. that is the problem. Buy an older usb card for 1.1, buy a new flash drive, or keep looking (such as I am) to see if there is a way to restore the defaults as it came out of the factory. My theory is if something fried, it should not work at all, since it does work on usb 1.1, then perhaps there is just a setting I can fix with a flash update? All I have to do is find it or find out that it does not exist, and there is something on the hardware that is fluffed up.
  6. nork

    nork TS Maniac Posts: 306

    Pretty sure nobodys barking up the wrong tree, lol. I believe that there are different issues with different chipsets on different mobos and different electronics and different chips on pci and onboard usb chips. So there are different solutions.

    Another thing to do is try the usb2 product on, simply, another usb2 outlet, wether on the same pc or another pc. And there is certainly nothing wrong with trying it on a usb1.1 connector.

    As for getting back to factory default i imagine its a simple matter of reformatting the drive, wether in a usb1, usb1.1 or usb2.0 port. That is, if its not broken in the first place! Some of these drivers can be easily broken.
  7. gbalkam

    gbalkam TS Rookie Posts: 22

    reformat usb drive

    Sorry, that will not work, been there, done that, including a llf (low level format) it comes up as unknown device when connected to USB 2.0.
    Like I said earlier, it works fine in USB 1.1
    Even tried going to computer management and remounting media to the drive, didnt work, soooo
    as I stated, it is either a firmware flash of the drive that I need to find, or use the drive only in USB 1.1
    The problem is in the USB Flash drive itself. I'm just glad that it has been made to work with 1.1 as failsafe. I just wonder, if there is a flash utility to restore factory defaults. I'll keep looking, and post if i find one.
  8. gbalkam

    gbalkam TS Rookie Posts: 22

    USB 2.0 issue

    conversation with an expert in flash drives from
    eprovided: I think it has circuit damage now.
    averybaddog: that is what i was thinking too. is there a way to fix that or just buy another flash drive?
    averybaddog: I was going to look for a firmware flash
    eprovided: We can recover data from them if needed but not worth fixing.
    averybaddog: no data, i moved it and low level formatted it.
    averybaddog: so the question was, just to see if i could get it working again, for the sake of learning to do it
    eprovided: you can try
    averybaddog: thanks.
    **end quote**
    So since the flash drive was like $10. I can just buy another to play with on the 2.0 port, or just continue using the one i have at 1.1 speed. OR. play with flashing to see if it can be recovered (usb 2.0 functionality)
  9. Rolfman

    Rolfman TS Enthusiast Posts: 95

    Dude im sorry but...... that makes absolutely no sense.

    If you let the computer sit there for a while , this is what happens.:

    The pc remains scanning for any driver software , until she finds the Microsoft driver
    when the pc finds the driver ... it will eventually install it . You are not helping at all by
    giving tips about a solution found while troubleshooting a different brand. Stick to the original
    poster's peripherals and find out the solution based on those parameters .

    I think that the best way would be by going to the manufacturers site and obtaining a fix for it. Or at least check the FAQ in search for known compatibility issues with windows XP.

    Thats one solution....... the other one is pretty much covered on technophobes post.
  10. gbalkam

    gbalkam TS Rookie Posts: 22

    USB flash storage device

    sorry, I was thinking it was a usb flash drive, not a usb external hard drive. My bad.
  11. Rolfman

    Rolfman TS Enthusiast Posts: 95

    Who the hell is talking about that ?
    Unpluggin while hot?

    you´ve gotten way off......

    Do not trample on the next guys suggestion just because you think you got it.
    Take look at nork´s answers he is clearlly ofering sugestions & solutions without attempting to diminish the other members.

    Nouddy is barking at wrong trees or forgetting their native language , we are all
    working on the original poster best interest.

    Listen there are only 2 people here on techspot
    that are capable of keeping the last word , those are :

    The original poster saying ¨ I FIXED IT¨
    or JULIO FRANCO the owner of everything....

    read the main post !!!

    that has nothing to do with what you are saying....
    and that guy is still stuck on his problem....

    By the way use the EDIT button ...Stop Double posting.
  12. mitche724

    mitche724 TS Rookie

    I have the same problem as all the rest of you - my vx9900 wont get recognized by my computer.

    now, I've tried a whole bunch of things, including resetting my phone, reprogramming it, reinstalling the lg usb drivers like 5 or so times to my computer (compaq presario v4000), and using technoprobe's method of unplugging my laptop and removing the battery for like 50 minutes.

    Unfortunately, my problem still remains, as every time I connect my vx9900 to the computer (using the MEK usb plug that I got like 2 years ago) the computer says "usb device malfunctioned...." etc.

    I had an enV that used to get picked up by the computer using the same usb cable (and was able to transfer data with bitpim), but the phone got water damage, so currently I am using a brand new replacement enV. Sometimes the phone, when plugged in, will not generate that
    error message on my computer, but then when I open bitpim, it doesn't recognize the phone.

    so do any of you have suggestions for further actions? do you think this problem could originate from the way the phone is sending out its signal? or is it simply a usb problem with the computer?
  13. sub3marathonman

    sub3marathonman TS Rookie

    OK, his post was over two years ago, and I KNEW something that simple could not possibly work. I resisted for a few days, but finally decided to try it. Problem Solved. And I joined this forum just to tell technophobe thank you and to reinforce to people that this actually worked.
  14. The Nemesis

    The Nemesis TS Rookie

    Hard drive : Western Digital - WD2500XMS-00

    I can pinpoint my problem, of "one of the devices has malfunctioned", to my Vista UMPC switching off without safely uninstalling it.

    Technophobes method didn't help me.

    I have around 180GB of downloaded material,. (And not the sort of material that can be viewed in public,.. like Baboons wrestling Ostriches) I don't have that stuff backed up. It was the back up. I just don't want to lose the files.

    Iv'e tried using it on my desktop XP, in various ports. Iv'e read the first four pages. I'm not changing port types. I know it's the device and not the PC. Because every other device works fine. And iv'e tried on more than one PC.

    A few people have suggested plugging the hard drive in, but even after that my toaster still displayed the error message.

    I'm phoning Western Digital tomorrow to see if they can come up with a pheasable solution rather then "I am verry sorry but there is nothing we can do, (because our company make millions of these but we don't know how to fix them, we could take the data off for you and install it on another harddrive at a cost,. but we don't want to do that) but you can buy a new one because it has malfunctioned"

    I'm going to ask them for the installation drivers and manually install the device, because the core problem is that it can't find the device driver to install or recognioze the device for what it is. I tried changing the hardware profile so the device reads as an external hard drive, but it still has no driver to work the device, meaning all that does is re-title it.

    I'm really banking now on Western Digital saying that even though the device can't be repaired we can still take the data off.

    I don't exactly want a member of the western digital repair team see a file named Hot_latino_drinks_horse_cum.avi

    But, I'll cross that bridge when I get to it.
  15. The Nemesis

    The Nemesis TS Rookie

    I phoned up,. To no Avail. They said it can't be fixed ATALL if you

    1. Right click the "My computer" Icon
    2. Left click "Manage"
    3. Left click "Disk Management"

    "Do you see your hard drive. If No,. then phone up to see if it can be replaced via warranty"

    Note : All Data maybe recovered by dedicated data recovery companies. If you have a western digital hard drive. After recovering the date you can still claim your hard drive under warranty. Some data may not be recovered. Some are no fee no data. It will cost, and will be not refunded via warranty.

    Check WDC's site, under "Support" - then "Data Recovery" for a list of data recovery specialists.

    Hope this info helps.
  16. greenhart52

    greenhart52 TS Rookie

    Another method to fix the USB "Unrecognised Device" probelm

    First, thanks everyone for posting. This is a really sticky problem. I had the same problem with a USB HDD. The problem just started out of the blue, but I believe it was when I was running a program that was trying to open the HDD (Windows Backup) at the same time I was trying to disconnect it...

    I tried the method detailed - unplug the PC from the power, wait 30 minutes etc. This DID NOT work for me. Still had an "Unknown Device" in Device Mgr.

    HOWEVER, what did work for me was:

    Open Device Manager
    Uninstall the "Unknown Device" (Right-click, Uninstall)
    Re-Scan for new devices

    And Hey Presto all was well again!!!

    NOW, whether the fact that I had powered down the PC beforehand mattered, I do not know...


    ARRGGGHHHH! After much stuffing around I found that it was a faulty connector all along! I squeezed the socket (on the end of a cable) so that it was a tighter fit and now it works fine every time!!!
  17. prj

    prj TS Rookie

    Hats off and kudos to you Technophobe!

    No apologies needed, as someone who actually repairs PCs for a living I'm always glad to learn a new trick and it worked a treat on my own PC which had been bugging me for a week now.

    I've been through all the updating and reloading drivers thing and had eliminated hardware failure by booting into Linux and everything working fine, but had not completely disconnected at the mains. EDIT - Why does it work in Linux but not Windows XP?

    Thank you, a simple elegant solution.

  18. David40

    David40 TS Member Posts: 27

    are you using the USB port on the back of the computer or ones that are located on the front? if they are ones on the front then the problem could be one of two things. 1. the front USB ports are not properly hooked up. 2. the case you are using doesnt support USB2.0 and only has USB 1.1 cables for the front connections.

    Ha, Cool, I had the same problem when I plug my digital camera in the front ports. I tried the rear ports and it worked. I'm going to pick up a short USB extension to leave hanging out so I don't need to pull the tower out every time I want to download pictures off my camera.
    Thanks ISS for that suggestion.
  19. powderkira17

    powderkira17 TS Rookie

    my kingston is having the same problem i think my cousin did it can you tell me how to fix it?

    :D it works i just pushed on the jump drive and it in places and it worked again:D:eek::confused: that was my emotion sycle
  20. artoodeeto

    artoodeeto TS Rookie

    similar issue with USB DVD drive

    I've been reading through these posts, and while I'm at work right now (unable to try a few of the proposed solutions), I thought I'd toss my issue out here and see if any further ideas come of it.
    I've got Windows Vista x64 Ultimate on an Asus Crosshair II formula board with a Thermaltake 650W PSU, AMD phenom II x4 processor, nvidia geforce 285 video card...and a laptop size DVD burner which used to be plugged in via an IDE converter, and for which I recently bought an external USB case. It uses 2 USB ports - 1 is for data, and the 2nd is for power.
    Initially, I plugged the burner into my two front panel ports as they were the most convenient to ascertain whether the case worked. It did. Drive showed up as an external, drive D, no issues.
    I then took my computer apart (I custom-built my case and needed to work on it) and put it back together a couple weeks later. This time around, I ran the USB cables for the drive around to the back. All of a sudden, the drive is an "Unknown Device."
    I'm first going to try hooking it to an extra set of "front panel" USB ports I have that I can run to a currently unused USB header on the motherboard. If that doesn't work I'll try the power suggestion posted about 3 years ago...
    Incidentally, I have 6 USB ports on the back, but with this drive plugged in am only using 4 of them. I have a regular 500GB external hard drive running off one of the front USB ports that's worked just fine throughout all of this. It has its own power supply.
    Only thing that makes any sense to me based on all my reading thus far is the "Unknown Device" error came up b/c of a lack of sufficient power to the DVD drive. Maybe all 6 ports on the back are hardwired into one header, while the front ports are just 2 sharing one header. So I'm hoping that by running it off a duplicate of the front port configuration, that'll solve the problem. We'll see...
  21. artoodeeto

    artoodeeto TS Rookie

    Update to my message from yesterday - I plugged the drive in using a dual set of USB plugs running to one of the extra m/b headers. Turned the computer back on, and voila! it worked.
    Again, only explanation I can think of is that the 6 ports on the back are sharing one power source, and so even if they're not all used, it's not enough power to run the drive. However, if there are only 2 ports sharing a single power source, it's enough. Weird...but that's what the evidence points to in my case.
    Hopefully this will help others too...if you're having similar issues and are reading this, good luck!
  22. tommyriantoro

    tommyriantoro TS Rookie

    the one with the intalled the driver manually works perfectly.
    thank you.:grinthumb
  23. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  24. ManQu

    ManQu TS Rookie

    My USB device error was caused by something blown in the southbridge,long story short ,was for me was to add a pci usb card.This worked for a further two years till i upgraded,even now the mobo is fine (gigabyte 939 3 gig) except for about weird.......
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...