1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB 2.0 storage device malfunctioned in Windows XP. Unknown Device!?!

By viciouz88 ยท 73 replies
Mar 23, 2005
  1. nork

    nork TS Maniac Posts: 306

    Technophobe, the fix you mentioned got me thinking. One trick you can use when you cant get your pc to boot is to disconnect the pc from the main power at the wall, just as you described, but hold the power on\off button in for about a minute. Then hook up and boot up. This often works and it seems to be related to what you are describing. Now the reason it works for what i am describing is that there is circuitry inside power supplies that gets "messed up" for lack of proper terminology, and the holding in the power on\off resets the internal circuitry of the power supply. I am thinking these are somehow related. It could be that some circuitry in not only the power supply could be at work here but also some circuitry on the motherboard as well. Its hard to say, only a guess, but there seems to possibly be some similarities here. Either way, if it works, it works, lol.
    Thanks for the tip!
  2. technophobe

    technophobe TS Rookie

    You're all very welcome!

    As you say, if it works, it works :)
  3. debstar41

    debstar41 TS Rookie

    Yep it worked

    i had the same problems as everyone else in this thread so i did what technophobe suggested, i turned off my computer disconnected the power waited thirty minutes and what do you know it all works again Thanks Technophobe ur a genius.
  4. BobZuruncle_1

    BobZuruncle_1 TS Rookie

    Thank You Thank You Thank You

    When it comes to dealing with windows xp errors it's never simple to resolve

    Rename this, delete oem blah blah blah inf that, patch this, fresh install that

    After so many years of being taught that I forgot that sometimes it the simple things that are the most profound

    This is the case with the USB mass storage device driver going south

    I searched for weeks and everyone had their own "solutions" none of which worked

    If it was suggested to wave a dead chicken over the box I would have done it (i was freaking out)

    What...? All I have to do is turn the computer off, unplug it, wait 30 minutes, replug and boot up

    I'm one of those types who leaves their computer on all the time so to just turn it off was not even on the radar screen

    Well I'm here to tell you THAT IS the fix

    After I did that everything came up like it should

    Again, thanks

  5. technophobe

    technophobe TS Rookie

    I'm just glad I was able to help someone... anyone... really, just one person finding a fix is good.

    And how did you know Bob was my uncle? ;)
  6. DeepBlack

    DeepBlack TS Rookie

    Thank You Technophobe!!!!!! It Worked!


    OMG! I can't believe that worked!!! You saved me hours of frustration!!!!!!

  7. technophobe

    technophobe TS Rookie

    You're welcome :)
  8. yuval_o

    yuval_o TS Rookie

    "unknown device"

    I had similar problem -while connecting usb devices I got errors,

    and I solved it by updating the bios version.
    I used MSI motherboard, and it solved few other problems as well.
  9. Mook30

    Mook30 TS Rookie

    Great Advice

    I just wanted to say that this works i got my external hardrive back and my printer, thank you for posting this tip.
  10. madjudge

    madjudge TS Rookie

    usb 2. fix works

    Just a word of thanks to technophobe. I had the identical problem and got advice from Sony to take everything off in safe mode and if that did not work to do a system recovery (just what I wanted to hear) and if that did not work to get the computer repaired.

    Incidentally, pulling the plug from the wall has been a useful technique with cordless phones, my multifunction HP printer, modems and other electrical items. It is important to remove the plug from the wall. Just removing the electrical cord from the back of the computer does not remove the charge that is probably located in the transformer (capacitator).
  11. gunnerhkjp

    gunnerhkjp TS Rookie


    I just registered to thank technophobe for solving my usb problem.
    Thank god google pointed me to your post (although it was on the second page of the search).

    They should put the solution on the first page of the computer manual.

    I would have NEVER come up with the solution on my own, and would probably have thrown the computer out the window.

    Thanks again!
  12. letteer

    letteer TS Rookie

    Thanks Everyone

    My usb nightmare began when I had my EOS camera hooked to the computer and took a shot. Most everything became an "unknown Device". I gave into tech support at Canon to no avail.Tried just about every fix I came across. Finally after so many hours of life never to be lived again :) All I had to do was unplug my computer for a couple of hours. This completely fixed all my USB problems. Thank you everyone for your posts.
  13. perereco

    perereco TS Rookie


    I just wanto to say hello to all and a big thanks for your tip. It saved my work day :)
  14. X-rock

    X-rock TS Rookie

    sorry, but I have another problem
    I have my optical mouse using USB port and it worked well, but suddenly it stop working, I check with 4 USB ports and none works
    I think my USB ports were all dead, but when I pluged my USB drive, it still worked well..
    and sometimes I tried to pluged the mouse again, and it worked for a while, but after that it stopped..

    so the problem is my mouse or my system ??

    thanks for all your help..
  15. nicpon

    nicpon TS Rookie

    My problem is very similar, but I haven't been so lucky to get it fixed. Same thing happened to all USB devices connected to my PC yesterday, they all stopped working and I'm getting bunch of error messages in XP sending me to troubleshooting(which is worth nothing). Anyway, after few hours, fresh reinstall I found out that unplugging power cord does help. But, it only helps for few seconds(at least in my case), sometimes minutes... For example, my laser mouse which lights up every time the PC boots up, stays on for only few seconds and then becomes unusable just as before. I left my PC unplugged all night and this morning I was able to get USB working literally for 20 seconds. I know for sure that my mouse is working properly cause I tested it on other PC. The things is that there is something else, besides residual power on MB that creates all this bs. The residual power is one thing and that other thing-I haven't figure out that one yet?! Any other ideas on next step?

    I have to say that while I was troubleshooting for that I noticed that my case was very static. I checked grounding, outlets and everything seems to be fine. hmmmm
  16. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    if you have too many devices on your usb system, you may be drawing too much power than it can handle. add a usb card to plug in those extra devices.
  17. nicpon

    nicpon TS Rookie

    One USB at a time and 600W PSU. Like I said it has something to do with being so static. I managed today to get it up and running, but will see for how long. I will perform some testing and see what happens.
  18. cedar9

    cedar9 TS Rookie

    Technophobe, speaking as a borderline Luddite compared to most here, I'd just like to say you've just saved me tearing all my hair out and having to tell my work I've bust my memory stick. Thanks a million :)
  19. lady_leanne

    lady_leanne TS Rookie

    Hey all

    I have like USB Bluetooth dongle, and its been work great ever since i got it.
    Last night when i went to use it, it said that it wasnt recognised and had malfunctioned or something :(

    This is the case for both my laptop and pc. I have tried disconnecting everything, waiting 30 mins and reconnecting, unfortunetly it hasnt worked for me, im still getting the same message.

    Any help or ideas at all would be tremendously appreciated.

    Thanks, Leanne x
  20. louis45

    louis45 TS Rookie

    Malfunctioning USB Ports

    All, I tried every cure listed on the web to fix this on my pc. Initially all ports worked then suddenly the dreaded error message that all of the malfunctioned.

    I read one post about the incompatability of the case and the board on some pc's and opted to buy a pci to USB card. ( $13.00)

    I now have four functioning ports and wish I would have done this sooner to save time. Just so you know.
  21. Xunny

    Xunny TS Rookie


    I apologize if I've upped this thread from the dead, but I wish I could say this fix helped me. Unfortunately, it didn't seem to. Since it seems this is the only tech place with this issue I could find on Google that doesn't require payed registration, I felt like asking this here.

    I have an HP Pavilion zv6000 laptop, purchased in the late summer of 2005. For the last two years the USB ports have worked relatively fine, but then earlier this month I've been getting the "USB Device Not Recognized" pop-up bubble. I find that only three of my devices seem to work well. The printer works, the USB mouse works, and a small external laptop HD works (though it runs slow (I suspect it's stuck on USB1.1), it is still recognized), but two external HDs (both powered with their own power devices) I've been using for the last year, and an iPod fail to be recognized anymore. I've tried all peripherals in all the ports, but only the mouse, printer and the laptop HD work in any of them. I've tested out the HDs and the iPod on other computers, and they work fine.

    I think I have the same problem as Technophobe, in that it seems that devices that support USB1.1 work, but the ones that require USB2.0 come back as 'malfunctioned', even though the ports themselves should be USB2.0.

    I've tried a number of "fixes" found on Google:
    1. I uninstalled all USB devices in the device manager, and then restarted, but that didn't do anything. I tried it again in safe mode, but again that does nothing.
    2. I reinstalled Windows XP on my machine, and - to my extreme disappointment - the problem still comes up.
    3. I tried editing the registry. Half the suggestions don't seem to correspond with my registry (I don't have the keys), and the others don't seem to do anything.
    4. I've looked in the BIOS, and haven't found anything about USB or peripherals. It's very simplified.
    5. I looked for drivers, but the drivers I have now are all standard to Windows. HP doesn't offer any additional software for it, and I've used programs that analyze the drivers, and those claim the drivers are updated. The motherboard is an HP-brand motherboard, so I don't know where to go for additional USB drivers for it (if I would need them at all).
    6. I've tried looking for Windows USB2.0 drivers, but I seem to be up-to-date with those.
    7. I tried this quick fix mentioned by Technophobe. I turned my computer off, unplugged the power and removed the battery. I let my computer stay this way for thirty minutes, and it didn't do anything. I tried different means of doing it. I removed the battery and left it on AC power. Nothing. I tried running it only on battery power. Nothing. I am now draining the battery, and seeing if that'll do anything.

    Technophobe's solution made me think that the reason these USB problems started popping up could've been what I did earlier this month when my computer froze. I had closed the lid, and it usually goes to standby; However, when I went to check on it a few hours later, it was still running and had frozen. I tried pressing the off button, nothing. Unplugging the AC power did nothing. So I unplugged the AC power and removed the battery, causing a sudden power loss for the laptop. Restarting it with the battery and AC back in place fixed that problem. I probably sound horrible for doing that, but I didn't feel like I had any other alternative.

    It was not long after that, that these problems started to pop-up.

    So, I'm pretty much stuck. I don't want to send it in (I've had bad experiences with other companies where I've sent things in, and I have very little extra money for it), but I'm starting to run low on ideas...
  22. CCT

    CCT TS Evangelist Posts: 2,653   +6

  23. spatty11

    spatty11 TS Rookie

    Thank Goodness Someone tried Reformatting B4 Me!

    To those who have reformatted, I truely empathise. There's nothing worse than killing a system that had conformed to my preferences of months of use, only because I can't fix a problem with the OS. So, to the troopers who went before me, and reprted back that this horrible method did not work, I thank you (with my hand over my heart for my fallen comrades :( ). I've got the same issue, and by Jove, it seemingly appeared overnight (anyone else?). I came across an article about restore points and external USB drives (which many sticks now behave as, these days). It was in my hurry for an answer, and it's lost in the dust, but I think there might be an answer there (somewhere). MSHEP, your story is inspiring. I might just need to upgrade my drivers to the SiS brand (if I understand you correctly). I tried to reinstall the USB drivers that came with my motherboard's disk, but it didn't work. It said it couldn't find the device. When I tried to update from Device Manager, using the .inf from the CD, it didn't work either. I might not know what I'm doing. I've got other problems, too. Now, my Windows Installer is broken. So many problems in a row. I think, for me, there is a deeper culprit.
  24. spatty11

    spatty11 TS Rookie

    Mshep, can you explain further?


    Can you tell me the steps you used to do this. I have the disk that came with my motherboard, including the installation .exe for the USB drivers, but it didn't work. I'll try to get back with a specific error message.

    you're comments are the only light at the end of the tunnel so far.

  25. amalmansy

    amalmansy TS Rookie

    Dear technophobe,

    I've had this problem for a week

    I tried your way and it realy worked :)

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...