USB drive or flash problems? How to cleanup and remove old USB storage drivers

By LookinAround ยท 81 replies
Apr 13, 2010
Post New Reply
  1. fritzo

    fritzo TS Rookie

    I used drive cleanup, sure cleaned out alot, 71 USB devices, 50 disk devices, 88 storage volumes, 70 keys from registry.

    I try to install a
    Weather Direct Light Wireless Device
    which talks to a LaCrosse weather station or its sensors...
    This USB device is SUPPOSED to self- register and NOT require any driver installation.
    Since I have no drivers I tell the wizard OK check this once on the web etc. but it won't find anything, code 28
    drivers not installed.

    XP SP3

    What else can I try?
  2. ucould2

    ucould2 TS Guru Posts: 271

    Did you end up getting this sorted out @fritzo ??

    If not try starting your own thread as LookinAround states
    Yo, please link through to your original post here too
  3. fritzo

    fritzo TS Rookie

    Sadly, no.
    Starting new thread.
  4. oner

    oner TS Rookie

    Move the 32 or 64 bit version of DriveCleanup.exe to C:\Windows\System32

    I'm trying to fix a problem of not being able to open my flash drives. I received a response saying to go to
    a url which tells you how to cleanup and remove old usb storage drives

    Part of the directions on that url are to
    . Move the 32 or 64 bit version of DriveCleanup.exe to C:\Windows\System32

    could someone please give me the actual steps to do this?
    Joel Margolis
  5. fritzo

    fritzo TS Rookie

    IN windows explorer make sure hidden and system files are visible
    you downloaded
    unzip the file
    it will create two directories, one called Win32, the other X64 each containing a version of drivecleanup.exe.
    Depending on what Windows system you are running copy the proper version of drivecleanup.exe to C:\Windows\System32
    navigate there and run it.
  6. oner

    oner TS Rookie

    Move the 32 or 64 bit version of DriveCleanup.exe to C:\Windows\System32

    Could you please tell me the EXACT STEPS I have to take to copy the file?
  7. fritzo

    fritzo TS Rookie

  8. oner

    oner TS Rookie

    here's what I mean by the exact steps

    The unzip file is on my desktop.What I need are explicit instructions.
    I'll give you a phony example: copy file; open word; paste file in word;
    open format; open font; click on times new roman; etc.

  9. oner

    oner TS Rookie

    USB Drive Problem Still unsolved

    I was able to run the suggested solution given in topic 145884. Unfortunately that solution didn't work for me. I've tried using new as well as used usb's but the problem persists, so I don't think the problem is with the usb but rather with my computer. If anybody has any suggestions, please let me know. Thanks
    Joel Margolis
  10. Anshul

    Anshul TS Rookie

    Does this method (clean up of drivers) works for laptops too.. i m using sony vaio e series and when i run this application....
    at the end it shows... devices not removed or ... hubs not removed..
    please help....

  11. LookinAround

    LookinAround Ex Tech Spotter Topic Starter Posts: 6,491   +184

    This method does work on laptops but it only removes certain types of USB drivers related to USB mass storage devices (such as disks, CDROMS and flash cards). It won't remove hubs for sure and don't know for sure about that other device eiter (but, off hand, would guess probably not). You might try creating a new thread for your problem. And provide more info (like what app? what version of Windows?)
  12. FatPhysicsBoy

    FatPhysicsBoy TS Rookie

    Hi I have a problem with a smarphone (Galaxy S2) it is running a custom ROM however I suppose the Samsung S2 drivers or the Google ones would/should do the trick. The only problem is, it has two types of USB transfer protocols MTP and UMS.

    I've had massive issues with plugging it into my laptop, I have gotten the laptop to recognise and successfully install drivers etc a few random times in the past week or so, but then not recognise it after a reboot. The phone charges from the laptop but is not detected as either a mass storage device. As I said, it has worked a couple of times randomly in the past.

    Here's the thing, as soon as I plug it into any of my friends laptops it works instantly and windows finds the drivers and everything and it works fine! I have tried everything, from using your script (which actually was the cause of one of the random detections) to updating chipset drivers to cleaning drivers, registry, removing usb host controllers and usb root hubs.

    Is there anything at all you can suggest? Thank you! I am on windows 7 64bit hp 6530b
  13. LookinAround

    LookinAround Ex Tech Spotter Topic Starter Posts: 6,491   +184

    I have a Samsung Galaxy S2 as well!

    Two possible things come to mind:

    1. Samsung sells USB cables that are for charging only as well as cables that do both data/charge. So make sure you're always testing with a cable capable of data connection

    2. Sometimes on my Samsung I have to do the following to get a USB Mass Storage connection (instead of MTP). Home->Settings->Applications->Development and check USB debugging. Don;t know if same might apply for you
    FatPhysicsBoy likes this.
  14. FatPhysicsBoy

    FatPhysicsBoy TS Rookie

    Hi, thank you for your speedy reply!

    1) Yes, I am using the correct cable, out of the box!

    2) Yes I have also heard of this solution, however it does not work for me!

    I have tried many of the common fixes for the custom ROM I am currently on (Hydr0g3n ICS ROM) which is an AOKP rom! However, none of them seem to work and also it's strange because it seems to work flawlessly on all of my flatmates (much newer laptops!)

    I have a feeling it's got something to do with the drivers/windows install etc. It works perfectly on all of their laptops! Also my brother is on the same ROM and it work perfectly for him at home too! It just seems to be my laptop!!
  15. LookinAround

    LookinAround Ex Tech Spotter Topic Starter Posts: 6,491   +184


    Don't know if I can help further but if you'd like to discuss your particular problem further please create a new thread in the Other Hardware forum. You can name it something like "Galaxy S2 won't connect USB"
  16. AndyChia

    AndyChia TS Rookie

    I am running Win 7 64bit SP1. I am currently facing the same problem with my SanDisk Cruzer. The problem started when I accidentally remove the thumb drive while its in operation and the whole episode unfolded. I tried using the method mentioned here but it seems like I am still facing the same problem which initially started on a 8Gb SanDisk Cruzer Edge thumbdrive and spread to a 16GB Cruzer Blade, 2 x 4GB Cruzer Micro and lastly a 16GB Cruzer Fit.... all these drives reported 0 bytes, no media.

    Appreciate any my wits ends...contemplating of reformatting the HDD.

    I had run these thumb drives on my office PC running Win XP 64-bit SP3...they ran fine....I tried to format them on my work PC, still facing the same problem when running from my home PC.

    Below are snapshots of the problem.

    01. 03.

    Attached Files:

    • 04.jpg
      File size:
      57.5 KB
  17. AndyChia

    AndyChia TS Rookie

    Yes...forget to say...2 old SanDisk Cruzer Micro (1GB and 8GB) were still able to run fine.....
  18. LookinAround

    LookinAround Ex Tech Spotter Topic Starter Posts: 6,491   +184

    Just to clarify and to make sure I understand your posts
    > All your SanDisk cruzers work on a different PC
    > But only some fail on your home PC but work on others?

    Question being if they ALL fail on just the home PC or if just a select few. And if the few that fail on home PC do or do not work on other PCs
  19. AndyChia

    AndyChia TS Rookie

    Yes, basically all the new ones fail after I accidentally plug out one of them while the drive is in "activity"

    Anyway, I reformatted my HDD and everything falls back in place again....must be some drivers that is stubbornly unable to be replaced except through a complete reformat of the HDD.
  20. LookinAround

    LookinAround Ex Tech Spotter Topic Starter Posts: 6,491   +184


    Thanks for taking the time to provide the update. Glad to hear you got your problem fixed! (y)
  21. Leyre

    Leyre TS Rookie

    OMG! I've been looking for something like this for ages!
    Thankyou so much! I signed up in the page just to tell you this.:)
    williambjacobs likes this.
  22. ChristCatnap

    ChristCatnap TS Rookie

    I also have registered here because of this topic singularly. I now reason that there is so much more I will realize and learn by coming to TechSpot.

    Thank You LookinAround.

    I will see if this is the solution, PowerSuite 2013 Pro is the trigger for the \Device\Harddisk\DR2 pop-up, and it is an intermittent issue. You should of seen the list of drives disabled, astonishing, I apologize for not grabbing an image of it.
  23. bentley30

    bentley30 TS Rookie

    Same problem here also. Using XP on this laptop where problem is. It does not happen on Windows 7 64 system. (USB 2TB WD External Hard Drive My Essentials).
    If I plug in USB external hard drive on a new restart, it does recognize hard drive and drive F. If I plug USB hard drive into an already booted up XP system, it will not let me do anything. I have a free moving arrow that will not activate or click on any right click "start" button, will not click on any shortcut link on desktop. I have to do a hardstop to exit out of this. I did the following to try and correct this: I used diskcleanup and cleaned out all old USB Drivers; I also removed Acronis True Image and Acronis Disk Monitor from this computer (XP). Does anyone have any other ideas I can try?

    As I said, it will work on this laptop XP computer if external hard drive USB is plugged into computer on a new bootup. I can see it in MY Documents as F drive. No problems with any shortcuts or programs running from desktop.

    The problem is when I plug in after a computer has been booted up. If I put in USB cable, I get nothing. No response and no links or icons work for anything. Scrolling button used to stick in hour glass mode prior to removing program and cleaning old USB drivers. If I do a new bootup and as I said, USB hard drive is working, and if I take it out, and then put back in, same thing happens even though it was working prior to taking out. Only works on new bootup.

    I have tested this USB hard drive on another laptop running Windows 7 64, and no problems. Works either way and I get the autoplay menu also, which I don't get even on a new startup in XP. Something is corrupt in the XP system and I don't know where to look. I can only share that one time I hit to remove USB driver safely, I got a screen with 3 choices that came up and said which one did I want to stop. My guess is the problem lies here with these 3 choices. One was a generic F drive controller or something like that, the other was the USB hard drive, and I can't remember what the third process was, as I have not seen that screen again.

    thanks as I have already ruined one external USB hard drive due to so many improper shutdowns/

    thanks and need help badly as I cannot solve this and am running out of ideas short of a new image of
    XP put back on, and that is allot of work to catch up to the present.
  24. AndyChia

    AndyChia TS Rookie

  25. KrizmKazm

    KrizmKazm TS Rookie

    I was having similar problems as the original thread creator. My Seagate external has been working for a few years and was working Friday night, but not Saturday morning. The green light signifies it is getting power and I can hear the spinning and sometimes a few clicks, but the drive doesn't show up in My Computer now. I attached an image showing what I see during the hardware detection and within 'Computer Management'. (64-bit Windows7)

    I followed the instructions above for DriveCleaner which removed an extra 33 items from the registry but I'm still having the same problem. There is a lot of precious content on here I would like recover so I can at least back it up somewhere else. Any suggestions?

    Attached Files:

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...