Spread the love! TechSpot Tech Gift Shortlist 2017

USB drive or flash problems? How to cleanup and remove old USB storage drivers

By LookinAround ยท 81 replies
Apr 13, 2010
Post New Reply
  1. LookinAround

    LookinAround Ex Tech Spotter Topic Starter Posts: 6,491   +184

    Disk Management shows the disk is unallocated. (Might be due to corruption so Windows no longer sees a valid partition or file system.) However, doesn't mean your data is lost.

    Try running PhotoRec
    Try using PhotoRec with its default options (you only need Enter). Two things to be certain of:
    1. Choose the right disk that needs scanning
    2. When it asks you where to write the recovered files, do NOT! point to the drive you are trying to recover! If you write anything to that drive, it can overwrite data that might otherwise be recovered.

    G;luck. Let us know how it goes <will keep fingers crossed>

    /* EDIT */
    p.s. 2. above also means you need a drive with enough free space to save all data you hope to recover! (so if you may need to connect a 2nd external if not enough space on your local disk)
  2. KrizmKazm

    KrizmKazm TS Rookie

    Just so I don't make a big mistake and rush this... I the Drive I selected to scan was my Seagate. Now it shows a screen that lists Partition: P Unknown with a size of sectors listed. I don't see where it is asking for the destination before I scan. It just has options for Search (Start Recovery), Options and File Options but no destination path listed. Should I proceed with Start Recovery or is that going to write to my Seagate?

    Also, the drive has hundreds of gigs of files. Is this the best way to try and access the contents? Thanks in advance!
  3. KrizmKazm

    KrizmKazm TS Rookie

    Ok, I'll have to grab a new hard drive to restore to before I try this, may be another week or two. Thanks for your help!
  4. KrizmKazm

    KrizmKazm TS Rookie

    Another questions regarding the same issue... I noticed my Windows Update isn't updating anymore either. It will scan for updates and hang on 0% infinitely. During this process, it also dramatically slows down my system until I CNTRL+ALT+DEL and stop the Windows Update service. Is there any chance if I do a complete OS reinstall, that may help access my external HD? I've read you can get a lot of USB bug fixes via Windows Update and am wondering if missing those could be affecting me as well.
  5. KrizmKazm

    KrizmKazm TS Rookie

    Ok, I started to run the PhotoRec. After I selected my damaged drive (Seagate external), I am presented with the menu shown in the attached file. I did not see a prompt asking where I would like to recover my files TO. Should I proceed or not yet?

    The hard drive I would like to restore to is verrrry close in size to the hard drive I'm trying to recover, but I'm not 100% positive sure it is larger than the files I am trying to recover. Is this why it has not asked me for a destination drive to recover to, or does that happen on the next screen? Im too afraid to proceed if I am unsure....

    Attached Files:

  6. LookinAround

    LookinAround Ex Tech Spotter Topic Starter Posts: 6,491   +184

    1. Not to worry about disk destination size. Since PhotoRec doesn't change anything on the disk it's recovering, you can always start again if you need more space

    2. As to the screens, I only used PhotoRec once, myself. You'll see the typical sequence of screens on PhotoRec Step by Step Guide.
    In my case, for whatever reason, not all the screens appeared

    That screenshot is the one that precedes the one allowing you to tell it what file types to recover. By default, all file types will be chosen. Just hit enter again to let it try to recover all file types. You eventually get to the screen that asks where to save recovered files. That one you want to pick drive you added.
  7. KrizmKazm

    KrizmKazm TS Rookie

    It just finished and recovered 0 files :(
    Thanks anyways for the help, I really do appreciate it.
    I've tried everything I can think of but I guess I just have to swallow the fact that I've lost 5-10 years worth of content.
  8. KrisX

    KrisX TS Rookie

    You said you have hundreds of gigs on the drive yet the usb drive only shows 4GB. Are you not mistaken an external hdd with a usb stick?
    You should try TestDisk to find lost partition table on the drive first. If it's true the ext. drive is only 4GB, it must be very old. I guess your problem is not due to the filtering problem but your disk's age (bad sectors). There's way to recover dying harddisk by freezing it first and then try to get as much content as possible from the drive's still not damaged sectors. Not guaranteed successful though.
  9. KrizmKazm

    KrizmKazm TS Rookie

    I'm not using any USB sticks. That's very interesting you mentioned freezing it. My buddy just told me that a few days ago and I couldn't believe it. Ok, I'll try TestDisk first and if the drive is only 4GB, I'll try the freezer. Thanks again for the help!
  10. KrisX

    KrisX TS Rookie

    I'll test the ext drive on another computer first, to make sure what the actual problem is: the ext drive or your computer. Also check the event viewer for errors (disk bad block or controller error) to confirm bad disk problem. If you later decide to try the freezing stuff, take care of condensation. You also have limited time to work on the disk before it's heating up again. Anyway this has to go to a new thread I guess. Good luck.
  11. stevej001

    stevej001 TS Rookie

    Drivecleanup.exe was helpful - in part; it did allow me to connect my drive, drivers loaded properly. However, I am still unable to "see" my drive and, therefore, am unable to use it.
    Any suggestions would be greatly appreciated.
  12. LookinAround

    LookinAround Ex Tech Spotter Topic Starter Posts: 6,491   +184

    Have you tried connecting your drive to a different computer? If it doesn't work on either computer is likely a problem with the device itself. (is it a flash drive or external usb drive?)
  13. HT4cae

    HT4cae TS Rookie

    None of my new USB drive devices work, only existing devices on my Windows 7 64 bit desktop.
    Examples of devices that won't work are my Nikon D7000 camera, my new Fantom 4TB USB3 drive.
    However my existing Fantom USB 2 drives 500 GB and 1 TB drives work and my Seagate USB 3 1.5 TB drive and various flash drives work.
    These new devices work perfectly on my Windows 7 32 bit laptop.
    Using my lastest purchase, the Fantom 4TB usb drive for this problem:
    The drive shows in diskmgmt but I can't do anyting with it, ie. can't format, assign drive letter. I resorted to command line.
    using DISKPART
    7/11/2013 3:36:02 PM
    select disk 3 ... OK
    clean ... OK
    convert gpt ... OK
    create partition primary
    ... stuck here, see below
    format quick fs=ntfs label="Media"
    assign letter="M"
    after create partition primary ...
    DISKPART> list partition

    Partition ### Type Size Offset
    ------------- ---------------- ------- -------
    Partition 1 Reserved 128 MB 24 KB
    Partition 2 Primary 3725 GB 129 MB

    DISKPART> select partition=2

    Partition 2 is now the selected partition.

    DISKPART> format quick fs=ntfs label="Media"

    There is no volume selected.
    Please select a volume and try again.
    DISKPART> detail partition

    Partition 2
    Type : ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
    Hidden : No
    Required: No
    Attrib : 0X8000000000000000
    Offset in Bytes: 135266304

    There is no volume associated with this partition.
    ........... but it is usable on my laptop!!!
    On my desktop, I've tried using the drivecleanup.exe utility. After that none of my USB drives worked, old or new!
    I restored desktop and got back to my original problem. Next I tried SparkTrust PC Cleaner, I ran it 3 times (rebooting after each cleanup).
    That didn't seem to help anything, my PC didn't boot any faster. Next, I tried ARO 2013 PC check for Errors. It was interesting that it found 1300+ more errors than
    SparkTrust, but it still didn't help anything. Finally, I tried (ran in elevated mode) "regjump.exe class-diskdrive". It only opens the regeditor without going
    to any entries. I search for "diskdrive" and found the following entry.
    Key Name: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}
    Class Name: <NO CLASS>
    Last Write Time: 7/10/2013 - 4:51 PM
    Value 0
    Name: Class
    Type: REG_SZ
    Data: DiskDrive
    Value 1
    Name: ClassDesc
    Type: REG_SZ
    Data: @%SystemRoot%\System32\StorProp.dll,-17000
    Value 2
    Name: <NO NAME>
    Type: REG_SZ
    Data: Disk drives
    Value 3
    Name: IconPath
    Type: REG_MULTI_SZ
    Data: %SystemRoot%\System32\imageres.dll,-32
    Value 4
    Name: Installer32
    Type: REG_SZ
    Data: StorProp.Dll,DiskClassInstaller
    Value 5
    Name: NoInstallClass
    Type: REG_SZ
    Data: 1
    Value 6
    Name: SilentInstall
    Type: REG_SZ
    Data: 1
    Value 7
    Name: UpperFilters
    Type: REG_MULTI_SZ
    Data: PartMgr
    Well, I finally thought I got to the bottom of the problem. I deleted value 7 (UpperFilters) and rebooted. My PC wouldn't boot
    until I restored to a prior restore point!
    So I'm at a loss what to do next any suggestions are welcomed... HT
  14. idleedo

    idleedo TS Rookie

    1. Download drivecleanup.zip, unzip and save to your desktop. Move the 32 or 64 bit version ofDriveCleanup.exe to C:\Windows\System32
    I downloaded it.how to move it to C?

    Steps to Safely Cleanup and Remove old USB Mass Storage Drivers on your PC
    1. Shut down your computer. Unplug your USB storage devices: USB Disks, flash, cams, CD/DVD, etc.
      ==> Other USB devices like keyboards, mice and LAN adapters can stay plugged in
    2. Boot computer back up. Click for how to determine whether you are running 32 or 64 bit Windows
    3. Download drivecleanup.zip, unzip and save to your desktop. Move the 32 or 64 bit version of DriveCleanup.exe to C:\Windows\System32
    I downloaded the drive cleanup.zip on desctop but I am unable to move
    Can you please tell me how to unzip and move to C:\Windows\System32
    Mine is vista 32 bit
    when I connect the external hard drive it does not show in my computer
    In the properties it shows not initiated
    Pl help
  15. osama rajpoot

    osama rajpoot TS Rookie

    Something has happened to my kingston 8 gb usb and now it is not shown in my computer also it it is visible in disk management but as generic usb mass storage usb device and so I'm unable to use it can this issue be resolved
  16. LookinAround

    LookinAround Ex Tech Spotter Topic Starter Posts: 6,491   +184

    If this a U3 flash drive? Have you tried it on another computer?

    U3 flash drives first appear to a computer as a CDROM device. The new CDROM device will appear on My Computer. Autoplay must be turned on for that "CDROM' to be launched and the flash drive to finally appear. (If autoplay is off you can double click the CDROM to launch it)

    For non-U3 flash drives, the drive should appear when plugged in.

    If it fails on multiple computers, is probably a flash drive problem
  17. ucould2

    ucould2 TS Guru Posts: 271

    From what I understand to see the full 4TB you need to have a machine that would need to have an Unified Extensible Firmware Interface (UEFI) not only a Basic Input/Output System (BIOS). There is a limitation of the BIOS to actually see any more than 2.2TB in one drive, that means you could potentially have a 2TB HDD as well as a 1.5TB HDD as well as a 350GB SSD and your computer would be able to access all of the memory.

    However if your single drive is larger than the 2.2TB it will not be useable space. It's a bit like how my 32Bit P4 system addresses it's memory block. I have 4Gb of RAM but due the Video card taking up the addressing for it's on board memory (512Mb) my system will only ever read 3.5Gb of RAM

    Last edited: Sep 28, 2014
  18. Greg Barry

    Greg Barry TS Rookie

    WOW! Thanks. I joined up to say thanks! My Samsung Galaxy S4 was freaking out. Works like a charm now.
  19. David G

    David G TS Rookie

    Thank you soo much!

    Fixed a problem with a message showing
    "Please Insert a Disk into Drive \Device\harddisk\Dr3.
  20. Aviral Singh

    Aviral Singh TS Rookie

    It did not work for me. Access was denied. What does that mean and what do I have to do? usb port problem.
  21. soumidutta09

    soumidutta09 TS Rookie

    Thank u soooo much...It was very much useful..I was facing this issue for long..but didnt found any good solution till dis one..
  22. Florio60

    Florio60 TS Rookie

    Hi. Until recently my laptop was working perfectly, but as of this morning it will not open any of my USB pendrives; when I insert a pendrive the little icon with the green circle and white tick appears in the task bar, but the disk does not open or appear in Explorer Resources.
    I just tried to install and run DriveCleanup.exe but can't get it to work, even though I am using an elevated command prompt and have placed the x64 folder in Windows->System32.
    I haven't yet read all of the posts here (3 pages of them), because from what I've seen most people have had other problems and not actually running the DriveCleanup application.
    One thing that may be important: the other day I had to change my laptop battery, and I hadn't had to use a pendrive until this morning.
    All advice willingly accepted!
  23. Florio60

    Florio60 TS Rookie

    Just an update on my earlier message. Managed to install and run DriveCleanup.exe. Did a reboot, inserted a couple of USB pendrives and my laptop began installing the necessary drivers. At that point I thought that my problem had been fixed, but basically nothing has changed. When I insert a pendrive, there is still the little icon in the task bar (and the disk appears in the Control Panel, Devices and Printers), but it does not open and does not appear in Explorer Resources. Can someone help me here?
  24. LookinAround

    LookinAround Ex Tech Spotter Topic Starter Posts: 6,491   +184

    Last edited: Sep 17, 2014
  25. Florio60

    Florio60 TS Rookie

    Thanks for your reply; sorry for not getting back to you earlier, but just got back from work.
    Yes, the pendrives work on other PCs.

    I have a small problem in that my OS is all in Italian, and from the translation it's sometimes very hard to work out what the original English must be. In the Device Manager menu I have USB Controller (Universal Serial Bus) as the fifth category, and 'Disc unit' as the eighteenth category. Is this the Disc driver you're referring to?

    I told you that the other day I had to change my laptop battery (I read somewhere that the battery can have something to do with USB pen-drives not being recognised). A few other things may be worth mentioning. Around the same time I changed batteries I also upgraded my BIOS for the first time since buying my laptop. I have also just got a new all-in-one printer and so new hardware has been installed. To top things off, last night I got a blue screen with a 'Driver_irql_not_less_or_equal' message. First time ever. I was so surprised I forgot to take down all the details.


Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...