USB drive or flash problems? How to cleanup and remove old USB storage drivers

Hello Everybody,

I am in the same deep trouble as many others: Windows 7. Some pendrives are recognized and work fine on each and every USB ports of my Dell Latitude 6410. However, some other pendrives and my Samsung camera do not work an any of my 4 USB ports. First they appear and disappear, and reappear, and so on in a cycle by themselves automatically in rapid succession.

The very same pendrives and the camera do work fine on my other Dell Latitude 6400 machine under Windows XP. Also those that work on Win7, work on WinXP.

I deleted my drives from the device manager, and got restored upon bootup. No avail. Then I run the DriveCleanup.exe
with the same eventual outcome: no avail.

I know one thing for sure: if I save my data, and reinstall Win7 from scratch (destroying the past,) the USB misery will go away, as it did for a friend of mine. However, it is a major undertaking for me, reinstalling everything, and doing the data restore. The guilty party is that Win7 by Microsoft.

Is there a solution???


(For the time being I use my XP machine, but...)
 
Brilliant. Marvellous. My USB 3 was so munted with drives dropping in an out on an HP8460p (with Windows 7 older than the PC and never rebuilt). It occurred after plugging in a suspect broken drive some months ago. I had a go at finding all the keys but failed. I was beginning to think it was hardware. I used both tools and could not believe how many obsolete hardware device were there.
 
Last edited:
I have a similar problem with my Alienware M15X, which is about 4 years old and running W7. For some reason USB pendrives no longer work in any of the USB ports. They used to work and all the USB ports still recognize mice and mobile phones. I have three pendrives, two Sandisk Cruzers and a Verbatim. All these work in my PC. When I try to connect them to my laptop (with mains power) either nothing happens or I get "device driver software was not successfully installed." There is a yellow error icon in device manager but attempting to reinstall drivers, disabling, deleting, none of these work. I have tried DriveCleanup with no success, also tried a powered hub, no use. I do not have Acronis installed, so this is not the problem. It was suggested that I make a rescue disc with Macrium Reflect and then boot from this. Tried that and I could see the files on the pendrives, but not open them. I also tried editing the registry, as mentioned elsewhere on this forum, this made no difference either. It would seem to be a software, rather than hardware, problem. I'm out of ideas now. I am aware that some Sandisk pendrives can be a bit temperamental, but my Verbatim doesn't work either, although this is an old model. I am waiting delivery of a 16GB Kingston pendrive, in the hope that a different brand may work. I have my doubts though. Hope someone is able to help.
 
I have a 64bit sony with Win10. how do I make this program work on a 64 bit machine? how do I designate the program as 64 bit? I am getting the error message when I try to run it.
 
I have been looking for a solution to my USB flash drives and external HDs for a while now. (I'm still on Windows XP Pro SP3, BTW.) The system stopped installing new drives a few months ago, even though I can take them to other machines and they will install fine. I always get that damned Hardware Wizard, which invariably "cannot find the driver". I have tried uninstalling the USB Root Hubs and letting Windows reinstall them on reboot, I have tried replacing usbstor.sys from the Windows install disk (I've even tried a delete of usbstor.pnf, usbstor.inf, and infcache.1 and letting Windows rebuild those files). I even spent Saturday afternoon reinstalling Windows in the hope that some misbehaving file would get overwritten and work. All that did was make Windows no longer recognize the USB drives it had before, so I'm worse off now for trying that.

Today I tried your DriveCleanup utility. It removed a ton of entries (which may have contributed to the problem, I don't know) but I still can't get any USB storage devices to install, and the Hardware Wizard is still being its annoying self.

Hoping someone here has been through this problem and has some ideas I haven't tried yet.
 
While I was transferring a 2GB file from pc to USB pendrive, appeared a strange error saying like “resource is no more avaliable” and transfer was abruptly aborted; I couldn’t safely expell so I shut down before removing pendrive, but after rebooting and reinserting appeared a message asking to format the drive; I did not and this time I could have safely expell. After then, not only laptop doesn’t recognize pendrive anymore, tablet too. At first Device manager lists pendrive as it should work, but then appears yellow question mark and drivers details reports error code 10 “device not started/failed to load” therefore Disk manager too doesn’t see it and I can’t assign a letter at all. I reinstalled all USB drivers already removing USB controller on both devices, in both there is Win10 1803 latest build with all cumulative updates and all drivers up-to-date. As a side-note Surface Pro 3 is from 2015 so there are no really new chipset or any other kind of drivers to download from Microsoft, but DELL Inspiron is new, bought a couple of months ago, and its update software keeps everything always up-to-date to the latest new version.
I am taking it is a hardware failure, but before I cry all my files out, I ask if there might be any minimal chance to have them recovered in some way. I really appreciate any kind of suggestion, even just a symbolic pat and a virtual tissue to wipe my tears off (LOL).
 

moon982

Posts: 39   +5
I have had many problems where windows showing drive letters after I remove USB flash drive. If I plug it in well it just uses a new drive letter.

It like the computer does not know I unplug the USB flash drive. When I remove the USB flash drive from the computer.

I will try that program out.