USB flash drive not recognized

By j4g3d ยท 8 replies
Apr 3, 2013
Post New Reply
  1. Googled all day and no answer to my specific question.

    I have some software that requires the USB pen drive to be inserted for the software to work. The chinese I bought it from have some how made the drive INVISIBLE.

    I mean it does not show in MY COMPUTER, it does not show in DISK MANAGEMENT. Tried various CMD lines, tried various software INC TWEAKUI and others. No joy. As I say its a working drive as its needed to run my software. It seems the chinese are doing this often now as I have bought other items from china and all have these silly drives with the software you buy.

    I just want to be able to read whats on the drive so I can clone it in case it breaks on me in the future. Or better still copy whats on it onto my HDD so that the software works without the damn FLASH DRIVE. I hate to have to always have a pen drive sticking out my laptop.
  2. Jad Chaar

    Jad Chaar Elite Techno Geek Posts: 6,515   +974

    Try a different USB port.
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    I'm not understanding something here.

    You have data on the drive now? Did you put it there?

    I don't see how 'the chinese' screwed up your drive after you've already used it. Boot off of a live linux cd/dvd/usb and see if the drive mounts. That will rule out any software issues with Windows. If your suspicions that 'the chinese' have tampered with the drive are correct, I would be reluctant to try it in a different computer, that is why booting into a live linux environment is a good test method here. Trying other, known good, usb drives on that same computer then rules out any hardware issues on that computer.
  4. j4g3d

    j4g3d TS Rookie Topic Starter Posts: 17

    Big misunderstanding here.

    Ok let me break it down.

    I buy software from china, it came with a USB dongle that is NOT recognized in my computer, disk management, disk utilities, tweakui...etc and many more...etc.

    The software comes up with a error message 'NO FOUND DONGLE!' when I try to load the software without the dongle in the laptop.

    Please note I am a computer engineer and I can assure you I have tried another USB port lol. It is nothing to do with the laptop/desktop/ports. Its a INVISIBLE usb flash drive, possibly with a key on it that matches a key the chinese have put in the registry so that when I try to start the software it requires the dongle. I have bought older versions of this software that did not need the dongle, the chinese are supplying the dongle so that you cannot create spare or multiple versions of the software on another HDD.

    So I will say again, the USB flash drive IS recognized in windows as it makes the noise when you insert it, to confirm this the software ONLY WORKS when the dongle is in the computer. The dongle does not show that its been assigned a letter or anything, its invisible. How did they do this? and how do I get around it?
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    From your description, the dongle isn't a flash drive. It's a security device. Sometimes they need their own driver. Look in Device Manager, when it's connected does any device listed appear with a yellow icon? When you plug it in and remove it you should see some device in device manager also appear / disappear.

    Another way to identify it: Download USBDevView.
    Insert the dongle and run the tool. Click on the Connected column so entries are sorted by Connection and look for which ones show Connected = Yes. Unplug the dongle. Click View->Refresh and see which device entry now shows Connected=No
  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Do this, and report back.
  7. j4g3d

    j4g3d TS Rookie Topic Starter Posts: 17

    Thanks for the advice,

    No as I say nothing appears in device manager, it does refresh when you insert or remove the usb flash drive.

    I have downloaded the software you recommend and it picks it up as a USBKEY. I can read the registry entry for this too. Do you have any ideas on what I can try to disable it, but also so that the software works without this dongle needed?

    Thanks again
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    To avoid confusion in terminology and for the benefit of any one reading the thread in the future, note it is NOT a usb flash drive. It is a USB Security dongle (or just security dongle). That's completely different from a flash drive

    That said, there's no way to work around it. It's called a Security dongle for just that reason. The software won't run without it. The software specifically checks that it's connected (and s/w may talk to it as well to verify it's the right device)

    I can try to take a closer look at the device and perhaps find more information about the dongle but it may just be they sent you the wrong dongle for the software you're trying to run :(

    Run USBDevView again. Then select any item, then Ctl-A to select All. Then Ctl-S to save. But be sure when you save, use the pull down menu to save it as Tab Delimited Text. Save to your Desktop. Then upload the file to your next post
    SNGX1275 likes this.
  9. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Security device... I'm out.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...