1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB flash drive write protection

By maxhar · 92 replies
Dec 28, 2004
Post New Reply
  1. derbykid

    derbykid TS Rookie


    I format my 512 Centon on a mac then format again on a differenet windows.
    Now it works fine on my computer.
    So I think it was some update from windows
  2. Ko Naing

    Ko Naing TS Rookie

    remove write protection for USB drive

    I need to remove write protection for USB drive.
    Please help ....
  3. meanfishy

    meanfishy TS Rookie

    I have a Dane-Elec 1GB USB Drive - Riviera, flash drive have been using it for months and now all of a sudden I can't save anything on it. it is saying make sure there is enough room, write-protected or damaged. any suggestions
  4. alb3rT

    alb3rT TS Rookie

    I've got an 1 GB A-Data, no more than a week old. Worked perfectly first week now it says that it is write protected. I tried formatting and looking for a switch on the side of the flash drive. Neither work. Can someone s-m-a-r-t give all of us nubs a step by step resolution?

  5. musical_racket

    musical_racket TS Rookie

    Hey guys, i found the problem for myself. i did all the troubleshooting and i found there was spyware doing this problem. what i would suggest is downloading spybot S&D because thats what i used and there will show spyware that gives you error messages like that, i deleted them and it works fine now, tell me if that works for ya. I just thought i would pass along the info
  6. seesoft22

    seesoft22 TS Rookie

    hi guyz....

    The solution for this is Simple.


    the problem will be automatically solved.

  7. hastawa

    hastawa TS Rookie

    I have tried this way successfully (C-ONE 256MB_Tiny USB, Windows XP):
    - boot in safe mode
    - run windows explorer
    - rigth click on the removable disk
    - format it

    good luck
  8. prasad66

    prasad66 TS Rookie

    please give solution immediately by mailing to me.

    I have trouble with removing of writeprotected usb can you give suggestions how to remove in xp service pack2

    please help me I have NCP 512MB memory card usb. it is a rewritable one. the data could not delted it shows writeprotected. how can I remove that writeprotected.can u help me.
  9. 3asfour

    3asfour TS Rookie

    write protection

    the same problem here i neeed help
  10. toygunone

    toygunone TS Rookie

    hello. i've got more or less the same problem. windows xp64. my disk is not copy protected though. after i format my memstick it says ' windows was unable to complete the format ' . i can delete the files but when i replug the stick the files are back. i tried using win98 to format but nothing... anyone?
  11. oneleg99

    oneleg99 TS Rookie

    Write Protect Flash Card Problem

    I had the same problem, and nearly went mad trying to find the reason. I moved all the data out from the stick, and then it would write! The last file I put in the stick proved to be the problem.
  12. m3rlinez

    m3rlinez TS Rookie

    I have experienced the same problem. I contacted the vendor and they suggest me to low-level format my flash drive. And it works! (They send me a link to download the lformat program) But my model is Apacer's. For more info in my case, visit my blog: Rescued my write-protected USB flash drive
  13. clueless89

    clueless89 TS Rookie

    I have a problem with my USB flash drive as well though it has nothing to do with "write protection" problems.

    I was in the process of transferring music from one computer to another and my usb flash drive now (after working previously) says that it is full though no music files appear in the folder when I plug it in.
    I'm not sure how else to delete these files or clear the drive completely.

    If anyone can offer help that would be great, Thanks.
  14. bajrangk23

    bajrangk23 TS Rookie

    Hello, i have a problem on my usb drive... I saw a Post here in TechSpot about this problem but it doesnt work... THe file system of my Usb drive changed to Raw... I tried to format it but it says its WRITE PROTECTED... Any Softwares I used doesnt work... can anyone please help me. How can i remove the write protection of my usb drive? there is no switch on it... Please Help!
  15. bajrangk23

    bajrangk23 TS Rookie

    reply me which software repair my pen drive
  16. bajrangk23

    bajrangk23 TS Rookie

    dear sir
    we try to formate my pen drive from killdisk software. but result is error.
    so please solve my problem because my pendrive is write protaction .

    thanking you
  17. bajrangk23

    bajrangk23 TS Rookie

    we unable formate my pen drive from any software so please solve my problems

    thanking you
  18. Dad4Mac

    Dad4Mac TS Rookie

    After trying all the suggested routes to correcting this problem I tried one more thing which did work. Remembering that Macs were quite often not affected by the disk problems which affected PCs, I took my flash drive to a Mac and it had no problem. I used the disk utility to repartition it and when I brought it back to the PC it was once again working correctly. Hopefully this will also work for some of the others who have had the same problem.
  19. zarathustra_

    zarathustra_ TS Rookie

    Absolutely BRILLIANT!

    I'd been struggling with this one for WEEKS! Every USB writeable device (daughter's barbie MP3 player, PSP, etc., etc.) was behaving as if it was write-protected - & scouring the net brought up hundreds of peeps with the very same problem.


    I alter these reg-keys & BINGO! All is now well in USB-land. I'll be pointing others toward your good advice from now on...

    A thousand thanx, fatbird, & a VERY merry Christmas! =]
  20. fatdex

    fatdex TS Rookie

    Just thought I'd say, FatBird's solution does actually work in some instances. It took me forever, and I tried everything else on this board (with the exception of paying for software) and it was actually a registry error. Thanks again!
  21. Zdroyd

    Zdroyd TS Rookie

    I am having the exact problem with my "PNY attache 2GB Flash Drive" has anyone salved the problem?

    I need help ASAP!

    If everyone is having this problem with different drives it might be a Microsoft problem, we should all contact Microsoft and complain.
  22. sulaiman saeed

    sulaiman saeed TS Rookie

    Hey folks
    i wish this message will solve all your problems but i just wanna tell a small story
    even i was having this 'write protection problem' with my 1 GB USB until i reached this site and so many ppl having the same problem. Anyhow my bro. came until then and slapped me few times and just moved the small button on the USB. Hope all of u get help from this.
  23. Marvo_man

    Marvo_man TS Rookie

    USB flash drive problem and how I made mine work..!

    I've had exactly the same problem and after some serious messing around and hair pulling I got my drive working again.
    I rebooted my pc into safe mode with the drive in the slot, logged on as an admin and highlighted the drive without opening it. I right-clicked the drive, selected Format, then selected FAT as the file system and did a Quick format. It worked straight away...no hassles.
    I then re-booted the pc into normal mode without removing the drive, logged on as normal and Hey presto....I now have a working flash drive.

    I have no idea why the volume locks itself up and refuses to allow write operations. Microsoft want £60 to tell me about it via email so they can get stuffed. :p The net has all sorts of solutions and offers of repair usually boiling down to "make sure the switch is on/off" even if there is no darn switch to be had!! It must be a o/s fault but as yet I have found no one single solution to this annoying trait of Xp and it's usb drive hang-up. If I do find one....I'll post it!!

    I hope this method works for you too.

  24. chael890

    chael890 TS Rookie

    hey i follow your instruction but when i type format e:( where's my usb located)....it says Insert new Disk for drive e:
    and press ENTER.....
  25. Grimi

    Grimi TS Rookie

    Possible solution

    I was having the same problem with with my 'Retail Plus+' 2gb drive (no switch wouldn't let me do anything)
    go (in any folder) Tools >Folder Options >View
    click show hidden files and folders
    go to you flash drive there should be a file call fdlist i'm not quite sure but the icon will be faded
    delete that file
    go to my computer right click on your flash drive
    click format then ok (it shouldn't give you the error)
    then it should be fixed

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...