USB flash drive write protection

By maxhar · 92 replies
Dec 28, 2004
Post New Reply
  1. Generalkilmall

    Generalkilmall TS Rookie

    The Easy fix

    The fix worked great ! Thanks Fatbird :grinthumb

    QUOTE=fatbird;198590]OK – after an hour or so of faffing around :knock: , I think that I have found a possible solution :p . The problem seems to be something to do with Microsoft’s SP2 :dead: !
    Here’s what worked for me (sorry for the *****’s Guide approach, but I used to :hotbounce hate it :hotbounce when I used forums and couldn’t understand what the technobabble meant!):

    - Start > Run > type ‘regedit’ (without the speachmarks) > Enter
    - Single-click on ‘My Computer’ > File > Export > save it to the Desktop (Always best to have a backup!!)
    - Go to the following:

    My Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies
    *There seems to be some spaces here in 'StorageDevicePolicies' in the text above, there shouldn't be, OK*
    - Double click on the string ‘WriteProtect’ and change the ‘Value Data’ box to ‘0’
    - Then: File > Export > save somewhere useful as something like ‘StorageDevicePolicies001.reg’
    - You also need to do this for the strings in any folders called ‘ControlSet***’ (* = any Digit, i.e. 001, 002) – for example: Everything is the same, just change ‘CurrentControlSet’ to ‘ControlSet***’

    My Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\StorageDevicePolicies
    *There seems to be some spaces here in 'StorageDevicePolicies' in the text above, there shouldn't be, OK*
    - Save these to the same place as before as ‘StorageDevicePolicies00*’

    The saves are in case it reverts at a later date, just double click (saying ‘yes’ to importing these to the registry) on all of the files and it will all work again!
  2. r4ndieL

    r4ndieL TS Rookie

    Thx buddy...

    it's surely work....thats cool :cool:
  3. scsl2004

    scsl2004 TS Rookie

    Remove Flash Drive Write Protect.

    Dear Guys
    Flash Drive write protect problem (Kingstone)

    Make low level format

    Download formatter

    You can successfully format it.

  4. erli

    erli TS Rookie

    Resolved write protect format

    i have been using all the methods in this forum without results.
    i googled for this problem and i founded a small program that did the trick. it format my flash drive in write protection mode ( without switch)

    try this small program


    free of charge
  5. SS99

    SS99 TS Rookie

    Awesome!!!!!!, I tried all of everything else and this actually worked, saved my 16gb usb drive from the trash, and money having to buy another one. I can't believe the manufacturers don't have a program like this to help their customers, guess they want you to buy another one after warranties expires.

  6. robbeye

    robbeye TS Rookie

    Write protection fix on usb

    Hi I thought I would let you know how I got rid of that sneaky write protection on my 16gb unkown brand usb pen drive. First go to device manager find drive and uninstall. Pull out usb drive and put back in to computer it will start to install the software for the usb pen drive once that is complete. Go to my computer go to usb drive right click and select format, when the format is open at the part which says volume, insert your pen drive letter, then select format and it will start formatting. Hey presto all done.
  7. squirrelone

    squirrelone TS Rookie

    usb drive write protection garbage

    Was having problems with usb drive as well. took advice from someones suggestion to keep your usb drive in the slot then reboot computer with flashdrive still plugged in.It worked great was able to reformat and can now load what ever i need to put on the flashdrive.. try it out see how it works for ya all...
  8. Brandonvang0

    Brandonvang0 TS Rookie

    USB Drive Write Protected

    I had the same problem with my 16gig USB Flash Drive. I opened it up and looked at the board and assembly carefully and found that three of the pins on the memory model lost contact with the board. You will need some micro-soldering equipment and micro solder it back on carefully. My worked fine after that. I guess what happened is over time, the memory module over-heats and one or more pins become loose from the board. The problem with this is your USB flash drive will still appear to be working and is detectable by your OS, but you just can't write or delete anything off of it. If this is the case, software modifications or configuration will not work. The only way is to get those pins to contact the board.

    Sometimes you have to look carefully. You might even have to get a strong magnifying glass to help you. Look for discolorations on the contacts. A lighter color usually is a sign that the pin has lost contact.

    Hope this helps....
  9. awaheed

    awaheed TS Rookie

    USB Memory Stick is Write Protected:

    USB Memory Stick is Write Protected:
    How to remove a write protection from your USB memory Stick if there is no Write protection ON or OFF button on stick then
    1. Shutdown your computer or laptop
    2. Insert USB Memory Stick into your laptop or Computer
    3. Turn on laptop and then immediately start pressing (F8) key then Advanced Boot Options screen will come up
    4. Select Safe Mode with Command Prompt
    5. After loading files if your USB Memory Stick drive letter is (G) for example then write as
    6. C:\windows\system32>G: and press enter
    7. G:\>format G: and press enter
    8. If ask you (Y/N) then press (y) and press enter
    9. Now a full format will start which remove write protection from USB Memory Stick.
    Before removing USB from your computer, Always remove it safely by going into to my computer then right click on USB and click eject.
  10. AdicelMare

    AdicelMare TS Rookie

    O my god!!How simple it was.I'm shamed.I'm a profesional in IT but i never learned the DOS commands.When i need one I ask a friend.Now hapened to be you. Thank you!
  11. rglenn

    rglenn TS Rookie

    Worked for me, hopefully for you too

    Well, we all seem to be down to Plan Z with no success, so maybe this will work for you also. I booted into safe mode (f8) and attempted to format by 4GB Centon drive. It failed. Fine. Whatever. Booted back into Win 7 and the drive was now listed as Raw. Attempted a format and actually worked!!! Worth a try.
  12. rglenn

    rglenn TS Rookie

    Good idea!

    Throwing it away is the best option. I just wanted to figure it out and it worked but after about a week of heavy use (very heavy use), it failed again. So, not worth the time and aggravation.
  13. rtahsler

    rtahsler TS Rookie


    You guys can give this a try:

    Go to a command prompt.
    Type Diskpart
    Select Disk X (The size should match your media) 1, 2, 3, or ect.

    This should reset the disk and give you back all of your space. You can use the Disk Management Utility in Windows to Format and Reassign the Drive letter.

  14. rryyaannbb

    rryyaannbb TS Rookie


    This actually worked (Even with a totally protected memory stick)

    Please try the following to reinstall your flash drive and see if you can get it working correctly again:
    Plug in the flash drive Right click on My Computer Choose Properties Switch to the hardware tab
    There should be a button like "Device Manager".
    Click on this. Find your flash drive on this list. Right click on it and choose uninstall. Unplug the flash drive, wait a few seconds then plug it back in.
    You should now get a new hardware wizard dialog from which you can reinstall the drivers.
    After reinstalling the drive test it again to see if it is working correctly and let us know. If these steps do not work; you can try rebooting the system after you remove the device before you re-install it.
    Other wise we will be happy to replace it.

    Taken from the corsair support pages.
  15. pastric

    pastric TS Rookie

    This worked for me

    I removed my usb drive and restarted my computer. Once the computer finished booting I inserted the usb drive and was able to add a file to the drive.
  16. AnnaJose

    AnnaJose TS Rookie

    I was also struggling with the same error 'DISK IS WRITE PROTECTED. REMOVE THE WROTE-PROTECTION OR USE ANOTHER DISK' I was using a Kingston data card which there is a small button to lock it...I only had to unlock it to remove the write protection.Hope it will be useful to you!
  17. Luke C

    Luke C TS Rookie

    Hi, I know this post is oooooolllldddddddd, but I have found a solution that works! :D I tried all the ones posted on here but they didn't work but this did!

    1) Plug in the Usb stick with the problem.
    2) Go to Control Panel, Administrative Tools, Disk Management.
    3) Then right-click on your USB stick and choose Properties.
    4) Go to the hardware tab along the top and find your USB in the list.
    5) Click it once and then click the properties button at the bottom.
    6) Go along to the Driver tab along the top and choose Uninstall.

    This will uninstall the driver for the USB. Now you just remove the USB, plug it back in and voila! 1x working USB stick!! :D
  18. zarathustra_

    zarathustra_ TS Rookie

    Luke, that will do ABSOLUTELY NOTHING to a b0rked USB drive. You need to understand exactly what you're describing before offering it as a solution, & it's patently obvious that you currently don't.

    Have a nice day now, y'hear...

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...