USB flash drive write protection

By maxhar · 92 replies
Dec 28, 2004
Post New Reply
  1. vickynair

    vickynair TS Rookie

    i sorry to say this..but i hve too...i too have the same problem and i have tried all the above method and failed yet....finally i have detected that itz a virus...and i used most of the anti-virus soft to delete it..but still now some one please please.... tell me what to do now??????????
  2. hellocdw

    hellocdw TS Rookie


    i can't find "storage device policies"
    i have tried all above suggestions, but none of the m doesnt work
  3. ahlidewan

    ahlidewan TS Rookie

    thank you very much!


    i am not very good in english and i seldom do this. writing in appreciation of another. how ever this time i would make an exeption.

    my kingston datatreveler 2.0 2gb flash drive suddenly went into "write-protection" mode. for no apparent reasons. i tried 2-3 ways to unlock it, but to no avail. later on i tried your way and wallah! all of the problems are now gone. i can delete, add or copy files from and into the flash drive. thank you very much.

    it was not just my kingston, the problem also extended to my easydisk 128mb and another of my flashdrive too. i think it might be because of registry done by my collague. anyway, it is back to normal now. thanks.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    This is a very old thread. And any users who still have issues should really create a New Thread on the forums

    But I thought I'd mention two other tools that may help members\viewers of this thread.
    Warning: These tools will format (ie remove all data from) your flash drive, but as a last resort it is worth it.

    HP USB Disk Storage Format Utility

    This will format most USB flash drives
    It can be known to recover Flash drives that are un-responsive too.

    If that doesn't work try this one:

    Hard Disk Low Level Format Tool (USB Flash drive "format" that is ;) )
  5. ch41ru1

    ch41ru1 TS Rookie

    i need help..........
    my flash drive write protected, I was able to copy a folder to the flash drive but when I tried to copy another one, the system says "Write Protect Error" I tried to format the drive but it also says the same problem. But When I dismounted it to the computer and mounted it again, you can now delete the files stored in it and also format the drive but still you cannot copy a file/folder to it because of this error
  6. Haris

    Haris TS Rookie

    Thanks fatbird, i solve my usb write protect problem,

    there is no problem in the USB, and no need to format, usb if giving the problems to write on it, actully you have to do some changes in ur registory, and that is very simple,

    - Start > Run > type ‘regedit’ (without the speachmarks) > Enter
    - Single-click on ‘My Computer’ > File > Export > save it to the Desktop (Always best to have a backup!!)
    - Go to the following:
    My Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDeviceP olicies
    *There seems to be some spaces here in 'StorageDevicePolicies' in the text above, there shouldn't be, OK*

    - Double click on the string ‘WriteProtect’ and change the ‘Value Data’ box to ‘0’

    that's all.....plug off the usb dirve and plug in again, now you can copy and delete the files from ur usb.....
    enjoy it....
  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Don't worry I copied this down ages ago
    I have the format options and the registry option, and even the little mico switch all in one text file to quote to others :)

    One user tried all and didn't work
    So other than manufacture format tools
    I'd say faulty USB drive (or data cable if it has one)
  8. jonamoos

    jonamoos TS Rookie


    like all of u i had a same problems withmy usb flash memory
    xp said that it is lock and i could not write or even format it

    i checked with many programs but non of thems work

    so at last i boot with dos ! i had a bootable cd i try with it
    my flash memory in dos was B: so i use scandisk in dos
    it find some problems and solved them and then i can
    format it in dos

    i wish it can help u all of my friends
    ( i hate microsoft xp )
  9. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Thanks for your info and time.
    By the way if you hate Xp, why use it? Try Linux instead of complaining
    Also try to write I instead of writing "i" (this is especially important when trying to help others, ie be clear)
  10. jimrich

    jimrich TS Rookie Posts: 36

    no storagedevicepolicies

    ...I looked in my registry (win xp, sp2, home ed.) but can find no such item in that registry string.
  11. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Obviously this thread gets viewed a lot (must be Google searches or something :confused: )

    Anyway, because no one wants to create a => New Thread; I'll just post some general info here! (Something is bound to work!)

    Advanced troubleshooting tips for general USB problems in Windows XP;en-us;310575

    The Care and Feeding of USB Storage Devices in XP

    USB Guides

    Solved: Drive Letters Cannot Be Assigned to Flash / USB Drives Under Windows XP

    Flash drive recovery procedures

    Western Digital external hard drive problem

    How to remove Virus from USB Drives

    Format an unresponsive USB Drive :grinthumb

    Troubleshoot: Windows Won't Recognize USB Hard Drive / Fix Unassigned Drive Letter :grinthumb

    It would be nice to know which one worked for you ;)
  12. maenam

    maenam TS Rookie

    YOU are a legend mate 4hrs scrolling through useless help topics, i knew it was a windows error and now the answer, all my control settings for groups 1 3 4 were set to 1 not 0!!!! all 5 of the usb sticks i have bought now work

    THANK YOU!!!!!!!!!!!!!!!!!!!!!!

    ps. i have XP SP3 and only needed to change control settings didnt save anything
  13. Itamar Chavez C

    Itamar Chavez C TS Rookie

    Hello all the people at forum

    To day I get big help from your community about problem in my PC ,
    The problem is : not have permit for to write in pendrive and external storage disk .but in your forum I found the solution, thanks very much.
    Now I am part the community of course one baby in this but have big curiosity and learn quick.
    have all very good day, afternoon, morning or night!!!

    Take care
  14. xehqter

    xehqter TS Rookie

    I wrote an article a few weeks back describing different types of flash drive failures and a few quick fixes to try. People experiencing flash drive issues may find it useful.

    How Flash Drives Fail
  15. jackonline

    jackonline TS Rookie

    thank you very much FATBIRD actually i googled for this problem and reached very near to the soluttion you gave but i found that controlset001 etc. are also to be changed....thnx once again
  16. eyezkills

    eyezkills TS Rookie

    Need help!

    I have this 4GBToshiba Transmemory USB Device. I used it last Wednesday. I was copying stuffs like songs and games and trying to save it on my USB then all the while a copywrite protected popped up. It said I need to remove the copywrite protection or use a new disk. I can't delete my old files too nor can format the device itself. Also I can't put new files again.

    I tried fatbird's solution but I can't find the StorageDevicePolicies...

    Please help me... I just borrowed it and I'd be so dead if the owner will learn I ruined her USB.

    please! thanks a lot!
  17. ShowPlay

    ShowPlay TS Rookie

    "Write protection" is actually an old Windows limitation

    If you are copying your files in the root folder, Windows has an arbitrary and archaic limit of about 128 files.

    To overcome that, simply create a folder and copy your files there instead -- voilà!
    No more limit...

    Well, were you expecting quality from Microsoft ?
  18. long20k

    long20k TS Rookie

    Fix for USB Card Reader With SD-to-Micro Adapter

    If you are getting a "write protect" message while trying to access a USB card reader/writer with an SD-to-Micro adapter in it, suggest you look carefully on each edge of the adapter. You may see a previously unnoticed (and tiny) slide switch.

    My Sandisk Micro-to-SD Adapter has such a switch, although I didn't see it two months ago when putting a 2GB micro into the adapter and then putting the adapter into the USB card reader/writer.

    Everything was ok until a couple of days ago. Then the "write protected" error appeared. Looking closely, the adapter did have a slide switch with a very small tab. It also became clear that the very act of removing and then reinserting the adapter into the reader would often push the tab backward enough to enable the write-protect mode.

    Using magnifying goggles, I carefully applied small drop of nail polish behind the tab. This proved enough to hold the switch in place. Please be careful. The tolerances are so small that too much nail polish could create its own problem.
  19. nanysut

    nanysut TS Rookie

  20. alswee

    alswee TS Rookie


    Hi guys, go to this website if interested to buy a write-protect thumbdrive: google it for a webpage called

    I've used it and it works great.
  21. lucifer98

    lucifer98 TS Rookie

    The same problem


    I just won a Duracell USB Stick 960 MB...It worked for 2 days...But yesterday I tried to format my Memory Stick and it sais I need to remove protection...What protection???...I tried to remove the protection with the solutions posted recently...maybe not recent :D:)but can someone help me please
  22. lucifer98

    lucifer98 TS Rookie

    For information:Duracell isn't a model of USB stick...I just won it from batteries Duracell...I dn't know what model is it:D!
  23. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    You need to try the things already mentioned in this Topic, before posting here

    If you have tried everything, then throw it away, or go back to "batteries Duracell" or wherever you won it, and say it doesn't work.
    Hopefully they give you a bigger one than 1 gig, really unheard of these days
  24. bringmeinplz

    bringmeinplz TS Rookie

    Okay, I have read through just about the whole thread and the same thing: "Cannot format (or whatever) - disk is protected remove write protected or use another disk". I have Windows XP Professional SP3, I'm using a 1 GB flash drive my Grandfather gave me from his work, which is at BMW so it says BMW on it, I do not see a switch for write protection.I have 3 others that aren't write protected and they are the same thing!!! This really pisses me off! Please help!
  25. GHORI9888

    GHORI9888 TS Rookie

    Write protected pen drive format

    Thanks buddy

    than after eject your pen drive and insret again
    than format your pen drive
    than you go
    now your pen drive is ready to use

    have gr8 work with you pen...............
    It work

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...