1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB IDE HDD not detected. Cause PC to hang

By desmond531 ยท 15 replies
Sep 27, 2009
  1. Hi,
    I see a number of people have had a similar problem but have tried all the solutions n nothing has worked..

    Bought a new maotherboard and processor.. Installed windows xp sp2. USB pen drive gets detected but my USB IDE HDD 160 GB doe not.. Does not get detected at BIOS and windows hangs durng loading if it is connected.

    If i connected it after Windows load , icon for removable hardware come in the system tray and Device is seen in "device managment" but its hangs and you cant access anything.

    Do not see it in Computer management if I open the window and then connect the HDD. Cant open Computer management after connecting...Window will open only after I remove the HDD.

    Could it be a problem with IDE number. The new mother-borad has 1 internal IDE connector to which i have connected my old internal hard disk and DVD rom. Both get detected at boot up.

    Please help!
  2. brucethetech

    brucethetech TS Enthusiast Posts: 229

    I know this may be stating the obvious but did it come with a installation disk it may not be plug and play.
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409

    IDE has absolutely nothing to do with it because it gets switched to USB in the enclosure.

    Either the enclosure is no good, or its some super obscure board doing the IDE/USB conversion where you need a driver. OR the most likely thing is the drive isn't getting enough power over USB to work properly. 3.5" drives will not work by being only powered by the USB, so you have to use an external power adapter. Most 2.5" drives will work, but that seems to be more dependent on the computer and how its USB ports/controllers are set up. So.. Try a different USB port if its a laptop drive, and regardless of the size of the drive use an external power adapter with it.

    And just on a personal note, I don't believe that a lot of people have had this problem and nobody has had a solution that works for you. I'm pretty sure that similar things have been said here, all with solution given. And this is probably a pretty common 'issue' across computer forums. I think it was just a way to get us to think you actually did some research before making your first post here. If you did try "ALL" the solutions, then telling us what they were would prevent us from wasting our time telling you things you already did.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Am I correct to restate this as: you are using a USB cable to connect your external IDE HDD (either directly over cable or is the IDE HDD in an enclosure?)

    If so then here some fixes to try and start withwhen connecting an external USB drive,
    1. See USB Device Problems? Check for Windows Updates
    2. Does the external drive have it's own AC adapter? if so, be sure it's ac adapter is also plugged in
    3. Make sure the problem is not do to Windows device conflicts. Unplug all your USB devices and remove any stale USB connection data Windows is still saving. See How to use the DriveCleanupTool
  5. desmond531

    desmond531 TS Rookie Topic Starter

    Hi. Thanks for your replies.

    No it didnt come with any installations cd. It was working fine with my old windows installation and even works fine on my laptop..its just with the new motherboard and processor that i see this issue.

    it doent have its own ac adapter...its a 2.5 inch case and it has the cable which plugs into 2 USB slots on the computer..I have tried with different combinations of slots. I can also heard the disc starting up.

    n btw i did search like crazy online and tried alot of stuff like reinstallin the chipset drivers, diabling USB in BIOS and remove all USB driver and then enabling USB again so that the drivers are reinstalled, changin the drive name of my dvd rom incase the drive letter is conflicting, even re-installig windows and all the drivers! so really post as last resort and much appriciate the time and inputs.

    will try using drive cleanup and check out the other link for usb device problems and get back to ul.. thanks alot!
  6. desmond531

    desmond531 TS Rookie Topic Starter

    tried drive cleanup but no luck...

    the releveant options in the link USB device problem pertain to issue of not detecting devices at all...here I am able to detect and read my 4 GB San Disk pen drive but have an issue with the 160 GB external IDE.

    For confirmation, I am using a USB cable to connect your external IDE HDD which is in a 2.5" enclosure

    Ne thing else you think i can try? Totally frustrated that I have spent the first day with my new comp restarting and installing drivers rather than playing NFS :(
  7. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409

    Do you have another computer you can try it on? It sounds a lot like an underpowered drive, but pulling from 2 usb ports on different controllers should eliminate that.. I suppose its possible the drive is just bad.
  8. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    Except he said that it works with other computers, including his laptop.

    What about the rest of your hardware?
    For example, do you have other usb drives that you are trying to attach at the same time?
    The reason I ask is this...
    I have a USB drive that is set-up to recognize as my "e" drive.
    I have another that the computer has decided to recognize as "e".
    When I attach both and then boot, the computer will not recognize either one.
    I need to plug in one, or else plug in the second after boot.

    I just haven't gotten around to fixing it, since the old "e' drive basically is not used much, so very seldom need to attach.

    Here is another possibility...
    You said that the issue arose with the new MB.
    Are you absolutely certain that your USB ports are PROPERLY connected to the new motherboard? If it is possible to invert the connecter on your board, this may be the cause of your issue.

  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Hi B00kWyrm!
    Your specific problem with your "e" drive is exactly what the drivecleanup tool will help easily fix! (i mention the tool earlier in this thread) Here's why
    • When a USB device is first connected to a USB port, Windows creates a USB "descriptor" for the connection
    • The data in the connection's USB descriptor includes stuff like the drive assignment for the connection ("e" in your case)
    • The USB descriptor is NOT deleted when you unplug the USB device. It's only deleted when you UNINSTALL the USB device. (That's cause the data is supposed to help Windows reconnect the device quicker when you unplug/replug the USB device to the port)
    • To fix: If you unplug all your USB devices and then run the drivecleanup tool, the tool deletes all the USB descriptors. So next time you replug any of your USB devices Windows will create a new descriptor with a new drive assignment

    /* edit */
    and, btw, it usually deletes lots of old and stale descriptors you don't even realize are still being saved by Windows!
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Hi desmond531

    You might also try using a USB external hub that can supply a 1000mA port. This would rule out any issues with drive failure due to USB power. (i;ve had a somewhat similar problem with a WD Passport that was failing to connect.)

    Check your computer store or online. Look specifically for a USB hub that provides 1000mA USB ports (the standard hubs and USB ports normally only provide 500mA)

    (for example, i use a Targus ACH81 hub. 2 of its 7 ports supply 1000mA. The WD passport hasn't failed whenever i connect to the these port)
    If not USB power issue could be hardware as B00kWyrm mentions
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

  12. desmond531

    desmond531 TS Rookie Topic Starter


    I do not have any other USB device connected so cant be the e drive proble.. also i have run drivecleanup

    I guss the USB ports are properly connected on the MB since my 4GB pen drive gets detected fine from the same ports

    I have tried resinstalling the USB controllers and chipset driver already ...no change

    Guess only option is to try the USB hub ... The cable i currently connect with uses 2 USB ports of my machine. neways ill will pick up a hub and try
  13. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    Please let us know how it goes!
    You will need to do your research to find one that meets the power spec suggested above!
  14. desmond531

    desmond531 TS Rookie Topic Starter

    hi guys...

    I installed windows 7 and tried viewing it from there. It come up in the list in explorer but hangs when you try to access it. Show in the list of Safetly Remove hardware as USB 2.0 IDE dvice but if you try to eject nothin happens and the light on the external HDD remains on.

    I went to check out USB hubs today. But they only had Hubs which are connected to a single USB port..so more like spliters.. ie Not connected to external power sourse so made no sense buying.

    Saw a Logitec 4 port with power adapter for IND Rs 1600 on ebay. Think that is what I need.

    For now I bought a 500 GB SATA internal HDD for IND Rs 2500. Will take it to my friends where my crappy 160 GB is working and transfer all my data to it :p

    Didnt wanna take the risk of buying the power adapter and then still not having a working disk.

    Thanks for your help guys.. If i do get around to buying the adapter will defietly update this post...
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Hmmm... The fact that it continues to "hang" vs. not being recognized or access errors sounds more and more like hardware/firmware issues rather then being due to USB power issue.. tho i'll add i, personally, find it handy just having a 1000mA hub around whenever i plug in a high powered USB device (like external disk drives).
  16. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    SNGX1275: See below... I overlooked stuff in the thread too, :blackeye: more than you did by far! As I said before, I have nothing but respect for you!

    LookingAround: What I just said to SNGX1275!
    and Thanks for the pointer re: drivecleanup tool. I'll add that one to my toolkit.
    I had not read your earlier post carefully enough. Sorry about that.
    My post wasn't really adding anything toward a solution. :eek:
    You had already provided an answer for my first suggestion.
    My second suggestion was ruled out by the very first post re: the pen drive.

    We need smilies for... :"Donning Dunce Cap": and :"sitting in the corner":
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...