1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB modem does not connect in XP, and there is no reason why it should not

By Lokalaskurar ยท 5 replies
Oct 1, 2010
Post New Reply
  1. I have four computers here, two running XP Pro, one running XP Media Center Edition and one running Windows 7 home (this one).

    I also signed up for a wireless 3G-modem (USB-connected).

    (Yes, I know that the USB port was really never made for LAN and I should have chosen an RJ45-model instead and so on...)

    The modem itself, a Huawei E1750, works flawlessly with all computers except for one, the one with the XP Media Center Edition on it, which also happens to be my gaming PC, thus I've installed tonnes of registry-changing games on it.

    The modem boots up, but always fails to connect to the 3G network (even the 2G network). It simply says: "Could'nt find a wireless connection." And goes back to idle mode.

    Could this be due to a pretty broken register?

    I will not run a registry-cleaner on the MCE-PC, because I've done so when the modem was faulty on the XP Pro's, and that jammed the modem up good.
    Luckily, those Pro OS's where easy to reinstall. The MCE-PC isn't.

    Might I get some advice on how to get the modem working with the MCE-PC?
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    1. I'd avoid any registry cleaners. Most will end up doing more harm then good. (The more aggressive the cleaner, the higher probablility it will screw you up someday)

    2. I'd first try reinstalling the driver
    > Check under Add/Remove Programs first. If you find it listed there, uninstall from there (this will uninstall from Device Manager as well). Otherwise, uninstall from Device Manager.
    > Now reboot. The Huwaeii should NOT reinstall itself. If it does, look in Add/Remove Programs again. You missed it
    > Now reinstall the driver package for the Huwaeii

    If you still have problems, you're best to check with the devcie provider for your 2G/3G net as they'll have specifics for that model and what it should be looking for (and its settings)
  3. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    (Sorry for the delay)

    Well, whaddaya know? I fixed the problem!

    Thing is: my video game guru/vendor quit, and the need for downloading games on the MCE-computer aroused greatly. Thus, I had to get things working - fast.

    So what was the problem?
    1. The PC had an internal modem that snatched the COM port away from the USB-modem.
    2. The registry was clogged up with game-registry junk that didn't allow new modems (units) until cleaned.
    3. The software used by the modem was corrupted.
    4. The firewall blocked all new incoming signals to the modem (including the 3G-tower signals).

    1. Remove the internal modem.
    2. Manually clean the registry from any entries made by the old modem.
    3. Download new software for the USB modem.
    4. Open ports 80, 81 and 120 for the modem. (why 120 - I do not know :confused: )

    All in all, the USB-modem started working, and I've even downloaded a couple of games using it. Problem solved.

    Thanx for the help, guys!
  4. jobeard

    jobeard TS Ambassador Posts: 10,432   +800

    not much detail on port 120
    CFDPTKT -- Coherent File Distribution Protocol
    see RFC1235 @ http://www.ietf.org/rfc/rfc1235.txt
    that smacks of FTP and imo has backdoor capability. I would close port 120 and wait to see what kind of diagnostics appear - - -
  5. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    I tried closing port 120, and it stopped working with an error message: "Error M13" - I opened port 120 again (started working) and looked up "Error M13."

    Also, running a search (in that neat document jobeard found) on "intercompability" and "port 120" also results in various statements further emphasizing that in this case, port 120 is used for checking and receiving (some kind of) signals to the 3G-tower.
  6. jobeard

    jobeard TS Ambassador Posts: 10,432   +800

    When using Ethernet (ADSL, Cable, or Satellite connected}, the comment
    is bogus as it relates ONLY to "modem-dial software", not Ethernet.

    The error M13 does directly relate to "or by denying it access to port 120 or port 121 using a firewall. " as that was the choice made.

    This 'noise' is from your system making a request on port 120, as an error for inbound traffic would have been blocked sliently.

    Suggest you view the systems and application logs; start->run->eventvwr.msc
    and locate the application that issued the M13 error

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...