1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB mouse freezes intermittently on laptop

By josbd ยท 15 replies
May 16, 2010
  1. Not posted in a long time, so apologies for having been a stranger.

    I have an Acer Aspire 5920, prob about 18 months old. Bog standard issue, nothing outstanding.

    I detest touchpads for many reasons, so ever since I have had the laptop, I have disabled the thing and been using a usb mouse. Again, nothing special. Wired, cost about a quid from ebay. Within the last week, the mouse began freezing. If unplugged and replugged it would work again. Dodgy mouse, I thought at first and tried another. Same situation. Dodgy usb port? No.

    Did some googling and it seems this has been a problem for many for a good couple of years now. Various solutions have been suggested and worked for some (usually those with far more expensive meece than my wee lighting up job).

    I have tried all of these suggestions and .... nothing makes a difference. It seems to be getting worse now, since often simply unplugging and replugging makes not a difference until a couple of hourse have passed. So I have to resort to reenabling the damn touchpad, which causes a lot of swearing and much annoyance.

    Nothing has changed on this laptop in the last couple of weeks, it is not overheating, it's just peaceably getting on with it's job as usual.

    If anyone can save what is remaining of my sanity, I would be very grateful. I have stupidly generously lent my pc to one in desperate needs, otherwise this thing would have been flown through the window by now!

    Many thanks.

  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Hi Jo,
    what antivirus or anti-malware software are you using? What version of Windows?
  3. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Have you tried other USB mouse devices known to work well on other computers?
    Sometimes you have to download USB drives even though they should not be needed. We have seen this on a number of Acer laptops... Once USB drivers are installed, it works fine thereafter.
  4. tipstir

    tipstir TS Ambassador Posts: 2,425   +112

    What OS? When last you clean out the registry for errors? Does the touchpad work? You said you had disable that how? In the BIOS or in the OS? You should do both. USB controller drivers tend to get corrupted. I take you have remove them all and let the OS re-install it correct?
  5. CAMusing

    CAMusing TS Enthusiast Posts: 179

    Have you tried a new mouse, they do wear out? And no, it does not have to be an expensive mouse to work.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

  7. josbd

    josbd TS Booster Topic Starter Posts: 198

    OS = Vista
    Antivirus/Malware = Avast! A-squared with MalwareBytes as a double check

    Registry is cleaned every two days, along with all other "housekeeping"

    I have tried several mice which I know work; this mouse works perfectly well on another pc in the house.

    I have used Windows Updates. There is no problem highlighted in Device Manager.

    I do what I always have done with laptops, disable mousepad with the fn key.

    The only thing I have not done is uninstalled usb drivers, so I shall try that next.

    As I say, this has been a perfectly happily working system until the last couple of weeks. Also, googling this problem throws up many many complaints of the same thing happening with Vista, not just with laptops but with pcs as well.

    Thanks for the suggestions guys. will uninstall usb drivers and let it install itself as per.
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    LookinAround has provided a link for instructions How to Reinstall Your USB Controllers and Motherboard Chipset Drivers... I would think that reinstalling your motherboards chipset drivers would be the key to solving this problem
  9. raybay

    raybay TS Evangelist Posts: 7,241   +10

    It appears you have a defective motherboard, or a defective socket in need of repair or replacement...
    I hope it is still under warranty, as this is a problem we see too often on Acer boards.
    Appeal for an entire board replacement... But in our experience on similar issues, Acer even wants shipment paid in both directions in advance...
  10. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Be sure you talk to Acer and affirm that they have not done a recall, and are not aware of a common problem in that model of system board.
  11. nbfi

    nbfi TS Rookie

    same situation

    nice to meet you. I'm new here. I'm hardly battling this problem too on a small aspire one AOA150. I have this problem since a week ago (may be ten days). I strongly think that this came out from an OS update (windows home).
    Here some strange things that happen:
    - in device manager, after plugging in the usb external mouse, I hear a Ding sound as usual, but ... no mouse device comes up, just the HID device.
    - other strange thing: if I connect a different kind of mouse (an old ball mouse instead optical) for a while (maybe two seconds) it works! ... then disappear. any kind of thing I do (reconnecting, deconnecting, changing port, etc,)
    I also made visible the 'invisible devices' but nothing strange there.
    Ok, maybe my mother board is gone too ... but ... I see many things that seems similar.

    (sorry for my bad english)
  12. josbd

    josbd TS Booster Topic Starter Posts: 198

    ok, tried all of the above and have come to the conclusion that it has to be a dodgy mobo. It isn't simply the socket as I have 4 usbs and have tried them all. I've not come across anything to suggest that this is a particular prob with Acers, tho I do know exactly what you mean.....

    As usual, the thing is out of warranty, but I shall bell Acer and see what they say......I can imagine......

    Time to get my pc back I think!

    Many thanks indeed for your time and help :D
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Hi josbd and nbfi

    This is a long shot (but may as well give it a try as it's easy)

    1. Try unplugging any other USB devices except your mouse and keyboard to see if the problem is any better

    2. Don't allow Windows USB power management. Find instructions in See How to Avoid Problems with USB Storage Devices
  14. josbd

    josbd TS Booster Topic Starter Posts: 198

    Sadly not.

    One of life's wee mysteries, well in my case another Acer mystery. I should know better.... *bangs head on desk*

    Thank you so much for trying.
  15. nbfi

    nbfi TS Rookie

    1 & 2 already tried.

    Thanks a lot for help
  16. josbd

    josbd TS Booster Topic Starter Posts: 198

    A bit more info. Eventually I decided not to bother with the mouse, and simply be bloody irritated with the mousepad. Then the external hard drive *disappeared* from view, and couldn't reinstall it. Following that, the Creative sound drive did same. I uninstalled all drivers and let them sort themselves out and all was fine.... for ten mins. *sigh*

    Part, the final....... THEN the bloody touchpad stopped working! New drivers, and no, so basically, it is under my bed collecting dust and there it shall stay until I recover some patience.

    Once again, thank you all for your help and time.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...