Vista sees Multiple network connections. I only have one

By mokaboy · 12 replies
Jun 4, 2008
  1. Basically ive been having a problem on my Windows Vista machine since installation. I connected it to my router and was browsing the internet near enough straight away but after i restarted there was another network windows was trying to connect to and although lan connections are fine i cannot connect to the internet.

    # I have not got wireless so i have ruled this out.
    # Disable and Re-Enabling the network device is a quick fix but restarting will only show the other network again.
    # I have been searching google for a few days now and have only found the quick fix solution of Disabling and Re-Enabling the device.
    # A friend told me to untick IPv6 which i did but still nothing

    Is anyone familiar with this problem, its definatly a vista problem as my XP laptop is fine.
  2. xxdanielxx

    xxdanielxx TS Booster Posts: 1,069

    what do you mean windows is trying to connect to another network? Does it show the limited or no connectivity. Can you post a picture it would help a lot.
  3. mokaboy

    mokaboy TS Rookie Topic Starter Posts: 136

    Well under Network and Sharing center i see 2 networks, one private and one public. The connection indicator at the top shows ive connected to the 'network' but the internet is not connected. This additional network comes out of nowhere and when i disable and re-enable the nic this network goes away and all is well. When i restart it is back?

    Here is a link to someone else explaining near enough the same problem.
  4. mokaboy

    mokaboy TS Rookie Topic Starter Posts: 136

    Anyone, i still have this problem and its driving me up the wall!
  5. infofreak

    infofreak TS Rookie

    Having the same problem

    I'm having the same problem on a Vista machine I'm working on. No wireless is installed on the machine, and there is only one network adapter.

    In the hardware profile, there is also only one network adapter showing in the list of devices.

    This system was purchased in February 2008, and has been barely used. The only software that has been installed on it is MS Office 2000 and the latest auto-updates for Windows.

    Disabling and re-enabling the NIC works for me as well to "band-aid" the problem until the next reboot.

    Upon reboot, the network status indicator shows the two monitors indicating LAN connectivity, but the globe icon is missing. When I single-left-click the indicator, it lists two networks: "Network (Secure)" and "Unknown Network (Public)".

    When I click the "Diagnose and Repair", the utility says I have two network connections active and that I need to disable one of my connections... But again, there is only one network connection.

    It's a Dell computer. On the geek scale of 1-10, I'd say I'm 6-7. Without any disrespect to the good phone techs out there, 9 times out of 10 I find my solutions in spite of phone support. Because I'm not up on Vista, I called Dell support who said it was a problem with my router and they wouldn't help me without elevating to paid support (which I didn't do, of course :p).

    Any thoughts or help would be great!

  6. xxdanielxx

    xxdanielxx TS Booster Posts: 1,069

    if you have Bonjour remove it and see if it fixes the problem

    Go to [Start > Run] and type the following command and hit OK.
    “C:\Program Files\Bonjour\mDNSResponder.exe” –remove
    Go to [Start > Run] again and type the following command and hit OK.
    regsvr32 /u “C:\Program Files\Bonjour\mdnsNSP.dll”
    After you restart, you can safely delete the Bonjour folder without errors.
  7. infofreak

    infofreak TS Rookie

    Status update

    Thanks for your ideas Daniel. I ran several virus and spyware scans from verious vendors (in addition to the built-in active security suite that shipped with the machine). Nothing there. I will be back at the machine tomorrow and will try uninstalling the Bonjour. Since you mentioned it, I do recall seeing that he had iTunes installed on the machine.

  8. mokaboy

    mokaboy TS Rookie Topic Starter Posts: 136

    please let me know if this works! :)
  9. xxdanielxx

    xxdanielxx TS Booster Posts: 1,069

    mokaboy that was for you (above) try and post back if not we can reinstall Bonjour
  10. mokaboy

    mokaboy TS Rookie Topic Starter Posts: 136

    it was a friends computer, i cannot try for at least 3 days. Sorry!

    ill post back asap.
  11. paragsony

    paragsony TS Rookie


    Eveen I had the same problem, what I did was went to IPV4 uncheck the radio button and saved it. Again went to IPv4 and check the radio button and it worked

    But this is a temp soln as i rebooted the vista, the 'unidentified n/w' came again.

    So even I, till now, havent got a perm soln
  12. mokaboy

    mokaboy TS Rookie Topic Starter Posts: 136

    its to do with iTunes, and a program it installs called bonjour. I had to boot into safe mode remove bonjour and boot back into normal mode and it fixed the problem.
  13. jobeard

    jobeard TS Ambassador Posts: 11,131   +982

    recommend disconnecting EVERYTHING and restarting the devices in this order
    modem, router, and (still disconnected) the system.

    connect the modem to the router and wait 30 seconds

    connect the router to the system and wait 30 seconds

    launch Network Wizard and recreate the Local Connection,
    being sure to specify, I'm Behind a Router, Private LAN.

    Let it complete.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...