WD Backup doesn't work on WD My Passport Ultra

By macx
Sep 1, 2016
Post New Reply
  1. Hi

    I liked what I read about the auto backup feature so bought 2 of these, one for myself and one for a friend
    who has some important files on her laptop.

    My friend has 8.1 and was the first time I tried this drive and the software. Just using the included WD Backup it worked fine.

    I've got Win 7 Home Premium x 64 on a Dell Inspiron and the drive I bought for myself seemed to work except that while trying to install WD Backup it couldn't identify a backup target. I got WD to replace it, but the same
    thing is happening with this one.

    Ive emailed their support and have rec'd a reply but it was just a couple questions I had to answer for starters.

    I've since read that the WD drives like this have a high failure rate? I purposely bought WD because I've had
    a number of their internal drives that have been very reliable.

    I just looked on CNET Download and saw there are a great number of well regarded free backup apps. I'd appreciate any good experiences with any one of them. I want to be able to unplug the drive except when I want to back up, and then would prefer the process to be simple, I.e. just plug it in, open it, and click "backup" on the soft ware and have it update any previously backed up files and copy any new ones.

    Also would like to create a mirror of my operating system on the backup drive.

  2. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    WD 1&2TB seem to be very reliable, while the 2,3&4TB fail frequently.
    "create a mirror of my operating system on the backup drive" - - MIRROR is a RAID-1 term and life gets complicated attempting that now that the system is already installed. I hope you're really thinking more alone the lines, of file copy of the C: drive.
  3. macx

    macx TS Evangelist Topic Starter Posts: 718

    Update: I spent an hour online with a WD tech person taking over my computer and trying everything he knew
    to make WD Backup work, to absolutely no avail. He said he'd never run into this situation before where WD Backup
    says it installs but it isn't listed in the Control Panel or even in the Registry. When WD Backup is started and I get to
    the Select Backup Device page (or whatever it's called in the WD software) it can't find a backup target even tho the
    app comes right off of the WD drive itself.

    I'm going to try on my friend's machine this weekend and he's going to call and see how it went after I get home.
    I had installed a similar drive and software on her 8.1 and it worked fine the first time. Altho she recently informed
    me that hers is now doing the same thing.

    I'll post what I discover.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...