WD "My Passport" Ultra 1TB not recording data

By Jacflash
Aug 27, 2015
Post New Reply
  1. Bought brand new one WD "My Passport" Ultra 1TB, plugged it in to my laptop "Lifebook" A Series running window 7.with supplied short lead.
    followed instructions,formatted drive, instigated back up of total hard drive from laptop to Passport everything seemed to munch away for about 40mins or more, when finished I opened the passport file on the laptop to view that it had the contents to find it was empty.
    tried again with same result.
    What am I doing wrong? please be kind! I'm not a technophobe but I do seem to get tied into an "electronic loop" on a regular basis and don't know the computer jargon words or what abbreviations mean.
    Thanks in advance
  2. Techpumpkin_WD

    Techpumpkin_WD TS Member

    Hello there,

    Could you please explain how exactly are you coping the data – are you using WD SmartWare, different backup software or just copy pasting? If you are using backup software please try to manually copy a file from your laptop and paste it in the My Passport drive. Does the file appear then in the external HDD? Keep me posted.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...