Wi-fi, audio, one USB not working on Asus X202E

Tomaz Lemos

Posts: 7   +0
Hi, it's my first time posting here but I've read and learned a lot from this forum, so thank you all very much in advance!

I'm trying to repair a friend's Asus X202E. It worked normally until it got stuck in the blue screen during startup, and wouldn't complete booting. Someone formated the HDD (including the recovery partition) and installed W8.1, which worked but with no sound or internet (wireless or cable). The device manager doesn't show these devices at all. One USB port doesn't work either.

I first thought it was a driver issue, but couldn't make it work. After many attempts I decided to try a W10 clean install, which is installed now, but the symptoms remain the same. I can access the internet through a USB wifi dongle.

I've tried:

- Using Windows troubleshooter;
- Downloading and installing many drivers from the Asus site, for many components (besides audio and internet cards);
- Downloading a X202E drivers compendium some good soul posted here in this forum;
- Using DriverEasy;
- Installing the audio card as legacy in device manager;
- Reseatting wi-fi card;
- Checking the logic board for damage (not good at this, but it looked alright);
- (Going to update as I remember more steps I tried)

I'd really appreciate your assistance in this matter, thank you all!
 

Tomaz Lemos

Posts: 7   +0
Ok, thanks, going to check that out, though it might not be that easy as I´m from Brazil. I´d really like to figure it out though, it looks very much like a software problem to me... Some chipset driver maybe... Asus is not that good at support, there´s no manual for this specific notebook, can´t find out if the audio chipset is Realtek or Via for example. Dell support is much better in this. And sure enough I´m not that proficient as well in all this...
 

Tomaz Lemos

Posts: 7   +0
Summarizing the situation so far:

The full model of the notebook is Asus S200E - ct252h - X202E

It had a persistent blue screen during boot which desapeared after a fresh install. After that, no wi-fi, no ethernet, no audio, no USB 3.0, on both W8.1 and W10.

I have tested: ASUS driver update, Intel driver update, DriverEasy, many original X202E ASUS drivers. Neither Audio or Network devices appear on device manager.

Can it still be a driver issue? Would it be a device by device driver solution, or could there be a chipset driver that would "unlock" the devices?

If not a driver issue, what else could it be?
 

Tomaz Lemos

Posts: 7   +0
Well, I finally gave up, going to assume the logic board is toasted and buy some USB dongles for the missing functions, as my friend can´t afford a new logic board.

Thank you all for the assistance!