WiFi showing 'limited', Ethernet works fine

By WayneY ยท 5 replies
Dec 21, 2015
Post New Reply
  1. Hello,

    Referring to the title, I can't seem to connect to the internet using my laptop's WiFi connection for the past week. The wireless connection always shows 'limited'. However, the internet works fine when the laptop is connected using the Ethernet cable. I tried to ping using my wifi, but the request always times out.

    My laptop is a HP ENVY dv4-5205tx model (Windows 8.1, using Avira Antivirus free edition) using a Ralink RT3290 802.11bgn WiFi Adapter. The router I'm connected to is a TP-Link TD-W8970 model.

    I only started having this problem recently. Prior to this, I have been able to connect to this router, and also different routers. Other devices have no problem connecting to this, only my laptop.

    Attached is the ipconfig file generated in text form while it is connected to the router.

    @jobeard I read a thread where you helped to solve an issue similar to this, so I hope you could provide some assistance if possible.

    Thanks for reading, and hopefully something can be tried out. I'm trying to avoid reinstalling my OS as a way to resolve this.

    Attached Files:

  2. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    Did the wifi EVER run on win/8.1?
    was Avira Antivirus installed before or after the problem occurred?
  3. dernt

    dernt TS Rookie Posts: 30

    Go to: Control Panel\Network and Internet\Network Connections\Properties and remove the Teredo tunneling item
  4. WayneY

    WayneY TS Rookie Topic Starter

    Thank you for your responses. I was busy which is why I can only respond now.

    @jobeard Yes, the WiFi worked before this on 8.1. I only recently started having this problem. I am not sure whether or not Avira updated to a new version before this thing happened. In any case, I have tried unsintalling and reinstalling Avira. The Wifi still showed limited during the time Aivra had been removed.

    @dernt I can't seem to go to the location you specified, I don't see Network Connections. When I move to Network and Sharing Center I can't see the Teredo tunneling.
  5. dernt

    dernt TS Rookie Posts: 30

    Not to sound like a broken record, I just copied this from my other post that someone was having a similar problem.
    Windows 7? click the internet icon next to the clock on the task bar (bottom right corner), open network and sharing center. Then click the change adapter settings (left side), next, right click the wifi adapter and go to properties. that's where u will see any tunneling items. But according to your post I see teredo listed as a Tunneling Pseudo-Interface and it needs to be gone.
  6. WayneY

    WayneY TS Rookie Topic Starter

    From the wifi adapter properties I can't see any tunneling items. I did however find it under the Device Manager after googling it up. I have disabled the Tunneling Pseudo-Interface by typing

    netsh int teredo set state disabled
    netsh int isatap set state disabled

    I also disabled the isatap using the commands above that I found online. The updated ipconfig file is uploaded here, no longer showing the tunneling connection. I restarted my laptop, and my connection is still showing 'limited' unfortunately.

    Attached Files:

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...