Win 7 (64-bit) mouse pointer flickers/disappears on XP apps/games

By yamaraion
Jan 1, 2011
Post New Reply
  1. That pretty much says it. The app/game can run quite well but drives me insane trying to use the pointer to click on hotspots. Sometimes the pointer is only visible when it rolls over a hotpiont and lights it up. Otherwise, the application runs quite well. Examples this week are CIV 4 COLONIZATION (but not CIV IV), GUILD WARS (prob the worst). Earlier games like AGE OF WONDERS 3 seem to work fine. I do see this mostly in games.

    The other issue I have a lot is that I can install and run a game from the CD/DVD but then the game will not play as it cannot see the disk it just booted from and claims it is not in the DVD drive.

    What is causing these and can anything be done? I have tried all the usual compatibility fixes. I have even run them on a VMPlayer XP emulator with no success.

    It reminds me of the issues with DOOM TRILOGY on WIN XP. That was dos driver issue for the mouse. However, this problem occured right out of the box before and after updates installed.

    Win7 Home Premium 64-bit (updated to current)
    Gateway SX-2840 Core i3 CPU 530 @2.93 GHz
    Gateway dual-core CLARKDALE
    6 Gb DDR3 RAM
    GRAPHICS EQUIVALENT = 256 MB ATI Radeon HD 2600 XT or better, 256 MB NVIDIA GeForce 7900 GS or better, or Core i3 or better integrated graphics (it uses the integrated graphics chip i3)
    Systems Requirements Labs says these should run on it.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Have you tried another mouse? Is the mouse wired or wireless?

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...