Windows 2003 Server problems

By cmatthee · 8 replies
Mar 13, 2008
  1. Hi

    I don’t have a lot of experience with 2003 server but one of my clients called me out yesterday to come and fix an internet problem after a power failure. The fault I found was that I could only go on the internet from the server and none of the other workstations on the network. The ADSL modem is connected on a second NIC on the server and then with the onboard NIC to the switch. I can’t ping the server form any workstations and I am sure it is not an IP problem. I gave the second NIC the same address as the onboard and disabled the onboard. Same problem. I also tried another port on the switch and it is a no go. I changed the IP in the ADSL modem to the same range as the network and plugged it into the switch thus bypassing the server. So now I got my client up and running for internet but still didn’t solve the comms problem with the server. Offline files also don’t work now and it I create a new user on the server and try and log in with it on a workstation it says sorry. I also a weird one, I can browse the share on the server. I’m totally confused. Help?
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Have you set up all workstations with static IPs in the range allowed by your Server and router?
    Note: you obviously require subnet mask (automatically comes, but must be the same as Server) and also the default Gateway (the router basically)
    Sometimes DNS must be assigned too (from the ISP)
  3. cmatthee

    cmatthee TS Rookie Topic Starter

    All the pc are configured with static Ip's and it is still the same as what it was before when it worked.
  4. cmatthee

    cmatthee TS Rookie Topic Starter

    some other guy said someting about active directory repair. :eek:
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    To check TCP/IP settings, use ipconfig /all command line. The part of the result looks like below.

    IP Address. . . . . . . . . . .. . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . :
    DHCP Server . . . . . . . . . . . :
    DNS Servers . . . . . . . . . .. . :

    1. Make sure you have correct IP range.
    2. Make sure the Subnet Mask is the same of the router.
    3. Make sure you have correct default gateway.
    4. Make sure you have correct DNS.
    5. Make sure no filtering in the router to block the Internet access.

    If you do have correct TCP/IP and you can ping the pubic IP but not web, check the DNS settings.

    To open DNS, click Start, click Control Panel, double-click Administrative Tools, and then double-click DNS More info Here

    I'm thinking DNS and Wins not assigned

    Have you got any further results?
  6. jobeard

    jobeard TS Ambassador Posts: 11,169   +986

    If your server is running DNS, DHCP, or LDAP services AND the users are using
    network loging, then the server configuration will be in question.

    The server needs the static address and a well known name.
    The clients should access services and shares from a name, not an IP.
    The client addresses can be either static or DHCP and should not be part of your problem.

    If you have disabled one interface and moved the same IP config to another device
    on that server, then a 100% faithful copy of the IP settings should have been successful.
    (provided that you minimize the access by IP addresses to an absolute minimum).

    VERIFY that the Domain Controller, LDAP, and DNS avoid uses of the IP address
    wherever possible AND if you see references to Interface Names, then be cautious
  7. cmatthee

    cmatthee TS Rookie Topic Starter

    Ok. what is LDAP?

    1st network card on Server IP to network =
    Subnet mask =
    2nd network card on Server IP to ADSL =
    ADSL IP =

    All workstations is configured with static IPs 192.168.0.??
    Dns is configured on the server to point to for internet connection
    On all user profiles P: = my docs on server d: drive
    p: is mapped on all the workstations and all users can access the drive.
    All users now get errors when offline files try ro sync

    No internet!!! :confused:
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Please re-read my post above.
    It looks as though, you are running a DNS configured Server not DHCP or LDAP

    What is the ipconfig / all on the Server? (ideally post this in a reply)
    What is the ipconfig /displaydns on the Server

    Is this it: (actually using the /all will tell me both cards settings on the server)

    IP Address..........:
    Subnet Mask.......:
    Default Gateway..:
    DHCP Server.......:
    DNS Servers.......:

    What is the setting on the Workstations?

    Is this it:

    IP Address..........: 192.168.0.**
    Subnet Mask.......:
    Default Gateway..:
    DHCP Server.......:
    DNS Servers.......:

    This is the part I've made mistakes on too. Make sure the Domain Name ServerName is assigned a Name ie servername.domain.local (ie the DNS)

    I would like Jobeard to also add info here too. As yes, even though I eventually get there, Jobeard tends to get right to the point.
  9. k.jacko

    k.jacko TS Rookie Posts: 493

    If i've read this correctly, why do you want both nics operational on the same server?
    I only use one, that goes into the switch, as does the modem/router as do the workstations. That way everything gets access.
    I was told by our support company that sometimes the 2nd nic can be troublesome for certain configs.
    I have my server 2003 acting as a dhcp and dns server, all workstations are dhcp clients, only the 5 servers have static IPs.Everything works fine.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...