Windows 7 cannot find 'taskmgr.exe'

By SpaceCat · 7 replies
Apr 19, 2010
  1. Recently a problem appeared on my computer. I dunno why, but every time I try to call a task manager in any way computer shows error message: ["Windows cannot find 'C:\Windows\system32\taskmgr.exe'. Make sure you typed the name correctly, and then try again."] But when I go to C:\Windows\system32, I can see taskmgr.exe, but opening it triggers the same error. I tried to copy taskmgr.exe file from another computer, in which it worked, but it still doesn't run on my computer.
    Before this problem started I defragmented the disk and messed with Advanced SystemCare Pro a bit, so maybe that is what caused this problem, or maybe it is some kind a virus.

    I'm running Windows 7 64x, using Kaspersky internet security.

    I looked around a internet a bit, but I haven't found any solutions for this kind of problem yet

    So, can anyone help?
  2. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Try System Restore. Go to a point before you messed with Advanced SystemCare.
  3. SpaceCat

    SpaceCat TS Rookie Topic Starter Posts: 34

    Well there is a problem. I was messing with Advanced SystemCare on 2010.04.16, while earliest restoration point is on 2010.04.18. There is a restore function in ASC too, but it doesn't help in this case.
    Isn't there any way to repair this problem manually?
  4. Leonidas1

    Leonidas1 TS Rookie

    If I´m on time try following (because I had the same error and have resolved):
    1. Download sysinternals suite from microsoft technet and unpack.
    2. Find and run procexp.exe.
    3. Click in Options menu on Replace Task Manager and than Restore Task Manager.
    4. Click Ctrl+Alt+Del or on taskbar Run Taskmanager.
    Settings are restored and MS Taskmanager works fine. Because of my habit I can´t work without sysinternals. Enjoy!
  5. CAMusing

    CAMusing TS Enthusiast Posts: 179

  6. webscaper

    webscaper TS Rookie Posts: 51

    If you think the taskmgr.exe file is corrupted then use the system file checker
  7. SpaceCat

    SpaceCat TS Rookie Topic Starter Posts: 34

    Clicking on Replace Task Manager doesn't seem to do something, Restore Task Manager button doesn't appear.

    My task manager isn't disabled by an Administrator

    scf/scannow says that a problem has been found, but cannot be fixed (or something like this)

    Why there are such stupid errors in Windows 7 anyway?

    EDIT: I just found out that regedit.exe has same issue as taskmgr.exe. This really starts to look like a virus, what program should I use to get rid of such viruses.

    I also tried to get rid of this problem by using repair windows function on windows cd, but it says something like that Windows versions on my Pc is different from the one on cd, so it cannot be repaired. Guess this is because of updates
  8. LAconditioner

    LAconditioner TS Rookie

    procexp replacing taskmgr

    i had the same problem.

    my taskmgr wouldn't launch and i get the same error described.

    the only thing i changed was this "Replace Task Manager" option in the procexp menu.

    Try checking that option on and launch task manager. If the error shows up, uncheck the option and launch task manager again. Repeat once if error keeps showing up.

    I think repairing Windows 7 may not even solve this. Something taskmgr.exe needs to start could not be found before I turned that procexp option off and back on again...

    Good luck!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...