Windows 7 not booting!

By Habylab ยท 12 replies
May 15, 2009
  1. Can't boot into Windows 7 at the moment. "required boot device was not found" AutoFix not fixing it!


    Come on....
  2. fastco

    fastco TS Booster Posts: 1,123

    Download and use a Hiren's Boot CD, boot from the cd and Run the (disk tools) repair the Master Boot record. If that doesn't get it going try a reformat and reinstall Windows 7
  3. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Doesn't that CD cost money?

    I'd say the reformat (meaning remove partition to be exact) would be a lot easier ;)
  4. Habylab

    Habylab TS Rookie Topic Starter Posts: 263

    It would be, but another week of installing apps? I have exams too...
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Hmm fix Windows 7 Boot loader :rolleyes:

    Vista had an excellent boot menu for this
    But I'll tell you the truth I'm not testing Windows 7, so I have no idea what prompts you get when the DVD boots up.

    But in any case, it's requested to remove the Partition before installing Windows 7
    I suspect the Windows 7 DVD has this startup option, just like previous versions of Windows discs.
  6. Habylab

    Habylab TS Rookie Topic Starter Posts: 263

    I did. Windows 7 was running fine. Needed more room, so I deleted another partion installed my Acronis TrueImage, when I was using it. I don't use it anymore, so i thought there was no harm in deleting it!

    Also, in XP i can't access some files, due to the permissions that i set in windows 7. Stupid system it is, I have no desktop now!

    @fastco Could you be more specific about which tool to run, as there are 50+ to choose from!

    EDIT: Going to get a picture of the errror now...
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    7 has the same repair utilities as Vista on the DVD. Does that "AutoFix" mean the startup repair option won't fix it?

    If that's the case, I think you deleted the partition where the boot files were. That can be fixed by going to the command prompt in 7's repair utility and using diskpart to set another partition active. Then the "startup repair" option should be able to detect that the boot loader is missing and fix it.
  8. fastco

    fastco TS Booster Posts: 1,123

    NO Kimsland it's free, I just downloaded the latest copy and it's loaded with tools. I have used the memory test tools before and they were pretty good.

    **Habylab, BootFix Utility >>Run this utility if you get 'Invalid system disk'
  9. Habylab

    Habylab TS Rookie Topic Starter Posts: 263

    Could you be more spcific, like how I get into the Repair utility and diskpart. Using the disc?

    If you mean going to the recovery console, it asks for the admins password. I tried mine and it doesn't work. Is that what you mean?
  10. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Boot with the Windows disc like you would when installing the OS. Select "Repair your computer" from the setup screen where you'd normally click "Install now".

    If I remember correctly, there's an automatic repair attempt first, but you should get to the repair menu after that where one of the options is command prompt.

    In command prompt type diskpart, then select the partition where you want to create the boot files (if you have more than one hdd you need to select the disk first, obviously).

    One example for the commands would be list disk -> select disk 1 -> list partition -> select partition 1 -> active -> exit.

    That would mark the first partition of the second disk as active (list commands aren't required, they're just for making sure you're not selecting wrong things).

    Then you can try the normal startup repair in the repair menu again.
  11. Habylab

    Habylab TS Rookie Topic Starter Posts: 263

    I will try that. Using XP now. It is actually noticably slower. Boy did 7 screw it up though!!! Its reset my XP desktop, which is a pain!

    It worked!! Didn't even need to do what you said. It managed an autofix. Looked through the log, and tcip.sys was corrupt. How didn't it find that before?
  12. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Um thanks for reviving an old thread (and another one as well I see made in 2007) with that (your?) "blogspot"
    Ironically after reading it (god know why I did) it stated the fix was to wait :confused:
    Oh I see, that's great :/

    If anyone else has problems with No POST, have a look here ;) Tutorial: No POST (Power On Self Test)

    Edit: Actually your posting on many old threads, some close to 6 months old ?

    Edit2: Note I was replying to member mentormatt8 (in case his post(s) gets removed ;))
  13. mentormatt8

    mentormatt8 TS Rookie

    Kimsland, Yes, amazing, sometimes all you need is patience. At least that is what solved my problem. Hopefully it will be useful to the members as well, so they don't ALWAYS have to go through the hoops.

    I know, sometimes doing NOTHING really works.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...