Windows and/or hard drive corrupted or something else?

Strange. Two years ago my PC with Samsung 840 EVO 1 TB got corrupted somehow. Impossible to fix Windows, so I bought a completely new computer and a new C: drive, Samsung 970 PRO 1 TB this time. Fresh install of Windows 10. Formatted the corrupted 840 drive, and to this day that old drive works fine. So it seems it was a software level corruption.

Yesterday something happened to my new computer with the 970 C: drive. I installed one thing, restarted the computer, and then everything was broken. Only simple programs like Thunderbird open. All other programs are corrupted, each producing different random errors (same error each time, but completely different error per program). So, I thought whatever, I'll recover to a week old incremental backup of whole C: and I did it (I have also older incremental backups). The recovery took a couple of hours and finished fine. However, now with the week old state, which worked fine before (because the corruption day was yesterday), the same random errors for programs are occurring!

So first thought, malware? But, I have been running Kaspersky Internet Security 2019 all the time, it shows absolutely no problems.

So one thought would be this must be a hardware problem. However, based on the problem 2 years back (completely different computer), I do not know if this might still be a data problem and not a hardware problem. Of course, how could it be that a recovered backup would be corrupted as well, when it worked fine at time of backup. Also, this new computer should be pretty good, only high quality components presumably.

Samsung Magician says Drive Health is GOOD (no signs of problems). No hints of any other problems I can think of, either.

What can I do to pinpoint the problem source?

"scandisk /sfc" didn't help (as usual, it says problems were fixed, but it makes no difference, as usual).
 
  • Thread Starter Thread Starter
  • #2
This might be a good clue:

On any working computer, a file like C:\Users\USER\AppData\Roaming\Microsoft\PowerPoint should show permissions in Properties / Security. However, on this broken computer, Security only shows "You must have Read permissions to view the properties of this object". This happens with many folders, however for example in the same folder, "Excel" does show the permissions normally. So permissions have corrupted for several random folders, I suspect. What can cause this?
 
  • Thread Starter Thread Starter
  • #3
Whoops, correcting a typo, I meant "sfc /scannow" there on the first message.

I did also

Dism.exe /online /cleanup-image /scanhealth

Dism.exe /online /cleanup-image /restorehealth


but didn't make any difference.
 
  • Thread Starter Thread Starter
  • #4
I got this solved, kind of. My hunch was correct, a bunch of random files did get file permissions messed up, causing lots of random problems. I recovered from backups again, this time not the newest backup but two incremental backups backwards. And problems were all gone. I confirmed, that backup didn't have the file permission problems. (I guess I had been using a broken Windows for a while without noticing, therefore I thought the newest backup should be faultless, but it wasn't.)
 

Cycloid Torus

Posts: 4,640   +1,444
Did you experience a sudden loss of power or spike? I would suspect that as a cause of data corruption - otherwise I would keep a close watch on my storage media and my RAM. In addition to good backup, thorough tests of RAM and storage using MEMTEST86 (7 hours or overnight on a loop) and the Samsung utility might be wise.