Windows not loading after dust cleaning

So, my problem is that my desktop is not loading once I start the computer.

The problem started after I dust cleaned my computer, I unplugged everything and cleaned everything. After I put everything back together it kept beeping, but it was a problem with the ram, so I took the ram out and put it bacck in one by one and it worked.

After this, when I started the computer it showed me this message: “Reboot and select proper Boot Device or Insert Boot Media in selected Boot device”

So I switched the boot priority to another one, it started after this and at first it showed a blue screen and the code was something like this (I don’t remember it perfectly): “switch boot device”.

After it restarted it repaired by itself, it finally started well, windows booted up, but when it opened some of the icons were missing and others showed the white rectangle, like the file is deleted.

And from there it turns the screen to a blue, and the taskbar keeps appearing and dissapearing, and from time to time the screen flickers like I refresh it.



What can I do?

Is the problem from the storage disk?

Will it fix if I reinstall windows?

Thanks for the help!
 

Kshipper

Posts: 898   +213
TechSpot Elite
Because you took it all apart and the problems started you have to think that operation is related to why you are having problems now. You uncovered one problem> the ram wasn't seated. Perhaps you have more than one bootable hard drive in there? If that is the case take another look and disconnect any extra drives you have in there as a test before you try to boot again. If it is Windows 10 it would normally be set to Windows Boot Manager as the first boot device in BIOS.
 

bazz2004

Posts: 1,883   +307
Taking everything apart for cleaning is rather ocd. There are air cans that will do most of what is needed. If you remove anything it's a good idea to take anti static precautions first. It's much easier with a tower than with a laptop.