Windows update problem KB892130

By Pazuzu ยท 8 replies
Mar 21, 2008
  1. I recently sorted out a problem with Firefox & IE7 & everything seems to be working with the exception of Windows Update. I am running XP home edition service pack 2.
    At first I could not get Microsoft Windows Installer 3.1 to install. I went to the windows download site & ran the downloaded .exe - this worked.
    I am left with a problem installing Windows Genuine Advantage Validation Tool (KB892130 ) I found a discusion on the Microsoft Discussion Group but it seems quite complicated.I wonder if there is a simpler solution?

    I hope it is acceptable to quote from another forum in this way.

    Microsoft Discussion Groups Home | Communities Home | Communities Worldwide

    KB892130 Failure: Another Solution in Windows Update | | Help

    David Arnstein 3/1/2006 11:02 PM PST

    Here is my experience with the KB892130 problem. I was able to defeat
    it. I don't know how useful this will be to the rest of you. I hope
    that my method works for some of you, at least.

    Actually, I will describe four methods that I tried. Only the fourth
    method worked for me, but perhaps there are useful clues present here.

    The computer is a Dell XPS, 2.5 years old. It uses Windows XP
    Professional, and I have applied service pack 2. I have applied all
    suggested updates from the "Windows Update" function that is built
    into Internet Explorer. Until 2006 February 28, that is. On that day,
    Windows Update ceased to function. I detail this in the section
    "Method 1," immediately following.

    This is what finally worked for me. Once again, I used the utility
    program PsExec from Sysinternals. But this time, I used it to execute the
    update.exe program. It succeeded!


    I don't remember if I rebooted or not. I ran Windows Update from IE,
    and it did not try to install KB892130 again. It successfully
    installed six patches from Microsoft. What a relief!

    I suspect that I still have a permisions problem lurking on my
    computer. I don't know if it is a registry key, a file, a directory,
    or some combination of these. I expect to make occasional use of
    PsExec in the future, too.

    Good luck to all of you! I hope to get some feedback and learn from
    David Arnstein | Have fun with your spams:
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    I am not sure what you are trying to do!

    Re-install the WGA Tool?

    Delete it?

    If Re-install is the choice, that update appears in Add/Remove programs. Is it there? If it isn't working right, remove it, reboot and then do an update.
  3. Pazuzu

    Pazuzu TS Booster Topic Starter Posts: 211

    I am trying to re-install Windows Genuine Advantage Validation Tool (KB892130 )

    It does not appear in Add/ Remove list.

    When I use windows update it checks & informs me that the WMG has already been downloaded to my computer & prompts me to select the item which will then be installed. Installation fails ( 4 attempts so far).
  4. CCT

    CCT TS Evangelist Posts: 2,653   +6

  5. Pazuzu

    Pazuzu TS Booster Topic Starter Posts: 211

    I tried the method 1 "Register the Wups2.dll file in Windows" & then tried to use windows Update - no change.

    when I tried the method " - save WUA to known location, browse,open & add the /wuforce switch it failed when I attempted to open the .exe Error message :- "wusetup.exe is not a valid Win 32 application"
  6. CCT

    CCT TS Evangelist Posts: 2,653   +6

    The following is a method often used to re-register your update dll's:

    > > > Try registering the following:
    > > >
    > > > Click Start, select Run and type (pressing enter after each one and wait for
    > > > the
    > > > success message):
    > > >
    > > > net.exe stop wuauserv
    > > > Press Ok
    > > >
    > > > Repeat for the following:
    > > > regsvr32 wuapi.dll
    > > > regsvr32 wups.dll
    > > > regsvr32 wuaueng.dll
    > > > regsvr32 wuaueng1.dll
    > > > regsvr32 wuweb.dll
    > > > regsvr32 jscript.dll
    > > > regsvr32 wucltui.dll
    > > > regsvr32 msxml3.dll
    > > > regsvr32 softpub.dll
    > > > regsvr32 atl.dll
    > > >
    > > > net.exe start wuauserv

    I also read that turning automatic updates OFF allowed many people to then manually update.
  7. Pazuzu

    Pazuzu TS Booster Topic Starter Posts: 211

    I turned off manual updates & folowed the instructions to update dll s . I downloaded a more recent MS validation tool & opted to try out "Silverlight" to see if this resolved the update problem. Windows Update still finds that my PC needs updates & then after downloads I get the same "installation failed" for KB892130. When I shut down I see that there are 81 updates to be installed - this happens every time so even though there appears an attempt to install it must be failing.

    I keep looking through the questions & problem solutions on the MSforums but they seem to go around in circles with nothing so far that works for my problem.
  8. CCT

    CCT TS Evangelist Posts: 2,653   +6

    It is possible, bacause you have had other 'problems' involving second party applications, that you have some kind of driver glitch.

    Try running sfc /scannow .

    Failing that, copy off your important stuff and reload everything.
  9. Pazuzu

    Pazuzu TS Booster Topic Starter Posts: 211

    I would like to "copy important stuff" & re- load everything. My fear is that I will overlook something which I later need to use - photos, email, bookmarks etc. I suppose the only really safe way would be to get a second PC & then check out that everything is working.
    I do have an external hard drive. Is there any other way to try to resolve " some kind of driver glitch" ?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...