Windows XP detects my flash drive as a DVD ROM

By monrayl ยท 10 replies
Oct 16, 2011
Post New Reply
  1. I put my flash drive into my pc yesterday and for some reason windows xp detected it as a dvd rom. This is the first time that this has ever happened. I am still able to open it and view the contents though. Can anyone help me?
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    You probably using a U3 flash driver from SanDisk?
  3. monrayl

    monrayl TS Member Topic Starter Posts: 66

    No, actually I'm using a Datatraveler from Kingston. When I check the properties, it says 'removable disk' on the general tab, but the icon is that of a dvd rom.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I just checked. That;s also a U3 drive!

    U3 drives play a "game" with Windows. They look like CD Rom with an autorun file that Windows opens and runs which then mounts the disk drive portion of U3

    The reason: that's how U3 drives fake out program launch functions (and if you ever turn off autoruns on your CD drives U3 drives won't work unless you manually click on the launch file)

    if you don't care about U3 (i.e. only want plain ol' file storage) there;s probably a tool on Kingston site to remove U3 so it behaves like a typical flash drive
  5. monrayl

    monrayl TS Member Topic Starter Posts: 66

    ok, I searched the Kingston site and I didn't find any helpful tools. The other thing is, I've had this flash drive for 4 years and I never had this problem before. I even tried formatting it, but that didn't help. When I put the flash drive in my sister's pc it showed up as an ordinary removable disk. What's the deal with that :confused:
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) OK. i know you can uninstall / reinstall U3 on SanDisk drives using SanDisk tools but looks like Kingston doesn't offer the option. If you google remove u3 kingston you'll find people post some methods, but i'd leave it alone as might ruin the drive and just live with U3 then

    2) The CD drive looks to the computer like a CDROM so it's write protected and just as you can't simply reformat a CDROM so too it is tricky to simply reformat a U3 drive. (After CDROM launched it looks to computer like both CDROM and disk drive)

    3) As to why you never saw it before I can only GUESS you just never noticed. Try again on your sister's PC and i'll bet you'll see both a new CD drive and removable disk listed on her devices

    /* EDIT */
    p.s. The CDROM "emulation" on the flash takes very little space so only advantage is having the flash run like a normal flash vs. U3. Not enough space reclaimed for U3 disk space to be an issue
  7. monrayl

    monrayl TS Member Topic Starter Posts: 66

    I just tried it in my sister's pc and it still just shows the removable disk icon, no cdrom icons. I just remembered something, not sure if it'll be of any help though, a couple of days ago I had a PnP Bios extension problem. I had to uninstall daemon tools to solve it. Could that have anything to do with it?
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I can't explain :confused:

    But if you click to open the "CD drive" on your computer, do you see 3 files?
    > Autorun.inf
    > LaunchU3.exe

    That's what i see on my U3 Sandisk on the "CD"
  9. monrayl

    monrayl TS Member Topic Starter Posts: 66

    Lol, none of those files are on my flash drive, I even unchecked the 'hide protected operating system files' option. I found the answer to this problem though :System restore! Thanks for all your help LookinAround. I appreciate it, even though I feel kinda dumb right now. Thanks man :grinthumb
  10. tweakboy

    tweakboy TS Guru Posts: 467

    This is funny thread.

    Dude the icon shows incorrectly. You need to delete your iconcache database so it re creates a new one and it should show correctly now. Let me know... gl
  11. monrayl

    monrayl TS Member Topic Starter Posts: 66

    I think you were right tweakboy. Sorry if I wasted anyone's time :).

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...