Windows XP Pro Remote Desktop

By tonyfelloni ยท 12 replies
Jul 22, 2008
  1. Hi All

    I have recently followed a guide on the net relating to setting up IIS on my Xp pro machine to allow remote desktop connections to be made to it through a web browser. I followed the guide to a T but i still cant connect through my web browser both inside or outside the LAN.
    I type in htp://computer_name/tsweb from inside the lan but nothing comes up.

    When I try to connect to the XP machine using remote desktop on another machine inside the LAN then the connection works. I can also connect to the other computer using the xp machine.

    Any ideas what I need to do to get it all running so I have remote desktop access through my IE browser (latest version)?
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Try this from Start-->Run--> CMD window (followed by enter key on each line)

    ipconfig /release
    ipconfig /flushdns
    ipconfig /registerdns
    ipconfig /renew
    net stop "DNS Client"
    net start "DNS Client"

    Or remove any TCP/IP settings in your network (make sure to write them all down first, in case of reverting back)
  3. tonyfelloni

    tonyfelloni TS Rookie Topic Starter

    Thanks for that, i'll give it a lash later when I get home

  4. surfersaiyan

    surfersaiyan TS Enthusiast Posts: 100

    do you just want access to your stuff remotely or do you wanna access another computer where a user will be present, as in a kinda helpdesk scenario.

    i often help my technophobe folks overseas with simple stuff by using a program called 'crossloops' to 'take over' their computer and make any necessary changes.

    super simple to setup, works a charm. just needs installing on both.

    maybe i got the wrong end of the stick. always found Windows XP Pro Remote Desktop a bit of a pain.
  5. tonyfelloni

    tonyfelloni TS Rookie Topic Starter

    Hi surfersaiyan

    No I want to access my desktop through any browser, do not have privilages to install anything on the work side and I dont want to have to get anyone on the other side to accept a connection.

    The way i'm going is sound, only trouble is it isnt working!


  6. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    Have you enabled the Remote Desktop Service?

    Contorl Panel> Administrative Tools> Service> right click> Properties on each Service below and set as follows:

    Remote Access Auto connect Manager> set Start mode to Manual
    Telephony> Set to Manual
    Plug & Play> set to Manual
    Remote Desktop Help Session Manager> set to Manual
    Rashman> set to Manual


    Reset Remote Access Auto Connection Manager to Automatic. Service should already be started.

    RPC- Remote Proceedure Call should already be set to Automatic and many Services need it to run
    RPC Locator can be set to Manual
    Workstation should already be set to Automatic. If it is not, set it to Manual and include it in the group before you reboot. Service will start on boot.

    The one main part of Services is checking the Dependency tab. Services that are needed to start a particular Service must already be on Manual or Automatic. Be using the Manual settings first, then rebooting, the Service will be able to start. If you want to change any from Manual to Automatic, do that AFTER the reboot when the Services have already started.

    NOTE: If any of the Services I've told you to set to Manual are already set to Automatic, leave them set that way.
  7. tonyfelloni

    tonyfelloni TS Rookie Topic Starter

    Hi Guys

    Cheers for the help, I can now access the remote desktop through my web browser from inside the LAN, now I have one final hurdle. To get access from anywhere on the net, which isnt working yet.

    I have set up the desktop web access on port XX, i have opened up this port XX in my windows firewall, I have also set up port forwarding on my router to the XP laptop on port XX

    I get the following message when I attempt to connect from the internet (through web warper)

    HTTP Error
    Cannot load the page at the address

    Cannot connect to Web-server "XXX.XXX.XXX.XXX"

    Any Ideas?

  8. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    Tony, I am not experienced in 'port' handling. Hopefully someone who is will stop by and help.
  9. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Isn't it:

    Cannot load the page at the address

    I could be wrong :confused:
  10. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    I think there is a syntax error here: Note the "hpt" instead of "http".
  11. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    4 posts so he needed to write htp

    Also RIES does that, it resets everything in IE
    Um unrelated to here!
  12. tonyfelloni

    tonyfelloni TS Rookie Topic Starter

    Hey All

    Many thinks for taking your time to help me out, its all working perfectly now after much perseverance.

    Best Wishes


    I think webwarper was the issue, got a friend to try it from his pc and it all looks good to go.
  13. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    You're welcome. Thanks for letting us know.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...